aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-09-04 22:25:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-09-04 22:25:41 +0000
commit4d78a5a7688b905fb4d48fe1aab74ed2af538dc3 (patch)
tree285554f6baa93915611d4282f0051d2d11b4a12b /graphics/freeimage
parent13d3016b1cb20de52346fa4f5293a3118836cd3a (diff)
downloadports-4d78a5a7688b905fb4d48fe1aab74ed2af538dc3.tar.gz
ports-4d78a5a7688b905fb4d48fe1aab74ed2af538dc3.zip
Notes
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile25
-rw-r--r--graphics/freeimage/distinfo2
-rw-r--r--graphics/freeimage/files/patch-Makefile60
-rw-r--r--graphics/freeimage/pkg-descr7
-rw-r--r--graphics/freeimage/pkg-plist4
5 files changed, 98 insertions, 0 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
new file mode 100644
index 000000000000..229b4b19475e
--- /dev/null
+++ b/graphics/freeimage/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: freeimage
+# Date created: 2005-09-01
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= freeimage
+PORTVERSION= 3.7.0
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= FreeImage${PORTVERSION:S/.//g}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= An open source graphics library
+
+WRKSRC= ${WRKDIR}/FreeImage
+USE_GMAKE= yes
+USE_ZIP= yes
+# convert CRLF to LF for gcc-2.95
+EXTRACT_BEFORE_ARGS= -qoa
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
new file mode 100644
index 000000000000..314bde2e7777
--- /dev/null
+++ b/graphics/freeimage/distinfo
@@ -0,0 +1,2 @@
+MD5 (FreeImage370.zip) = 3bfa59d6b6ea2a6fad024d9223d97dfb
+SIZE (FreeImage370.zip) = 2377410
diff --git a/graphics/freeimage/files/patch-Makefile b/graphics/freeimage/files/patch-Makefile
new file mode 100644
index 000000000000..4a26d1dcc7db
--- /dev/null
+++ b/graphics/freeimage/files/patch-Makefile
@@ -0,0 +1,60 @@
+--- Makefile.orig Tue May 3 18:53:46 2005
++++ Makefile Mon Sep 5 00:21:22 2005
+@@ -4,27 +4,27 @@
+ include Makefile.srcs
+
+ # General configuration variables:
+-CC = gcc
+-CXX = g++
++CC ?= gcc
++CXX ?= g++
+ AR = ar
+
+-INSTALLDIR = /usr/lib
++INSTALLDIR = ${PREFIX}/lib
+
+ # Converts cr/lf to just lf
+ DOS2UNIX = dos2unix
+
+-COMPILERFLAGS = -O3
++COMPILERFLAGS := ${CFLAGS}
+ LIBRARIES = -lstdc++
+
+ MODULES = $(SRCS:.c=.o)
+ MODULES := $(MODULES:.cpp=.o)
+-CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
+-CXXFLAGS = $(COMPILERFLAGS) -Wno-ctor-dtor-privacy $(INCLUDE)
++CFLAGS = $(COMPILERFLAGS) -fPIC $(INCLUDE)
++CXXFLAGS = $(COMPILERFLAGS) -fPIC -Wno-ctor-dtor-privacy $(INCLUDE)
+
+ TARGET = freeimage
+ STATICLIB = lib$(TARGET).a
+-SHAREDLIB = lib$(TARGET)-$(VER_MAJOR).$(VER_MINOR).so
+-LIBNAME = lib$(TARGET).so.$(VER_MAJOR)
++SHAREDLIB = lib$(TARGET).so.$(VER_MAJOR)
++LIBNAME = lib$(TARGET).so
+
+
+
+@@ -34,7 +34,7 @@
+
+ dist: FreeImage
+ cp *.a Dist
+- cp *.so Dist
++ cp *.so.* Dist
+ cp Source/FreeImage.h Dist
+
+ dos2unix:
+@@ -55,10 +55,9 @@
+ $(CC) -s -shared -Wl,-soname,$(LIBNAME) -o $@ $(MODULES) $(LIBRARIES)
+
+ install:
+- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
+- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
++ install -m 644 -o root -g wheel $(STATICLIB) $(INSTALLDIR)
++ install -m 755 -o root -g wheel $(SHAREDLIB) $(INSTALLDIR)
+ ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(LIBNAME)
+- ldconfig
+
+ clean:
+ rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/graphics/freeimage/pkg-descr b/graphics/freeimage/pkg-descr
new file mode 100644
index 000000000000..178aea424e0a
--- /dev/null
+++ b/graphics/freeimage/pkg-descr
@@ -0,0 +1,7 @@
+FreeImage is an Open Source library project for developers who would like to
+support popular graphics image formats like PNG, BMP, JPEG, TIFF and others as
+needed by today's multimedia applications. FreeImage is easy to use, fast,
+multithreading safe, compatible with all 32-bit versions of Windows, and
+cross-platform (works both with Linux and Mac OS X).
+
+WWW: http://freeimage.sf.net
diff --git a/graphics/freeimage/pkg-plist b/graphics/freeimage/pkg-plist
new file mode 100644
index 000000000000..f38d451a1ce0
--- /dev/null
+++ b/graphics/freeimage/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+lib/libfreeimage.a
+lib/libfreeimage.so
+lib/libfreeimage.so.3