aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2008-03-17 11:16:52 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2008-03-17 11:16:52 +0000
commit86a19a3a0b8e2fc098361207fb51a2ebf6bd5522 (patch)
tree32fe8f60cd083c9b2f8f0480d1af4b955d9ed7e0 /graphics/freeimage
parent8e08e2697ffcbb9649dd82d46120b04c8c73ec11 (diff)
downloadports-86a19a3a0b8e2fc098361207fb51a2ebf6bd5522.tar.gz
ports-86a19a3a0b8e2fc098361207fb51a2ebf6bd5522.zip
Notes
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile2
-rw-r--r--graphics/freeimage/distinfo6
-rw-r--r--graphics/freeimage/files/patch-Makefile.gnu14
3 files changed, 11 insertions, 11 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index 46b7a00b5d6e..3e4c28c7055d 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= freeimage
-PORTVERSION= 3.9.3
+PORTVERSION= 3.10.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index c5f31a09ed38..c33c9bb7f99b 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,3 +1,3 @@
-MD5 (FreeImage393.zip) = bf3574fa4e6135cf511d5ff4bc871ec3
-SHA256 (FreeImage393.zip) = 59f6b75d778e40eff7cb4068e556c65230f9fe1af8d17ad74fec48f334a34fc0
-SIZE (FreeImage393.zip) = 2507055
+MD5 (FreeImage3100.zip) = 2e57135e26bb487cc8e13ee7b7e0a595
+SHA256 (FreeImage3100.zip) = 17705bd58f31edbd315ebeeb308800f3a516156bec942c00c55fe8c0c85d9cb4
+SIZE (FreeImage3100.zip) = 3379388
diff --git a/graphics/freeimage/files/patch-Makefile.gnu b/graphics/freeimage/files/patch-Makefile.gnu
index 16e2615cb3d9..b527b0e12dc4 100644
--- a/graphics/freeimage/files/patch-Makefile.gnu
+++ b/graphics/freeimage/files/patch-Makefile.gnu
@@ -1,5 +1,5 @@
---- Makefile.gnu.orig Sun Mar 11 02:46:54 2007
-+++ Makefile.gnu Sun Mar 11 02:53:21 2007
+--- Makefile.gnu.orig 2007-08-25 18:44:24.000000000 +0900
++++ Makefile.gnu 2008-03-17 14:49:16.000000000 +0900
@@ -4,27 +4,27 @@
include Makefile.srcs
@@ -18,7 +18,7 @@
# Converts cr/lf to just lf
DOS2UNIX = dos2unix
--COMPILERFLAGS = -O3 -fPIC
+-COMPILERFLAGS = -O3 -fPIC -fexceptions -fvisibility=hidden
+COMPILERFLAGS := ${CFLAGS}
LIBRARIES = -lstdc++
@@ -45,19 +45,19 @@
cp Source/FreeImage.h Dist
dos2unix:
-@@ -58,12 +58,11 @@
+@@ -58,12 +58,10 @@
$(CC) -s -shared -Wl,-soname,$(VERLIBNAME) -o $@ $(MODULES) $(LIBRARIES)
install:
- install -m 644 -o root -g root $(HEADER) $(INCDIR)
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
+- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
+- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
+- ldconfig
+ install -m 644 -o root -g wheel $(HEADER) $(INCDIR)
+ install -m 644 -o root -g wheel $(STATICLIB) $(INSTALLDIR)
+ install -m 755 -o root -g wheel $(SHAREDLIB) $(INSTALLDIR)
- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
-- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
-- ldconfig
+ ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
clean: