aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeimage
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-24 21:12:05 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-24 21:12:05 +0000
commitaef10e4bd1da6f8e8e8eb94dd6319eb4c5093d0d (patch)
treea26b0d09ccf0ea8d06cf543be7450ca8f5a7c66e /graphics/freeimage
parenta9cdff2007c7ff0ac2ae36f57491d96d654a55a0 (diff)
downloadports-aef10e4bd1da6f8e8e8eb94dd6319eb4c5093d0d.tar.gz
ports-aef10e4bd1da6f8e8e8eb94dd6319eb4c5093d0d.zip
- Update to 3.11.0
Notes
Notes: svn path=/head/; revision=220728
Diffstat (limited to 'graphics/freeimage')
-rw-r--r--graphics/freeimage/Makefile9
-rw-r--r--graphics/freeimage/distinfo6
-rw-r--r--graphics/freeimage/files/patch-Makefile.gnu21
-rw-r--r--graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp20
-rw-r--r--graphics/freeimage/files/patch-Source-Metadata_Exif.cpp11
5 files changed, 17 insertions, 50 deletions
diff --git a/graphics/freeimage/Makefile b/graphics/freeimage/Makefile
index e1b9791e2baa..230c8a86579b 100644
--- a/graphics/freeimage/Makefile
+++ b/graphics/freeimage/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= freeimage
-PORTVERSION= 3.10.0
+PORTVERSION= 3.11.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= FreeImage${PORTVERSION:S/.//g}
MAINTAINER= gahr@FreeBSD.org
@@ -27,4 +26,8 @@ PLIST_FILES= include/FreeImage.h \
lib/libfreeimage.so \
lib/libfreeimage.so.3
+post-patch:
+ ${FIND} ${WRKSRC} -type f -print0 | ${XARGS} -0 ${REINPLACE_CMD} -e 's|<malloc\.h>|<stdlib.h>|g'
+ ${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/Makefile.gnu
+
.include <bsd.port.mk>
diff --git a/graphics/freeimage/distinfo b/graphics/freeimage/distinfo
index c33c9bb7f99b..06e039627588 100644
--- a/graphics/freeimage/distinfo
+++ b/graphics/freeimage/distinfo
@@ -1,3 +1,3 @@
-MD5 (FreeImage3100.zip) = 2e57135e26bb487cc8e13ee7b7e0a595
-SHA256 (FreeImage3100.zip) = 17705bd58f31edbd315ebeeb308800f3a516156bec942c00c55fe8c0c85d9cb4
-SIZE (FreeImage3100.zip) = 3379388
+MD5 (FreeImage3110.zip) = ad1db36414391417654ba7bf1c0277d3
+SHA256 (FreeImage3110.zip) = 84021b8c0b86e5801479474ad9a99c18d121508ee16d363e02ddcbf24195340c
+SIZE (FreeImage3110.zip) = 4250382
diff --git a/graphics/freeimage/files/patch-Makefile.gnu b/graphics/freeimage/files/patch-Makefile.gnu
index b527b0e12dc4..7f8ac1a92a4c 100644
--- a/graphics/freeimage/files/patch-Makefile.gnu
+++ b/graphics/freeimage/files/patch-Makefile.gnu
@@ -1,6 +1,6 @@
---- Makefile.gnu.orig 2007-08-25 18:44:24.000000000 +0900
-+++ Makefile.gnu 2008-03-17 14:49:16.000000000 +0900
-@@ -4,27 +4,27 @@
+--- Makefile.gnu.orig 2008-09-24 22:28:31.000000000 +0200
++++ Makefile.gnu 2008-09-24 22:34:35.000000000 +0200
+@@ -4,17 +4,17 @@
include Makefile.srcs
# General configuration variables:
@@ -12,8 +12,8 @@
-INCDIR = /usr/include
-INSTALLDIR = /usr/lib
-+INCDIR = ${PREFIX}/include
-+INSTALLDIR = ${PREFIX}/lib
++INCDIR = %%PREFIX%%/include
++INSTALLDIR = %%PREFIX%%/lib
# Converts cr/lf to just lf
DOS2UNIX = dos2unix
@@ -23,11 +23,7 @@
LIBRARIES = -lstdc++
MODULES = $(SRCS:.c=.o)
- MODULES := $(MODULES:.cpp=.o)
--CFLAGS = $(COMPILERFLAGS) $(INCLUDE)
--CXXFLAGS = $(COMPILERFLAGS) -Wno-ctor-dtor-privacy $(INCLUDE)
-+CFLAGS = $(COMPILERFLAGS) -fPIC $(INCLUDE)
-+CXXFLAGS = $(COMPILERFLAGS) -fPIC -Wno-ctor-dtor-privacy $(INCLUDE)
+@@ -24,7 +24,7 @@
TARGET = freeimage
STATICLIB = lib$(TARGET).a
@@ -53,12 +49,11 @@
- install -m 644 -o root -g root $(STATICLIB) $(INSTALLDIR)
- install -m 755 -o root -g root $(SHAREDLIB) $(INSTALLDIR)
- ln -sf $(SHAREDLIB) $(INSTALLDIR)/$(VERLIBNAME)
-- ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
-- ldconfig
+ install -m 644 -o root -g wheel $(HEADER) $(INCDIR)
+ install -m 644 -o root -g wheel $(STATICLIB) $(INSTALLDIR)
+ install -m 755 -o root -g wheel $(SHAREDLIB) $(INSTALLDIR)
-+ ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
+ ln -sf $(VERLIBNAME) $(INSTALLDIR)/$(LIBNAME)
+- ldconfig
clean:
rm -f core Dist/*.* u2dtmp* $(MODULES) $(STATICLIB) $(SHAREDLIB) $(LIBNAME)
diff --git a/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp b/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp
deleted file mode 100644
index 619c057fdf83..000000000000
--- a/graphics/freeimage/files/patch-Source-FreeImage_PluginBMP.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- Source/FreeImage/PluginBMP.cpp.orig 2008-06-13 00:40:16.000000000 +0200
-+++ Source/FreeImage/PluginBMP.cpp 2008-06-13 00:46:51.000000000 +0200
-@@ -224,7 +224,7 @@
- throw(1);
- }
- if (status_byte != 0) {
-- status_byte = MIN(status_byte, end - q);
-+ status_byte = MIN((size_t)status_byte, (size_t)(end - q));
- // Encoded mode
- if(io->read_proc(&second_byte, sizeof(BYTE), 1, handle) != 1) {
- throw(1);
-@@ -279,7 +279,7 @@
- default:
- {
- // Absolute mode
-- status_byte = MIN(status_byte, end - q);
-+ status_byte = MIN((size_t)status_byte, (size_t)(end - q));
- for (int i = 0; i < status_byte; i++) {
- if ((i & 0x01) == 0) {
- if(io->read_proc(&second_byte, sizeof(BYTE), 1, handle) != 1) {
diff --git a/graphics/freeimage/files/patch-Source-Metadata_Exif.cpp b/graphics/freeimage/files/patch-Source-Metadata_Exif.cpp
deleted file mode 100644
index 2bc8c56c6688..000000000000
--- a/graphics/freeimage/files/patch-Source-Metadata_Exif.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- Source/Metadata/Exif.cpp.orig 2008-06-13 16:09:38.000000000 +0200
-+++ Source/Metadata/Exif.cpp 2008-06-13 16:10:15.000000000 +0200
-@@ -495,7 +495,7 @@
- }
-
- // remember that we've visited this directory so that we don't visit it again later
-- DWORD visited = (((DWORD)ifdp & 0xFFFF) << 16) | (DWORD)de;
-+ DWORD visited = (((size_t)ifdp & (size_t)0xFFFF) << 16) | (DWORD)de;
- if(visitedIFD.find(visited) != visitedIFD.end()) {
- continue;
- } else {