aboutsummaryrefslogtreecommitdiff
path: root/graphics/frei0r-plugins
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-06-29 15:15:08 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-06-29 15:15:08 +0000
commit570727393615a5b064247c78060e7cea45c04f5a (patch)
treeaef413f32bcf655c9f866d417ceb1c236292c5d5 /graphics/frei0r-plugins
parent0d91efac3a764bc056f60ed9f6ea1756092a9a09 (diff)
Notes
Diffstat (limited to 'graphics/frei0r-plugins')
-rw-r--r--graphics/frei0r-plugins/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/graphics/frei0r-plugins/Makefile b/graphics/frei0r-plugins/Makefile
new file mode 100644
index 000000000000..3d7772350cbc
--- /dev/null
+++ b/graphics/frei0r-plugins/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: frei0r-plugins
+# Date created: 29 June 2011
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+PKGNAMESUFFIX= -plugins
+MASTER_SITES= # empty
+DISTFILES= # empty
+EXTRACT_ONLY= # empty
+
+COMMENT= Frei0r meta-port
+
+RUN_DEPENDS= ${LOCALBASE}/include/frei0r.h:${PORTSDIR}/graphics/frei0r
+
+MASTERDIR= ${.CURDIR}/../frei0r
+NO_BUILD= yes
+PLIST= ${WRKDIR}/PLIST
+
+BUILDING_FREI0R_METAPORT= yes
+
+OPTIONS= GAVL "Install gavl plugins" on \
+ OPENCV "Install OpenCV plugins" on
+
+.include "${MASTERDIR}/Makefile"
+
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_GAVL)
+RUN_DEPENDS+= ${LOCALBASE}/lib/frei0r-1/rgbparade.so:${PORTSDIR}/graphics/frei0r-plugins-gavl
+.endif
+
+.if !defined(WITHOUT_OPENCV)
+RUN_DEPENDS+= ${LOCALBASE}/lib/frei0r-1/facedetect.so:${PORTSDIR}/graphics/frei0r-plugins-opencv
+.endif
+
+do-install:
+ @${DO_NADA}
+
+.include <bsd.port.mk>