aboutsummaryrefslogtreecommitdiff
path: root/graphics/frei0r
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-12-20 09:06:19 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-12-20 09:06:19 +0000
commitcdd929a0b99258aa6ae8c1a6ace113d7e8280585 (patch)
tree7dc5b073bd53694425ddc431c579e5405340cf67 /graphics/frei0r
parent52795398fe1d40091929572e6d4b154bb45fe55f (diff)
downloadports-cdd929a0b99258aa6ae8c1a6ace113d7e8280585.tar.gz
ports-cdd929a0b99258aa6ae8c1a6ace113d7e8280585.zip
graphics/frei0r-plugins-opencv: prepare for OpenCV 3.4.7
Notes
Notes: svn path=/head/; revision=558733
Diffstat (limited to 'graphics/frei0r')
-rw-r--r--graphics/frei0r/Makefile3
-rw-r--r--graphics/frei0r/files/extra-patch-src_filter_facebl0r_facebl0r.cpp10
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
index 00228640bf81..4a6b77dce8cf 100644
--- a/graphics/frei0r/Makefile
+++ b/graphics/frei0r/Makefile
@@ -23,7 +23,8 @@ IGNORE= cannot build OpenCV and gavl plugins simultaneously
.if defined(BUILDING_FREI0R_OPENCV) || defined(BUILDING_FREI0R_GAVL)
EXTRA_PATCHES= ${PATCHDIR}/extra-patch-frei0r-plugins \
- ${PATCHDIR}/extra-patch-src_filter_facedetect_CMakeLists.txt
+ ${PATCHDIR}/extra-patch-src_filter_facedetect_CMakeLists.txt \
+ ${PATCHDIR}/extra-patch-src_filter_facebl0r_facebl0r.cpp
USES+= localbase
.endif
diff --git a/graphics/frei0r/files/extra-patch-src_filter_facebl0r_facebl0r.cpp b/graphics/frei0r/files/extra-patch-src_filter_facebl0r_facebl0r.cpp
new file mode 100644
index 000000000000..ad29a784c180
--- /dev/null
+++ b/graphics/frei0r/files/extra-patch-src_filter_facebl0r_facebl0r.cpp
@@ -0,0 +1,10 @@
+--- src/filter/facebl0r/facebl0r.cpp.orig 2020-12-20 08:53:32 UTC
++++ src/filter/facebl0r/facebl0r.cpp
+@@ -19,6 +19,7 @@
+ #include <stdlib.h>
+ #include <opencv/cv.h>
+ #include <opencv/highgui.h>
++#include <opencv2/imgproc.hpp>
+
+ #include <frei0r.hpp>
+ #include <frei0r_math.h>