aboutsummaryrefslogtreecommitdiff
path: root/graphics/ftgl
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 17:45:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-04-01 17:45:58 +0000
commit0f935e5714d67e93833cd5a66de337339783f1af (patch)
treed585ffdbe5516f7f28d919da11cf63ab26a4f278 /graphics/ftgl
parent3815fb13b2ef807a15821e8832d1df0926369871 (diff)
downloadports-0f935e5714d67e93833cd5a66de337339783f1af.tar.gz
ports-0f935e5714d67e93833cd5a66de337339783f1af.zip
Notes
Diffstat (limited to 'graphics/ftgl')
-rw-r--r--graphics/ftgl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index de5c725669c9..f23ce3597128 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ftgl
DISTVERSION= 2.1.3-rc5
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/FTGL%20Source/2.1.3%7Erc5
@@ -11,6 +11,9 @@ MASTER_SITES= SF/${PORTNAME}/FTGL%20Source/2.1.3%7Erc5
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= OpenGL FreeType fonts rendering library
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
GNU_CONFIGURE= yes
@@ -19,7 +22,6 @@ CONFIGURE_ARGS= --with-gl-inc="${LOCALBASE}/include" \
USES= pathfix gmake libtool
USE_GL= gl glu
USE_XORG= x11 xext xmu
-INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/-/~/}
@@ -28,4 +30,7 @@ post-patch:
@${REINPLACE_CMD} -e '/SUBDIRS/ s|docs||; /SUBDIRS/ s|demo||' \
${WRKSRC}/Makefile.in
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libftgl.so
+
.include <bsd.port.mk>