aboutsummaryrefslogtreecommitdiff
path: root/graphics/fv/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 21:08:22 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 21:08:22 +0000
commit70e175ed96eb4254bd1457cda38601b72a125a0e (patch)
treeec56efa85c0d4eaf0ec38a1cc9f6317b65ac20dc /graphics/fv/Makefile
parent889ec1900a289f6ab6b3903efaae7f3021391329 (diff)
downloadports-70e175ed96eb4254bd1457cda38601b72a125a0e.tar.gz
ports-70e175ed96eb4254bd1457cda38601b72a125a0e.zip
Notes
Diffstat (limited to 'graphics/fv/Makefile')
-rw-r--r--graphics/fv/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
new file mode 100644
index 000000000000..9d94102e5ac7
--- /dev/null
+++ b/graphics/fv/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: fv
+# Date created: 07 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fv
+PORTVERSION= 1.01
+CATEGORIES= graphics
+MASTER_SITES= http://www.eaflux.com/fv/sources/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= A viewer of hdr/pfm images
+
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_ZIP= yes
+USE_GCC= 3.3+
+USE_GETOPT_LONG=yes
+USE_GL= yes
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+do-build:
+ ${CXX} ${CXXFLAGS} -DNDEBUG -DHAVE_DECL_GETOPT -I${X11BASE}/include \
+ -I${LOCALBASE}/include -I${WRKSRC} ${CPPFLAGS} \
+ ${PTHREAD_CFLAGS} ${LDFLAGS} -L${X11BASE}/lib \
+ -L${LOCALBASE}/lib -lpng -lz -lbz2 -lglut -lGLU -lGL -lXi \
+ -lXmu -lX11 -lXext -lSM -lm ${PTHREAD_LIBS} \
+ -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/*.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>