aboutsummaryrefslogtreecommitdiff
path: root/graphics/fv
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-14 18:45:11 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-14 18:45:11 +0000
commit18c62a92d5b23fa24e229699efdf5e3f65d9bd56 (patch)
tree288053c45e5166a918995092b01ccd938391fafb /graphics/fv
parentc669f701fe247f41979bab5fcd6f9c4cfbe44687 (diff)
downloadports-18c62a92d5b23fa24e229699efdf5e3f65d9bd56.tar.gz
ports-18c62a92d5b23fa24e229699efdf5e3f65d9bd56.zip
Notes
Diffstat (limited to 'graphics/fv')
-rw-r--r--graphics/fv/Makefile25
-rw-r--r--graphics/fv/distinfo6
-rw-r--r--graphics/fv/files/patch-common.h15
3 files changed, 13 insertions, 33 deletions
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
index 350fd416f955..fd8ab4d7e78c 100644
--- a/graphics/fv/Makefile
+++ b/graphics/fv/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= fv
-PORTVERSION= 1.01
-PORTREVISION= 2
+PORTVERSION= 1.02
CATEGORIES= graphics
MASTER_SITES= http://www.eaflux.com/fv/sources/
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
@@ -15,25 +14,21 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A viewer of hdr/pfm images
-LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut \
- png.5:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_ZIP= yes
-USE_GCC= 3.3+
-USE_GETOPT_LONG=yes
-USE_GL= yes
-USE_X_PREFIX= yes
+USE_GL= glut
-PLIST_FILES= bin/${PORTNAME}
PORTDOCS= README
+PLIST_FILES= bin/${PORTNAME}
do-build:
- ${CXX} ${CXXFLAGS} -DNDEBUG -DHAVE_DECL_GETOPT -I${X11BASE}/include \
- -I${LOCALBASE}/include -I${WRKSRC} ${CPPFLAGS} \
- ${PTHREAD_CFLAGS} ${LDFLAGS} -L${X11BASE}/lib \
- -L${LOCALBASE}/lib -lpng -lz -lbz2 -lglut -lGLU -lGL -lXi \
- -lXmu -lX11 -lXext -lSM -lm ${PTHREAD_LIBS} \
- -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/*.c
+ cd ${BUILD_WRKSRC} \
+ && ${CXX} ${CXXFLAGS} -DNDEBUG -I${WRKSRC} \
+ -I${LOCALBASE}/include ${CPPFLAGS} ${PTHREAD_CFLAGS} \
+ ${LDFLAGS} -L${LOCALBASE}/lib -lpng -lz -lbz2 -lglut \
+ -lGLU -lGL -lXi -lXmu -lX11 -lXext -lSM -lm ${PTHREAD_LIBS} \
+ -o ${PORTNAME} *.c
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
diff --git a/graphics/fv/distinfo b/graphics/fv/distinfo
index 00e301d2b239..924a07082964 100644
--- a/graphics/fv/distinfo
+++ b/graphics/fv/distinfo
@@ -1,3 +1,3 @@
-MD5 (fv-src-1.01.zip) = 0ad6b8fda55f22dc1d0dc21c8fe6ae57
-SHA256 (fv-src-1.01.zip) = fa5de1af4d207abb24b0235ed0f8237cacfae100d52560ffd4f938c6084c48e7
-SIZE (fv-src-1.01.zip) = 41089
+MD5 (fv-src-1.02.zip) = e84ece1b1af1ec085966c02f829c67a9
+SHA256 (fv-src-1.02.zip) = 698b0423df4372390572d0cb2c4355999425f95e2fe6939f16998c4e7a1f9f58
+SIZE (fv-src-1.02.zip) = 42169
diff --git a/graphics/fv/files/patch-common.h b/graphics/fv/files/patch-common.h
deleted file mode 100644
index 8dc6c8e4fe30..000000000000
--- a/graphics/fv/files/patch-common.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- common.h.orig
-+++ common.h
-@@ -38,7 +38,12 @@
- #include <fcntl.h>
- #include <map>
- #include <pthread.h>
-+#if (defined(__unix__) || defined(unix)) && !defined(USG)
-+#include <sys/param.h>
-+#endif
-+#ifndef BSD
- #include <stdint.h>
-+#endif
- #include <string>
- #include <sys/stat.h>
- #include <sys/time.h>