aboutsummaryrefslogtreecommitdiff
path: root/graphics/fyre
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-07-02 16:09:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-07-02 16:09:38 +0000
commit3c4074641170b98d02cd4268f2508c05a6699f2c (patch)
tree8ad0bd92f655b9a4c39c05099300631bc29319a5 /graphics/fyre
parent335e9d47aa34946ca85180e64f886720a9189314 (diff)
downloadports-3c4074641170b98d02cd4268f2508c05a6699f2c.tar.gz
ports-3c4074641170b98d02cd4268f2508c05a6699f2c.zip
Notes
Diffstat (limited to 'graphics/fyre')
-rw-r--r--graphics/fyre/Makefile47
-rw-r--r--graphics/fyre/distinfo4
-rw-r--r--graphics/fyre/pkg-plist8
3 files changed, 34 insertions, 25 deletions
diff --git a/graphics/fyre/Makefile b/graphics/fyre/Makefile
index ea7baf25b622..85e36a71ceb0 100644
--- a/graphics/fyre/Makefile
+++ b/graphics/fyre/Makefile
@@ -6,45 +6,54 @@
#
PORTNAME= fyre
-PORTVERSION= 1.0.0
-PORTREVISION= 11
+PORTVERSION= 1.0.1
CATEGORIES= graphics
MASTER_SITES= http://releases.navi.cx/fyre/
MAINTAINER= ports@FreeBSD.org
COMMENT= Chaos map rendering system with GTK+-2 interface
-BUILD_DEPENDS= update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- gnet-2.0:${PORTSDIR}/net/gnet2
+OPTIONS= OPT_CFLAGS "Enable additional optimizations (x86 only)" off \
+ OPENEXR "Enable OpenEXR suport" on \
+ GNET "Enable GNet support" on
+
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
USE_BZIP2= yes
-USE_GNOME= libglade2 desktopfileutils
-INSTALLS_ICONS= yes
+USE_GNOME= desktopfileutils libglade2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+MAKE_ENV= LDFLAGS="${LDFLAGS}"
+INSTALLS_ICONS= yes
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386"
-.if defined(WITH_OPTIMIZED_CFLAGS)
-CPPFLAGS+= -march=i686 -O3 -ffast-math \
- -fomit-frame-pointer -D__NO_INLINE__
+.if ${ARCH} == "i386" && defined(WITH_OPT_CFLAGS)
+CFLAGS+= -march=native -O3 -ffast-math -fomit-frame-pointer
+.endif
+
+.if defined(WITHOUT_OPENEXR)
+CONFIGURE_ARGS+=--disable-openexr
.else
-pre-everything::
- @${ECHO_CMD} ""
- @${ECHO_CMD} "The following options are available:"
- @${ECHO_CMD} " WITH_OPTIMIZED_CFLAGS - build port with optimization support"
- @${ECHO_CMD} ""
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
.endif
+
+.if defined(WITHOUT_GNET)
+CONFIGURE_ARGS+=--disable-gnet
+.else
+LIB_DEPENDS+= gnet-2.0.0:${PORTSDIR}/net/gnet2
.endif
+post-patch:
+ @${REINPLACE_CMD} -e '/-O3/s|^|#|g' ${WRKSRC}/configure
+
post-install:
- @-update-desktop-database
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
+ @-update-desktop-database
.include <bsd.port.post.mk>
diff --git a/graphics/fyre/distinfo b/graphics/fyre/distinfo
index 495a04047413..dac1999d0256 100644
--- a/graphics/fyre/distinfo
+++ b/graphics/fyre/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fyre-1.0.0.tar.bz2) = 652f9c80569e7ddb85bf8de43222a2b37e5c6a80c2f01260215be8485a234f8e
-SIZE (fyre-1.0.0.tar.bz2) = 243544
+SHA256 (fyre-1.0.1.tar.bz2) = dafca8e54c77f6078220a2687978914d8e4f7a045306ce4221c403b065425352
+SIZE (fyre-1.0.1.tar.bz2) = 263406
diff --git a/graphics/fyre/pkg-plist b/graphics/fyre/pkg-plist
index f5cda6b07511..3e47295ab8cc 100644
--- a/graphics/fyre/pkg-plist
+++ b/graphics/fyre/pkg-plist
@@ -4,14 +4,14 @@ share/applications/fyre.desktop
%%DATADIR%%/about-box.fa
%%DATADIR%%/animation-render.glade
%%DATADIR%%/explorer.glade
-%%DATADIR%%/fyre-16x16.png
-%%DATADIR%%/fyre-32x32.png
-%%DATADIR%%/fyre-48x48.png
%%DATADIR%%/metadata-emblem.png
+share/icons/hicolor/16x16/apps/fyre.png
+share/icons/hicolor/22x22/apps/fyre.png
+share/icons/hicolor/24x24/apps/fyre.png
share/icons/hicolor/48x48/mimetypes/application-x-fyre-animation.png
+share/icons/hicolor/scalable/apps/fyre.svg
share/mime/application/x-fyre-animation.xml
share/mime/packages/fyre.xml
-share/pixmaps/fyre-48x48.png
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications