aboutsummaryrefslogtreecommitdiff
path: root/graphics/gauche-gl
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-29 00:09:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-29 00:09:52 +0000
commit1c0e2ae331974e48df2c0b4ae1964189a0aa12ec (patch)
tree6b23296c4f255f31c5a0606b616234baf5a4ce13 /graphics/gauche-gl
parent653aef86bca9e3d3807bd0bbfdecd29a7beda3bd (diff)
downloadports-1c0e2ae331974e48df2c0b4ae1964189a0aa12ec.tar.gz
ports-1c0e2ae331974e48df2c0b4ae1964189a0aa12ec.zip
Notes
Diffstat (limited to 'graphics/gauche-gl')
-rw-r--r--graphics/gauche-gl/Makefile12
-rw-r--r--graphics/gauche-gl/distinfo5
-rw-r--r--graphics/gauche-gl/files/patch-src-glext-lib.stub18
-rw-r--r--graphics/gauche-gl/pkg-plist8
4 files changed, 12 insertions, 31 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index bd8742395e3b..4608c86a0864 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gl
-PORTVERSION= 0.4
+PORTVERSION= 0.4.1
CATEGORIES= graphics scheme
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gauche
@@ -30,15 +30,19 @@ DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
PLIST_SUB= VERSION="`gauche-config -V`" \
TARGET="${CONFIGURE_TARGET}"
+.if !defined(NOPORTDOCS)
+INFO= gauche-gl-refe gauche-gl-refj
+.endif
+
do-install:
cd ${WRKSRC}/src; ${MAKE} ${INSTALL_TARGET}
cd ${WRKSRC}/lib; ${MAKE} ${INSTALL_TARGET}
post-install:
.if !defined(NOPORTDOCS)
-.for info in gauche-gl-refe.info gauche-gl-refj.info
- ${GZCAT} ${WRKSRC}/doc/${info}.gz >${PREFIX}/info/${info}
- install-info ${PREFIX}/info/${info} ${PREFIX}/info/dir
+.for i in gauche-gl-refe.info gauche-gl-refj.info
+ ${GZCAT} ${WRKSRC}/doc/${i}.gz >${PREFIX}/info/${i}
+ install-info ${PREFIX}/info/${i} ${PREFIX}/info/dir
.endfor
${MKDIR} ${EXAMPLESDIR}
${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
diff --git a/graphics/gauche-gl/distinfo b/graphics/gauche-gl/distinfo
index d57c2ef53f7d..4826bacf2210 100644
--- a/graphics/gauche-gl/distinfo
+++ b/graphics/gauche-gl/distinfo
@@ -1,2 +1,3 @@
-MD5 (Gauche-gl-0.4.tgz) = 11b2f49ee8344308d8c69b2bbc3282a6
-SIZE (Gauche-gl-0.4.tgz) = 939391
+MD5 (Gauche-gl-0.4.1.tgz) = a51b19a0f16f88ed6cd85c6e49cc6e75
+SHA256 (Gauche-gl-0.4.1.tgz) = e4350d5d0e53374306e84af772724ebbaa34ec2d47950f16dbe069c4fa1d4d04
+SIZE (Gauche-gl-0.4.1.tgz) = 940134
diff --git a/graphics/gauche-gl/files/patch-src-glext-lib.stub b/graphics/gauche-gl/files/patch-src-glext-lib.stub
deleted file mode 100644
index 2a2db92213f8..000000000000
--- a/graphics/gauche-gl/files/patch-src-glext-lib.stub
+++ /dev/null
@@ -1,18 +0,0 @@
---- src/glext-lib.stub.orig Fri Jun 10 13:27:17 2005
-+++ src/glext-lib.stub Wed Jul 13 22:18:47 2005
-@@ -524,6 +524,7 @@
- "GLint nstrings = Scm_Length(strings); int i = 0;
- GLint *lengths;
- GLcharARB **ss;
-+ ScmObj sp;
- ENSURE(glShaderSourceARB);
- if (nstrings < 0) goto einval;
- lengths = SCM_NEW_ATOMIC2(GLint*, nstrings*sizeof(GLint));
-@@ -531,7 +532,6 @@
- input parameter, and we don't need this array after calling
- glShaderSourceARB. */
- ss = SCM_NEW_ATOMIC2(GLcharARB**, nstrings*sizeof(GLcharARB*));
-- ScmObj sp;
- SCM_FOR_EACH(sp, strings) {
- if (!SCM_STRINGP(SCM_CAR(sp))) goto einval;
- lengths[i] = SCM_STRING_SIZE(SCM_CAR(sp));
diff --git a/graphics/gauche-gl/pkg-plist b/graphics/gauche-gl/pkg-plist
index c8de23a7b143..dfe1cdaf6f5f 100644
--- a/graphics/gauche-gl/pkg-plist
+++ b/graphics/gauche-gl/pkg-plist
@@ -5,13 +5,8 @@ lib/gauche/%%VERSION%%/include/gauche/math3d.h
share/gauche/%%VERSION%%/lib/gl.scm
share/gauche/%%VERSION%%/lib/gl/glut.scm
share/gauche/%%VERSION%%/lib/gl/math3d.scm
+share/gauche/%%VERSION%%/lib/gl/simple-image.scm
@dirrm share/gauche/%%VERSION%%/lib/gl
-%%PORTDOCS%%@unexec install-info --delete %D/info/gauche-gl-refe.info %D/info/dir
-%%PORTDOCS%%@unexec install-info --delete %D/info/gauche-gl-refj.info %D/info/dir
-%%PORTDOCS%%info/gauche-gl-refe.info
-%%PORTDOCS%%info/gauche-gl-refj.info
-%%PORTDOCS%%@exec install-info %D/info/gauche-gl-refe.info %D/info/dir
-%%PORTDOCS%%@exec install-info %D/info/gauche-gl-refj.info %D/info/dir
%%PORTDOCS%%%%EXAMPLESDIR%%/gears.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/glbook/README
%%PORTDOCS%%%%EXAMPLESDIR%%/glbook/example1-2.scm
@@ -67,7 +62,6 @@ share/gauche/%%VERSION%%/lib/gl/math3d.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/slbook/ogl2particle/particle.vert
%%PORTDOCS%%%%EXAMPLESDIR%%/slbook/ogl2particle/README.txt
%%PORTDOCS%%%%EXAMPLESDIR%%/slbook/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/images/foo.scm
%%PORTDOCS%%%%EXAMPLESDIR%%/images/noturn.rgb
%%PORTDOCS%%%%EXAMPLESDIR%%/images/flower.rgb
%%PORTDOCS%%%%EXAMPLESDIR%%/glbook/example8-6.scm