aboutsummaryrefslogtreecommitdiff
path: root/graphics/gauche-gl
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-26 09:07:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-06-26 09:07:08 +0000
commit88270f435e4636442d018b6b8795f7e0517f5e93 (patch)
treec6e0f0e36c22048a86231ce66afe41fad81ae3af /graphics/gauche-gl
parentc425f018ab8e1c5fd2ded46085e8b2e6da4416a0 (diff)
downloadports-88270f435e4636442d018b6b8795f7e0517f5e93.tar.gz
ports-88270f435e4636442d018b6b8795f7e0517f5e93.zip
Notes
Diffstat (limited to 'graphics/gauche-gl')
-rw-r--r--graphics/gauche-gl/Makefile7
-rw-r--r--graphics/gauche-gl/pkg-plist20
2 files changed, 13 insertions, 14 deletions
diff --git a/graphics/gauche-gl/Makefile b/graphics/gauche-gl/Makefile
index a0edabbbde34..d9682cca287d 100644
--- a/graphics/gauche-gl/Makefile
+++ b/graphics/gauche-gl/Makefile
@@ -15,8 +15,6 @@ COMMENT= OpenGL binding for Gauche
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN= fails to stage
-
BUILD_DEPENDS= gosh:lang/gauche
RUN_DEPENDS= gosh:lang/gauche
@@ -26,11 +24,12 @@ USE_XORG= ice sm x11 xext xmu xi
USE_GL= gl glu glut
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
+GAUCHE_ABI= 0.97
DOCSDIR= ${PREFIX}/share/doc/gauche/${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/gauche/${PORTNAME}
-PLIST_SUB= TARGET="${CONFIGURE_TARGET}"
+PLIST_SUB= TARGET="${CONFIGURE_TARGET}" ABI_VER=${GAUCHE_ABI}
INFO= gauche-gl-refe gauche-gl-refj
@@ -50,7 +49,7 @@ do-install:
${GZCAT} ${WRKSRC}/doc/${i}.info.gz \
> ${STAGEDIR}${PREFIX}/${INFO_PATH}/${i}.info
.endfor
- @(cd ${STAGEDIR}${PREFIX}/lib/gauche-0.9/site/${CONFIGURE_TARGET} && \
+ @(cd ${STAGEDIR}${PREFIX}/lib/gauche-${GAUCHE_ABI}/site/${CONFIGURE_TARGET} && \
${CHMOD} u+w libgauche-*.so && ${STRIP_CMD} libgauche-*.so && \
${CHMOD} u-w libgauche-*.so)
diff --git a/graphics/gauche-gl/pkg-plist b/graphics/gauche-gl/pkg-plist
index 4e0d09da9fc0..658726cdc5ef 100644
--- a/graphics/gauche-gl/pkg-plist
+++ b/graphics/gauche-gl/pkg-plist
@@ -1,7 +1,7 @@
-lib/gauche-0.9/site/%%TARGET%%/libgauche-gl.so
-lib/gauche-0.9/site/%%TARGET%%/libgauche-glut.so
-lib/gauche-0.9/site/%%TARGET%%/libgauche-math3d.so
-lib/gauche-0.9/site/include/gauche/math3d.h
+lib/gauche-%%ABI_VER%%/site/%%TARGET%%/libgauche-gl.so
+lib/gauche-%%ABI_VER%%/site/%%TARGET%%/libgauche-glut.so
+lib/gauche-%%ABI_VER%%/site/%%TARGET%%/libgauche-math3d.so
+lib/gauche-%%ABI_VER%%/site/include/gauche/math3d.h
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cg/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cg/cg-gl-vertex-example.cg
@@ -74,9 +74,9 @@ lib/gauche-0.9/site/include/gauche/math3d.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slbook/ogl2particle/particle.frag
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slbook/ogl2particle/particle.vert
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/slbook/ogl2particle/run.sh
-share/gauche-0.9/site/lib/gl.scm
-share/gauche-0.9/site/lib/gl/glut.scm
-share/gauche-0.9/site/lib/gl/math3d.scm
-share/gauche-0.9/site/lib/gl/simple-image.scm
-share/gauche-0.9/site/lib/gl/simple/image.scm
-share/gauche-0.9/site/lib/gl/simple/viewer.scm
+share/gauche-%%ABI_VER%%/site/lib/gl.scm
+share/gauche-%%ABI_VER%%/site/lib/gl/glut.scm
+share/gauche-%%ABI_VER%%/site/lib/gl/math3d.scm
+share/gauche-%%ABI_VER%%/site/lib/gl/simple-image.scm
+share/gauche-%%ABI_VER%%/site/lib/gl/simple/image.scm
+share/gauche-%%ABI_VER%%/site/lib/gl/simple/viewer.scm