aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-06-26 18:51:00 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-06-26 18:51:00 +0000
commitf07b8e6ae951da252e65c9b5fc205181164cc638 (patch)
tree11c81b10e649755e9f7809cd34a34690b1a26526 /graphics/gd/Makefile
parent4e774bc5a1a14c82ae1a7835ad08bcb01ef6f142 (diff)
Notes
Diffstat (limited to 'graphics/gd/Makefile')
-rw-r--r--graphics/gd/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index 3e61ef13b3ed..4ac9eaecf87f 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= gd
-PORTVERSION= 2.0.34
-PORTREVISION?= 1
+PORTVERSION= 2.0.35
+PORTREVISION?= 0
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= http://www.libgd.org/releases/
@@ -64,6 +64,8 @@ USE_PERL5_BUILD= yes
SCRIPTS_ENV+= GD_FONTS="${GD_FONTS}"
.endif
+FONTBASE= ${X11BASE}/lib/X11/fonts
+
pre-extract::
@${ECHO_MSG} ""
@${ECHO_MSG} "gd has the following tunables:"
@@ -86,6 +88,9 @@ post-configure:
-e 's|@FEATURES@|${FEATURES}|' \
${WRKSRC}/config/gdlib-config.in \
> ${WRKDIR}/gdlib-config
+ ${REINPLACE_CMD} \
+ -e 's|#define DEFAULT_FONTPATH .*|#define DEFAULT_FONTPATH "${FONTBASE}/TTF:${FONTBASE}/Type1:${FONTBASE}"|' \
+ ${WRKSRC}/gd.h
post-install:
${INSTALL_DATA} ${WRKSRC}/gdfx.h ${WRKSRC}/gdhelpers.h \