aboutsummaryrefslogtreecommitdiff
path: root/graphics/gd
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-28 09:22:32 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-28 09:22:32 +0000
commitac00cca6e50cdd00ccce56b0121c6a16a2f7d066 (patch)
tree84efcc262a8eea83a1b8d023fd5ea1fa354f77b1 /graphics/gd
parent66f78e35c6805543f09fbda768ad901a052ff6fb (diff)
downloadports-ac00cca6e50cdd00ccce56b0121c6a16a2f7d066.tar.gz
ports-ac00cca6e50cdd00ccce56b0121c6a16a2f7d066.zip
Notes
Diffstat (limited to 'graphics/gd')
-rw-r--r--graphics/gd/Makefile2
-rw-r--r--graphics/gd/files/patch-gd_png.c15
2 files changed, 13 insertions, 4 deletions
diff --git a/graphics/gd/Makefile b/graphics/gd/Makefile
index ce392258c821..8b68ed8dc075 100644
--- a/graphics/gd/Makefile
+++ b/graphics/gd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gd
PORTVERSION= 2.0.35
-PORTREVISION?= 5
+PORTREVISION?= 6
PORTEPOCH= 1
CATEGORIES+= graphics
MASTER_SITES= http://www.libgd.org/releases/
diff --git a/graphics/gd/files/patch-gd_png.c b/graphics/gd/files/patch-gd_png.c
index 37ac9812b558..42c677ae41f3 100644
--- a/graphics/gd/files/patch-gd_png.c
+++ b/graphics/gd/files/patch-gd_png.c
@@ -1,6 +1,15 @@
---- gd_png.c.orig Sat Feb 3 02:41:00 2007
-+++ gd_png.c Tue Feb 13 15:31:57 2007
-@@ -189,6 +189,16 @@
+--- gd_png.c.orig 2007-06-14 21:51:41.000000000 +0200
++++ gd_png.c 2010-03-28 11:23:08.000000000 +0200
+@@ -149,7 +149,7 @@
+ return NULL;
+ }
+
+- if (!png_check_sig (sig, 8)) { /* bad signature */
++ if (!png_sig_cmp (sig, 0, 8)) { /* bad signature */
+ return NULL; /* bad signature */
+ }
+
+@@ -193,6 +193,16 @@
png_read_info (png_ptr, info_ptr); /* read all PNG info up to image data */
png_get_IHDR (png_ptr, info_ptr, &width, &height, &bit_depth, &color_type, &interlace_type, NULL, NULL);