aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2022-03-28 19:20:06 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2022-03-29 12:44:53 +0000
commitb71f7e3faa7181387717df55cfd009db723b3d71 (patch)
tree89cf32f4c0cf6a7644af47bd9ef25262347ae2e1 /graphics/gdal
parentc35c6fc30a60b1d106b032cc77affc0192fe132e (diff)
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 5cd9500a265b..9d874f096276 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -2,7 +2,7 @@
PORTNAME= gdal
PORTVERSION= 3.4.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/gdal/${PORTVERSION}/ \
LOCAL/sunpoet
@@ -42,12 +42,12 @@ PCRE2_DESC= Regular expression support for SQLite
RASTERLITE2_DESC= RasterLite2 support
TILEDB_DESC= TileDB support
-USES= compiler:c++14-lang cpe gmake iconv jpeg localbase pkgconfig ssl tar:xz
+USES= compiler:c++17-lang cpe gmake iconv jpeg localbase pkgconfig ssl tar:xz
CFLAGS+= -fPIC
CONFIGURE_ARGS= --datadir=${PREFIX}/share \
--enable-static=yes \
- --with-cpp14 \
+ --with-cpp17 \
--with-crypto=yes \
--with-geotiff=yes \
--with-gif=yes \
@@ -69,7 +69,7 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share \
GNU_CONFIGURE= yes
LDFLAGS+= ${ICONV_LIB}
MAKEFILE= GNUmakefile
-USE_CXXSTD= c++14
+USE_CXXSTD= c++17
USE_LDCONFIG= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}