aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-24 16:21:20 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-24 16:21:20 +0000
commita76e244dc20754ee8531e8bd351f846851c53126 (patch)
treef356f503b6d1ac7d370ec8e83e26576468dabe59 /graphics/gdal
parent56bf956b38dfe76c0caaaf5ada43883050976360 (diff)
downloadports-a76e244dc20754ee8531e8bd351f846851c53126.tar.gz
ports-a76e244dc20754ee8531e8bd351f846851c53126.zip
Notes
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index d8035000026c..8601cf148447 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gdal
PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/gdal/${PORTVERSION}/ \
ftp://ftp.remotesensing.org/pub/gdal/${PORTVERSION}/ \
@@ -20,9 +20,9 @@ LIB_DEPENDS= libgeotiff.so:${PORTSDIR}/graphics/libgeotiff \
libpng.so:${PORTSDIR}/graphics/png \
libtiff.so:${PORTSDIR}/graphics/tiff
-OPTIONS_DEFINE= ARMADILLO CFITSIO CURL ECW EXPAT FREEXL GEOS GTA HDF5 ICONV \
- JASPER KML LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL PROJ \
- SQLITE WEBP XERCES
+OPTIONS_DEFINE= ARMADILLO CFITSIO CURL ECW EXPAT FREEXL GEOS GTA HDF5 JASPER \
+ KML LIBXML2 MYSQL NETCDF ODBC OPENJPEG PCRE PGSQL PROJ SQLITE \
+ WEBP XERCES
OPTIONS_DEFAULT=JASPER
OPTIONS_RADIO= PDF
OPTIONS_RADIO_PDF= PODOFO POPPLER
@@ -40,12 +40,15 @@ CONFIGURE_ARGS= --datadir=${DATADIR} \
--with-libz=/usr \
--with-png=${LOCALBASE} \
--with-threads=yes \
- --without-libtool
+ --without-libtool \
+ ${ICONV_CONFIGURE_ARG}
+CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
+LDFLAGS+= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
MAKE_JOBS_UNSAFE= yes
MAKEFILE= GNUmakefile
USE_LDCONFIG= yes
-USES= gmake jpeg tar:xz
+USES= gmake iconv jpeg tar:xz
PLIST_SUB= MAJOR_VER=${PORTVERSION:R:R} PORTVERSION=${PORTVERSION}
PORTDATA= *
@@ -79,11 +82,6 @@ GTA_LIB_DEPENDS= libgta.so:${PORTSDIR}/devel/libgta
HDF5_CONFIGURE_OFF= --with-hdf5=no
HDF5_CONFIGURE_ON= --with-hdf5=${LOCALBASE}
HDF5_LIB_DEPENDS= libhdf5.so:${PORTSDIR}/science/hdf5
-ICONV_CONFIGURE_OFF= --with-libiconv-prefix=no
-ICONV_CONFIGURE_ON= ${ICONV_CONFIGURE_ARG}
-ICONV_CPPFLAGS= -I${LOCALBASE}/include
-ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
-ICONV_USES= iconv
JASPER_CONFIGURE_OFF= --with-jasper=no
JASPER_CONFIGURE_ON= --with-jasper=${LOCALBASE}
JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper