aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdal
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2009-03-17 15:09:07 +0000
committerRong-En Fan <rafan@FreeBSD.org>2009-03-17 15:09:07 +0000
commit69201b7c8bf5fa28ea40d78f3181a519c4d7bc07 (patch)
tree74850c12deda66dc4d336be8e2f75257e7cc25c2 /graphics/gdal
parent0f78d77ae27ee35ece26d94a4eb835f31e6efe26 (diff)
downloadports-69201b7c8bf5fa28ea40d78f3181a519c4d7bc07.tar.gz
ports-69201b7c8bf5fa28ea40d78f3181a519c4d7bc07.zip
Notes
Diffstat (limited to 'graphics/gdal')
-rw-r--r--graphics/gdal/Makefile6
-rw-r--r--graphics/gdal/distinfo6
-rw-r--r--graphics/gdal/files/gdalwarp.1105
-rw-r--r--graphics/gdal/files/patch-ogr-GNUmakefile6
-rw-r--r--graphics/gdal/files/patch-ogr-ogrsf_frmts-kml-ogr2kmlgeometry.cpp11
-rw-r--r--graphics/gdal/files/patch-swig-python-GNUmakefile18
-rw-r--r--graphics/gdal/pkg-plist15
7 files changed, 138 insertions, 29 deletions
diff --git a/graphics/gdal/Makefile b/graphics/gdal/Makefile
index 8db579d42321..d0afa73a0e09 100644
--- a/graphics/gdal/Makefile
+++ b/graphics/gdal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gdal
-PORTVERSION= 1.5.0
-PORTREVISION= 2
+PORTVERSION= 1.6.0
CATEGORIES= graphics geography
MASTER_SITES= ftp://ftp.remotesensing.org/pub/gdal/ \
http://www.gdal.org/dl/ \
@@ -269,4 +268,7 @@ post-patch:
' ${WRKSRC}/swig/python/GNUmakefile
.endif
+post-install:
+ ${INSTALL_MAN} ${FILESDIR}/gdalwarp.1 ${PREFIX}/man/man1/
+
.include <bsd.port.post.mk>
diff --git a/graphics/gdal/distinfo b/graphics/gdal/distinfo
index b651765f059d..964f9531e164 100644
--- a/graphics/gdal/distinfo
+++ b/graphics/gdal/distinfo
@@ -1,3 +1,3 @@
-MD5 (gdal-1.5.0.tar.gz) = ffbb024db521a002018cb5666bd6e60d
-SHA256 (gdal-1.5.0.tar.gz) = 9ac75f8928aa649a70e2aa3ebda86e71e18acc295cd874c43d33a84ac11c1e91
-SIZE (gdal-1.5.0.tar.gz) = 6167411
+MD5 (gdal-1.6.0.tar.gz) = 0c53697511f489455f8b60e843986568
+SHA256 (gdal-1.6.0.tar.gz) = acdc2faf7496f8d8f4680347ce30fd3a2139b5c050f13dcd6ca8a3d7f6e418a4
+SIZE (gdal-1.6.0.tar.gz) = 7072689
diff --git a/graphics/gdal/files/gdalwarp.1 b/graphics/gdal/files/gdalwarp.1
new file mode 100644
index 000000000000..4f17869152e0
--- /dev/null
+++ b/graphics/gdal/files/gdalwarp.1
@@ -0,0 +1,105 @@
+.TH "gdalwarp" 1 "20 Dec 2007" "GDAL" \" -*- nroff -*-
+.ad l
+.nh
+.SH NAME
+gdalwarp \- gdalwarp
+simple image reprojection and warping utility
+.SH "SYNOPSIS"
+.PP
+.PP
+.PP
+.nf
+
+gdalwarp
+ [-s_srs srs_def] [-t_srs srs_def] [-order n] ] [-tps] [-et err_threshold]
+ [-te xmin ymin xmax ymax] [-tr xres yres] [-ts width height]
+ [-wo "NAME=VALUE"] [-ot Byte/Int16/...] [-wt Byte/Int16]
+ [-srcnodata "value [value...]"] [-dstnodata "value [value...]"] -dstalpha
+ [-r resampling_method] [-wm memory_in_mb] [-multi] [-q]
+ [-of format] [-co "NAME=VALUE"]* srcfile* dstfile
+.fi
+.PP
+.SH "DESCRIPTION"
+.PP
+The gdalwarp utility is an image mosaicing, reprojection and warping utility. The program can reproject to any supported projection, and can also apply GCPs stored with the image if the image is 'raw' with control information.
+.PP
+.IP "\fB\fB-s_srs\fP \fIsrs def\fP:\fP" 1c
+source spatial reference set. The coordinate systems that can be passed are anything supported by the OGRSpatialReference.SetFromUserInput() call, which includes EPSG PCS and GCSes (ie. EPSG:4296), PROJ.4 declarations (as above), or the name of a .prf file containing well known text.
+.IP "\fB\fB-t_srs\fP \fIsrs_def\fP:\fP" 1c
+target spatial reference set. The coordinate systems that can be passed are anything supported by the OGRSpatialReference.SetFromUserInput() call, which includes EPSG PCS and GCSes (ie. EPSG:4296), PROJ.4 declarations (as above), or the name of a .prf file containing well known text.
+.IP "\fB\fB-order\fP \fIn\fP:\fP" 1c
+order of polynomial used for warping (1 to 3). The default is to select a polynomial order based on the number of GCPs.
+.IP "\fB\fB-tps\fP\fP" 1c
+Enable use of thin plate spline transformer based on available GCPs. Use this \fIinstead\fP of the -order switch.
+.IP "\fB\fB-et\fP \fIerr_threshold\fP:\fP" 1c
+error threshold for transformation approximation (in pixel units - defaults to 0.125).
+.IP "\fB\fB-te\fP \fIxmin ymin xmax ymax\fP:\fP" 1c
+set georeferenced extents of output file to be created.
+.IP "\fB\fB-tr\fP \fIxres yres\fP:\fP" 1c
+set output file resolution (in target georeferenced units)
+.IP "\fB\fB-ts\fP \fIwidth height\fP:\fP" 1c
+set output file size in pixels and lines
+.IP "\fB\fB-wo\fP \fI'NAME=VALUE'\fP:\fP" 1c
+Set a warp options. The GDALWarpOptions::papszWarpOptions docs show all options. Multiple \fB-wo\fP options may be listed.
+.IP "\fB\fB-ot\fP \fItype\fP:\fP" 1c
+For the output bands to be of the indicated data type.
+.IP "\fB\fB-wt\fP \fItype\fP:\fP" 1c
+Working pixel data type. The data type of pixels in the source image and destination image buffers.
+.IP "\fB\fB-r\fP \fIresampling_method\fP:\fP" 1c
+Resampling method to use. Available methods are:
+.IP "\fB\fBnear\fP: \fP" 1c
+nearest neighbour resampling (default, fastest algorithm, worst interpolation quality).
+.IP "\fB\fBbilinear\fP: \fP" 1c
+bilinear resampling.
+.IP "\fB\fBcubic\fP: \fP" 1c
+cubic resampling.
+.IP "\fB\fBcubicspline\fP: \fP" 1c
+cubic spline resampling.
+.IP "\fB\fBlanczos\fP: \fP" 1c
+Lanczos windowed sinc resampling.
+.PP
+.IP "\fB\fB-srcnodata\fP \fIvalue [value...]\fP:\fP" 1c
+Set nodata masking values for input bands (different values can be supplied for each band). If more than one value is supplied all values should be quoted to keep them together as a single operating system argument. Masked values will not be used in interpolation. Use a value of \fCNone\fP to ignore intrinsic nodata settings on the source dataset.
+.IP "\fB\fB-dstnodata\fP \fIvalue [value...]\fP:\fP" 1c
+Set nodata values for output bands (different values can be supplied for each band). If more than one value is supplied all values should be quoted to keep them together as a single operating system argument. New files will be initialized to this value and if possible the nodata value will be recorded in the output file.
+.IP "\fB\fB-dstalpha\fP:\fP" 1c
+Create an output alpha band to identify nodata (unset/transparent) pixels.
+.IP "\fB\fB-wm\fP \fImemory_in_mb\fP:\fP" 1c
+Set the amount of memory (in megabytes) that the warp API is allowed to use for caching.
+.IP "\fB\fB-multi\fP:\fP" 1c
+Use multithreaded warping implementation. Multiple threads will be used to process chunks of image and perform input/output operation simultaneously.
+.IP "\fB\fB-q\fP:\fP" 1c
+Be quiet.
+.IP "\fB\fB-of\fP \fIformat\fP:\fP" 1c
+Select the output format. The default is GeoTIFF (GTiff). Use the short format name.
+.IP "\fB\fB-co\fP \fI'NAME=VALUE'\fP:\fP" 1c
+passes a creation option to the output format driver. Multiple \fB-co\fP options may be listed. See format specific documentation for legal creation options for each format.
+.IP "\fB\fIsrcfile\fP:\fP" 1c
+The source file name(s).
+.IP "\fB\fIdstfile\fP:\fP" 1c
+The destination file name.
+.PP
+.PP
+Mosaicing into an existing output file is supported if the output file already exists.
+.SH "EXAMPLE"
+.PP
+For instance, an eight bit spot scene stored in GeoTIFF with control points mapping the corners to lat/long could be warped to a UTM projection with a command like this:
+.PP
+.PP
+.nf
+
+gdalwarp -t_srs '+proj=utm +zone=11 +datum=WGS84' raw_spot.tif utm11.tif
+.fi
+.PP
+.PP
+For instance, the second channel of an ASTER image stored in HDF with control points mapping the corners to lat/long could be warped to a UTM projection with a command like this:
+.PP
+.PP
+.nf
+
+gdalwarp HDF4_SDS:ASTER_L1B:"pg-PR1B0000-2002031402_100_001":2 pg-PR1B0000-2002031402_100_001_2.tif
+.fi
+.PP
+.SH "AUTHORS"
+.PP
+Frank Warmerdam <warmerdam@pobox.com>, Silke Reimer <silke@intevation.de>
diff --git a/graphics/gdal/files/patch-ogr-GNUmakefile b/graphics/gdal/files/patch-ogr-GNUmakefile
index 4da75e2a5311..699047678a4d 100644
--- a/graphics/gdal/files/patch-ogr-GNUmakefile
+++ b/graphics/gdal/files/patch-ogr-GNUmakefile
@@ -1,6 +1,6 @@
---- ogr/GNUmakefile.orig Fri Nov 9 11:11:24 2007
-+++ ogr/GNUmakefile Wed Dec 26 12:30:59 2007
-@@ -15,7 +15,7 @@
+--- ogr/GNUmakefile.orig 2009-03-02 23:42:30.000000000 +0300
++++ ogr/GNUmakefile 2009-03-02 23:42:35.000000000 +0300
+@@ -19,7 +19,7 @@
default: lib
diff --git a/graphics/gdal/files/patch-ogr-ogrsf_frmts-kml-ogr2kmlgeometry.cpp b/graphics/gdal/files/patch-ogr-ogrsf_frmts-kml-ogr2kmlgeometry.cpp
deleted file mode 100644
index 8a620a6aba54..000000000000
--- a/graphics/gdal/files/patch-ogr-ogrsf_frmts-kml-ogr2kmlgeometry.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- ogr/ogrsf_frmts/kml/ogr2kmlgeometry.cpp.orig Mon Dec 17 13:49:31 2007
-+++ ogr/ogrsf_frmts/kml/ogr2kmlgeometry.cpp Wed Dec 26 11:43:43 2007
-@@ -365,7 +365,7 @@
-
- CPLXMLNode* OGR_G_ExportEnvelopeToKMLTree( OGRGeometryH hGeometry )
- {
-- VALIDATE_POINTER1( hGeometry, "OGR_G_ExportEnvelopeToKMLTree", NULL );
-+ //VALIDATE_POINTER1( hGeometry, "OGR_G_ExportEnvelopeToKMLTree", NULL );
-
- CPLXMLNode* psBox = NULL;
- CPLXMLNode* psCoord = NULL;
diff --git a/graphics/gdal/files/patch-swig-python-GNUmakefile b/graphics/gdal/files/patch-swig-python-GNUmakefile
index 04988668b7ba..a8a14b4b9528 100644
--- a/graphics/gdal/files/patch-swig-python-GNUmakefile
+++ b/graphics/gdal/files/patch-swig-python-GNUmakefile
@@ -1,20 +1,20 @@
---- swig/python/GNUmakefile.orig 2007-11-26 16:02:20.000000000 +0800
-+++ swig/python/GNUmakefile 2008-02-13 14:27:20.000000000 +0800
-@@ -43,7 +43,7 @@
+--- swig/python/GNUmakefile.orig 2008-05-31 11:41:25.000000000 +0400
++++ swig/python/GNUmakefile 2009-03-03 00:05:31.000000000 +0300
+@@ -47,7 +47,7 @@
generate: ${WRAPPERS}
build:
-- python setup.py build
-+ CXX="" python setup.py bdist_egg
+- $(PYTHON) setup.py build
++ CXX="" $(PYTHON) setup.py bdist_egg
egg:
- python setup.py bdist_egg
-@@ -51,7 +51,7 @@
+ $(PYTHON) setup.py bdist_egg
+@@ -55,7 +55,7 @@
install:
ifeq ($(PY_HAVE_SETUPTOOLS),1)
-- python setup.py install
+- $(PYTHON) setup.py install
+ env %%MAKE_ENV%% python setup.py easy_install -O 1 -N -S %%PYTHON_SITELIBDIR%% -d %%PYEASYINSTALL_SITELIBDIR%% -s %%PYEASYINSTALL_BINDIR%% %%WRKSRC%%/swig/python/dist/%%PYEASYINSTALL_EGG%%
else
- python setup.py install --prefix=$(DESTDIR)$(prefix)
+ $(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
endif
diff --git a/graphics/gdal/pkg-plist b/graphics/gdal/pkg-plist
index 552c5c255a1f..21e541406681 100644
--- a/graphics/gdal/pkg-plist
+++ b/graphics/gdal/pkg-plist
@@ -8,8 +8,12 @@ bin/gdal2xyz.py
bin/gdal_contour
bin/gdal_grid
bin/gdal_merge.py
+bin/gdal_polygonize.py
+bin/gdal_proximity.py
bin/gdal_rasterize
bin/gdal_retile.py
+bin/gdal_sieve.dox
+bin/gdal_sieve.py
bin/gdal_translate
bin/gdaladdo
bin/gdalchksum.py
@@ -28,26 +32,34 @@ bin/ogrinfo
bin/ogrtindex
bin/pct2rgb.py
bin/rgb2pct.py
+bin/testepsg
include/cpl_config.h
include/cpl_conv.h
include/cpl_csv.h
include/cpl_error.h
+include/cpl_hash_set.h
include/cpl_http.h
include/cpl_list.h
include/cpl_minixml.h
+include/cpl_minizip_ioapi.h
+include/cpl_minizip_unzip.h
include/cpl_multiproc.h
include/cpl_odbc.h
include/cpl_port.h
+include/cpl_quad_tree.h
include/cpl_string.h
include/cpl_vsi.h
include/cpl_vsi_virtual.h
include/cpl_win32ce_api.h
include/cpl_wince.h
+include/cplkeywordparser.h
include/gdal.h
include/gdal_alg.h
+include/gdal_alg_priv.h
include/gdal_frmts.h
include/gdal_pam.h
include/gdal_priv.h
+include/gdal_proxy.h
include/gdal_rat.h
include/gdal_version.h
include/gdal_vrt.h
@@ -71,7 +83,7 @@ include/vrtdataset.h
lib/libgdal.a
lib/libgdal.la
lib/libgdal.so
-lib/libgdal.so.13
+lib/libgdal.so.14
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
@@ -134,6 +146,7 @@ lib/libgdal.so.13
%%DATADIR%%/GDALLogoColor.svg
%%DATADIR%%/GDALLogoGS.svg
%%DATADIR%%/LICENSE.TXT
+%%DATADIR%%/coordinate_axis.csv
%%DATADIR%%/cubewerx_extra.wkt
%%DATADIR%%/ecw_cs.wkt
%%DATADIR%%/ellipsoid.csv