aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-11-19 11:49:04 +0000
commitaf3811313c14afb06fe2d1f6158e3e431bbfc2b6 (patch)
tree1ad98a4e8faecd0e2fa9ac2c18e65da4cf89c236 /graphics/gdk-pixbuf2/Makefile
parentc7d4d6bd7ef6ff4955eab2863a5c6e2feb14b839 (diff)
The FreeBSD GNOME team proudly presents GNOME 3.14 and Cinnamon 2.2.
Gnome 3.14.1 and Cinnamon 2.2.16 are supported on FreeBSD 9.3-RELEASE and up. This commit removes the old GNOME 2 desktop, bindings and some ports that can't be compiled. A few ports where updated to more recent versions to allow them to compile with this update. Apart from updating ports to newer versions GDM is more integrated with gnome-shell now, and handles several things for the GNOME desktop such as screen locking. If you want to use GNOME 3 via startx, you will have to add your own lock screen/screensaver. For example xscreensaver can be used for sessions started without GDM. Shell Extensions can be installed via https://extensions.gnome.org/ , we have ported a few that can't be installed via this way. The old gnome-utils and gnome-games ports where split up into single ports and where converted to meta-ports. gnome-terminal requires a UTF-8 locale to run, gdm handles this already, but if you use startx you need to do this yourself. Upgrade instructions: Delete the old and conflicting packages: # pkg delete clutter gnome-utils gnome-panel gnome-keyring vala-vapigen \ guile gcalctool gnome-media libgnomekbd # pkg delete gnome-screensaver gnome-applets bug-buddy evolution-exchange \ evolution-webcal gnome-system-tools seahorse-plugins gnome-control-center For package users the following lines will be enough: # pkg upgrade # pkg install gnome3 For ports users should do the following: # portmaster -a # portmaster x11/gnome3 We are currently aware of two issues. The first issue is a bug in the file monitoring code in the glib20 port. This bug causes glib programs to crash when files in a monitored directory are added or removed. Upstream is aware of the problem, but since the problem is quite complex there is no solution yet. This problem isn't restricted to BSD. The second issue is that on certain video cards totem will display a purple/pink overlay on the video. It not clear yet where the issues comes from. Major thanks goes to Gustau Perez for being a driving force behind getting GNOME 3 up to speed again. Also thanks to Antoine Brodin for running the exp-runs. This update was also made possible by: Joe Maloney Kris Moore Beeblebrox Ryan Lortie Antoine Jacoutot and everyone I missed
Notes
Notes: svn path=/head/; revision=372768
Diffstat (limited to 'graphics/gdk-pixbuf2/Makefile')
-rw-r--r--graphics/gdk-pixbuf2/Makefile57
1 files changed, 16 insertions, 41 deletions
diff --git a/graphics/gdk-pixbuf2/Makefile b/graphics/gdk-pixbuf2/Makefile
index 379e335e624e..31950e52d0f6 100644
--- a/graphics/gdk-pixbuf2/Makefile
+++ b/graphics/gdk-pixbuf2/Makefile
@@ -1,10 +1,9 @@
# Created by: Ade Lovett <ade@lovett.com>
# $FreeBSD$
-# $MCom: ports/trunk/graphics/gdk-pixbuf2/Makefile 18692 2013-09-22 00:45:30Z kwm $
+# $MCom: ports/trunk/graphics/gdk-pixbuf2/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= gdk-pixbuf
-PORTVERSION= 2.28.2
-PORTREVISION= 1
+PORTVERSION= 2.31.1
CATEGORIES= graphics
MASTER_SITES= GNOME
PKGNAMESUFFIX= 2
@@ -14,16 +13,26 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= Graphic library for GTK+
USE_XORG= xt xi x11
-USES= gmake libtool:keepla pathfix pkgconfig tar:xz
-USE_GNOME+= gnomehier glib20 introspection:build
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_GNOME+= glib20 introspection:build
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+LIBS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --enable-introspection=yes --with-x11
+INSTALL_TARGET= install-strip
+OPTIONS_SUB= yes
OPTIONS_DEFINE= JASPER JPEG PNG TIFF
OPTIONS_DEFAULT=JASPER JPEG PNG TIFF
+JASPER_CONFIGURE_WITH= libjasper
+JASPER_LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper
+JPEG_CONFIGURE_WITPNGH= libjpeg
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+PNG_CONFIGURE_WITH= libpng
+PNG_LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
+TIFF_CONFIGURE_WITH= libtiff
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
.include <bsd.port.options.mk>
@@ -35,41 +44,7 @@ CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if ${PORT_OPTIONS:MJASPER}
-LIB_DEPENDS+= libjasper.so:${PORTSDIR}/graphics/jasper
-CONFIGURE_ARGS+=--with-libjasper
-PLIST_SUB+= JP2=""
-.else
-PLIST_SUB+= JP2="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MJPEG}
-LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/graphics/jpeg
-PLIST_SUB+= JPEG=""
-.else
-CONFIGURE_ARGS+=--without-libjpeg
-PLIST_SUB+= JPEG="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MPNG}
-LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
-PLIST_SUB+= PNG=""
-.else
-CONFIGURE_ARGS+=--without-libpng
-PLIST_SUB+= PNG="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTIFF}
-LIB_DEPENDS+= libtiff.so:${PORTSDIR}/graphics/tiff
-PLIST_SUB+= TIFF=""
-.else
-CONFIGURE_ARGS+=--without-libtiff
-PLIST_SUB+= TIFF="@comment "
-.endif
-
post-install:
- @cd ${WRKSRC}/docs/reference/gdk-pixbuf && env DESTDIR=${STAGEDIR} ${MAKE_CMD} install-man1
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libgdk_pixbuf*-2.0.so.0
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/gdk-pixbuf-2.0/${GTK2_VERSION}/loaders/lib*.so
+ @cd ${WRKSRC}/docs/reference/gdk-pixbuf && env DESTDIR=${STAGEDIR} ${GMAKE} install-man1
.include <bsd.port.mk>