aboutsummaryrefslogtreecommitdiff
path: root/graphics/gdk-pixbuf
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /graphics/gdk-pixbuf
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'graphics/gdk-pixbuf')
-rw-r--r--graphics/gdk-pixbuf/Makefile4
-rw-r--r--graphics/gdk-pixbuf/files/patch-io-png.c29
2 files changed, 31 insertions, 2 deletions
diff --git a/graphics/gdk-pixbuf/Makefile b/graphics/gdk-pixbuf/Makefile
index 5f538988e7c3..d7fe1c7dd517 100644
--- a/graphics/gdk-pixbuf/Makefile
+++ b/graphics/gdk-pixbuf/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= gdk-pixbuf
PORTVERSION= 0.22.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES?= graphics
MASTER_SITES= GNOME
MASTER_SITE_SUBDIR= sources/gdk-pixbuf/0.22
@@ -17,7 +17,7 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT?= A graphic library for GTK+
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.11:${PORTSDIR}/graphics/jpeg
diff --git a/graphics/gdk-pixbuf/files/patch-io-png.c b/graphics/gdk-pixbuf/files/patch-io-png.c
new file mode 100644
index 000000000000..1c54d8b77770
--- /dev/null
+++ b/graphics/gdk-pixbuf/files/patch-io-png.c
@@ -0,0 +1,29 @@
+--- gdk-pixbuf/io-png.c.orig 2001-01-24 21:59:23.000000000 +0100
++++ gdk-pixbuf/io-png.c 2012-04-24 22:50:30.000000000 +0200
+@@ -175,7 +175,7 @@
+ return NULL;
+ }
+
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct (&png_ptr, &info_ptr, &end_info);
+ return NULL;
+ }
+@@ -311,7 +311,7 @@
+ return NULL;
+ }
+
+- if (setjmp (lc->png_read_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(lc->png_read_ptr))) {
+ if (lc->png_info_ptr)
+ png_destroy_read_struct(&lc->png_read_ptr, NULL, NULL);
+ g_free(lc);
+@@ -366,7 +366,7 @@
+ lc->max_row_seen_in_chunk = -1;
+
+ /* Invokes our callbacks as needed */
+- if (setjmp (lc->png_read_ptr->jmpbuf)) {
++ if (setjmp (png_jmpbuf(lc->png_read_ptr))) {
+ return FALSE;
+ } else {
+ png_process_data(lc->png_read_ptr, lc->png_info_ptr, buf, size);