aboutsummaryrefslogtreecommitdiff
path: root/graphics/geeqie/Makefile
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-11 03:05:44 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-11 03:05:44 +0000
commit3e8b4617b3d60d2ccdb0409824e3c96745657c68 (patch)
treed80e900ee89535fa0abf660640e8a40eb4901ec5 /graphics/geeqie/Makefile
parent2a1cfeed8c92104c5d51b867146325720371b103 (diff)
downloadports-3e8b4617b3d60d2ccdb0409824e3c96745657c68.tar.gz
ports-3e8b4617b3d60d2ccdb0409824e3c96745657c68.zip
Notes
Diffstat (limited to 'graphics/geeqie/Makefile')
-rw-r--r--graphics/geeqie/Makefile28
1 files changed, 19 insertions, 9 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 603a485e9ff8..e5a06cd7f88d 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -1,17 +1,16 @@
# New ports collection makefile for: graphics/geeqie
# Date created: 17 May 2008
-# Whom: Martin Tournoij <carpetsmoker@xs4all.nl>
+# Whom: Martin Tournoij <carpetsmoker@rwxrwxrwx.net>
#
-# $Carpetsmoker: ports/graphics/geeqie/Makefile,v 1.2 2008/05/17 19:35:22 carpetsmoker Exp $
# $FreeBSD$
#
PORTNAME= geeqie
-DISTVERSION= 1.0alpha1
+DISTVERSION= 1.0alpha3
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= carpetsmoker@xs4all.nl
+MAINTAINER= carpetsmoker@rwxrwxrwx.net
COMMENT= Lightweight image viewer forked from GQview
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
@@ -22,29 +21,40 @@ CONFIGURE_ARGS= --docdir="${DOCSDIR}" \
--htmldir="${DOCSDIR}/html" \
--with-htmldir="${DOCSDIR}/html" \
--with-readmedir="${DOCSDIR}"
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CFLAGS}" LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ARGS+= top_builddir="${WRKSRC}"
PORTDOCS= *
-
MAN1= geeqie.1
+USE_GETTEXT= yes
OPTIONS= EXIV2 "Enable EXIV2 for metadata editing" on \
LCMS "Enable LCMS for color adjusting" on
+# Build fails with lirc enabled, disable it for now
+# LIRC "Enable lirc for remote control" off
.include <bsd.port.pre.mk>
.if defined(WITH_EXIV2)
LIB_DEPENDS+= exiv2.3:${PORTSDIR}/graphics/exiv2
-CONFIGURE_ARGS+=--with-exiv2
+CONFIGURE_ARGS+=--enable-exiv2
.else
-CONFIGURE_ARGS+=--without-exiv2
+CONFIGURE_ARGS+=--disable-exiv2
.endif
.if defined(WITH_LCMS)
LIB_DEPENDS+= lcms.1:${PORTSDIR}/graphics/lcms
-CONFIGURE_ARGS+=--with-lcms
+CONFIGURE_ARGS+=--enable-lcms
+.else
+CONFIGURE_ARGS+=--disable-lcms
+.endif
+
+.if defined(WITH_LIRC)
+LIB_DEPENDS+= lirc_client.1:${PORTSDIR}/comms/lirc
+CONFIGURE_ARGS+=--enable-lirc
.else
-CONFIGURE_ARGS+=--without-lcms
+CONFIGURE_ARGS+=--disable-lirc
.endif
post-patch: