aboutsummaryrefslogtreecommitdiff
path: root/graphics/geeqie
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-29 12:37:54 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-29 12:37:54 +0000
commit292f409addd9b3436ee0e716261cd953085d0808 (patch)
tree3109eb1d2b3f2cd142cd9e9b4ac84cb5e3eaf2a7 /graphics/geeqie
parent8b563fc71d026c0c004003a9f58728312481adee (diff)
downloadports-292f409addd9b3436ee0e716261cd953085d0808.tar.gz
ports-292f409addd9b3436ee0e716261cd953085d0808.zip
Notes
Diffstat (limited to 'graphics/geeqie')
-rw-r--r--graphics/geeqie/Makefile42
-rw-r--r--graphics/geeqie/distinfo6
-rw-r--r--graphics/geeqie/files/patch-Makefile.am10
-rw-r--r--graphics/geeqie/files/patch-configure.ac20
-rw-r--r--graphics/geeqie/files/patch-configure.in15
-rw-r--r--graphics/geeqie/files/patch-plugins_ufraw_geeqie-ufraw35
-rw-r--r--graphics/geeqie/files/patch-src_layout__util.c11
-rw-r--r--graphics/geeqie/pkg-plist90
8 files changed, 106 insertions, 123 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 8d2ce82334c2..1d2d96dd14af 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geeqie
-PORTVERSION= 1.4
-PORTREVISION= 5
+PORTVERSION= 1.5.1
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
@@ -14,24 +13,27 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpng.so:graphics/png
+RUN_DEPENDS= bash:shells/bash
USES= autoreconf compiler:c++11-lang gettext gmake gnome jpeg \
- localbase pkgconfig desktop-file-utils tar:xz lua:51
+ localbase pkgconfig desktop-file-utils tar:xz lua:53 shebangfix
USE_GNOME= intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readmedir="${DOCSDIR}"
+SHEBANG_FILES= plugins/*/geeqie-*
PORTDOCS= *
-OPTIONS_DEFINE= EXIV2 LCMS LIRC GPS TIFF DOCS
-OPTIONS_DEFAULT=EXIV2 LCMS GTK2
+OPTIONS_DEFINE= EXIV2 LCMS LIRC MAP TIFF PDF FFMPEGTHUMBNAILER DOCS NLS
+OPTIONS_DEFAULT=EXIV2 LCMS GTK3 PDF FFMPEGTHUMBNAILER
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT=GTK2 GTK3
+OPTIONS_SUB= yes
EXIV2_DESC= Metadata editing
LCMS_DESC= Color adjusting
-LIRC_DESC= Remote control
-GPS_DESC= GPS map support via libchamplain (experimental!)
+LIRC_DESC= Remote control (broken)
+MAP_DESC= GPS map support via libchamplain
TOOLKIT_DESC= Graphical user interface toolkit
GTK2_DESC= Use GTK 2
GTK3_DESC= Use GTK 3
@@ -45,10 +47,12 @@ LCMS_CONFIGURE_ENABLE= lcms
LIRC_LIB_DEPENDS= liblirc_client.so:comms/lirc
LIRC_CONFIGURE_ENABLE= lirc
LIRC_CONFIGURE_ON= --with-lirc-prefix="${LOCALBASE}"
+LIRC_BROKEN= does not build with old lirc from ports
-GPS_LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
+MAP_LIB_DEPENDS= libchamplain-0.12.so:graphics/libchamplain \
libclutter-gtk-1.0.so:graphics/clutter-gtk3
-GPS_CONFIGURE_ENABLE= map gpu-accell
+MAP_CONFIGURE_ENABLE= map gpu-accel
+MAP_REQUIRES= GTK3
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
TIFF_CONFIGURE_ENABLE= tiff
@@ -56,15 +60,15 @@ TIFF_CONFIGURE_ENABLE= tiff
GTK2_USE= GNOME=gtk20
GTK3_USE= GNOME=gtk30
GTK3_CONFIGURE_ENABLE= gtk3
-GTK3_PREVENTS= GPS
-GTK3_PREVENTS_MSG= GPS option does not support GTK3 yet
-
-post-patch:
- @${REINPLACE_CMD} -e 's| -r %F||' ${WRKSRC}/geeqie.desktop.in
- @${REINPLACE_CMD} -e '/readme_DATA/ s|COPYING||' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|lua5.1|lua-5.1|' ${WRKSRC}/configure.in
-# I cannot get gnome-doc-tool working properly: Outputs gibberish
- @${REINPLACE_CMD} -Ee '/^(SUBDIRS|DIST_SUBDIRS)/ s|doc||' \
- ${WRKSRC}/Makefile.am
+
+PDF_LIB_DEPENDS= libpoppler-glib.so:graphics/poppler-glib
+PDF_CONFIGURE_ENABLE= pdf
+PDF_REQUIRES= GTK3
+
+FFMPEGTHUMBNAILER_DESC= Video file thumbnails generating support
+FFMPEGTHUMBNAILER_CONFIGURE_ENABLE= ffmpegthumbnailer
+FFMPEGTHUMBNAILER_LIB_DEPENDS= libffmpegthumbnailer.so:multimedia/ffmpegthumbnailer
+
+NLS_CONFIGURE_ENABLE= nls
.include <bsd.port.mk>
diff --git a/graphics/geeqie/distinfo b/graphics/geeqie/distinfo
index bafe0b5ed53f..f3c35be71ba3 100644
--- a/graphics/geeqie/distinfo
+++ b/graphics/geeqie/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1515356766
-SHA256 (geeqie-1.4.tar.xz) = 5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32
-SIZE (geeqie-1.4.tar.xz) = 35881152
+TIMESTAMP = 1566422244
+SHA256 (geeqie-1.5.1.tar.xz) = 4854d5d323c31f8f4068fd73ab2c454ff91e826c4ca4d37b22c246ad14dea10a
+SIZE (geeqie-1.5.1.tar.xz) = 1587116
diff --git a/graphics/geeqie/files/patch-Makefile.am b/graphics/geeqie/files/patch-Makefile.am
index 8acd2c18e81c..37a435fce8e6 100644
--- a/graphics/geeqie/files/patch-Makefile.am
+++ b/graphics/geeqie/files/patch-Makefile.am
@@ -1,11 +1,9 @@
---- Makefile.am.orig 2017-12-31 12:31:21 UTC
+Don't install changelogs for they're too heavy and are a git logs (instead of real changelogs) anyway
+--- Makefile.am.orig 2019-07-26 18:19:11 UTC
+++ Makefile.am
-@@ -10,9 +10,9 @@ man_MANS = geeqie.1
- readmedir = @readmedir@
-
+@@ -12,7 +12,7 @@ readmedir = @readmedir@
if HAVE_MARKDOWN
--readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS README.html ChangeLog.html
-+readme_DATA = README.md TODO README.lirc AUTHORS
+ readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS README.html ChangeLog.html
else
-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS ChangeLog.html
+readme_DATA = README.md TODO README.lirc AUTHORS
diff --git a/graphics/geeqie/files/patch-configure.ac b/graphics/geeqie/files/patch-configure.ac
new file mode 100644
index 000000000000..9f91619b1723
--- /dev/null
+++ b/graphics/geeqie/files/patch-configure.ac
@@ -0,0 +1,20 @@
+--- configure.ac.orig 2019-08-20 19:01:23 UTC
++++ configure.ac
+@@ -518,7 +518,7 @@ AC_ARG_ENABLE([lua],
+ [liblua=$enableval], [liblua=auto])
+
+ if test "x${liblua}" != "xno"; then
+- PKG_CHECK_MODULES(LUA, lua5.3 >= 5.3,
++ PKG_CHECK_MODULES(LUA, lua-5.3 >= 5.3,
+ [
+ HAVE_LUA=yes
+ AC_DEFINE(HAVE_LUA, 1, [define to enable lua support])
+@@ -581,7 +581,7 @@ AC_SUBST(PDF_LIBS)
+ # Markdown support
+ # ----------------------------------------------------------------------
+
+-AM_CONDITIONAL(HAVE_MARKDOWN, [ "$(command -v markdown)" ])
++AM_CONDITIONAL(HAVE_MARKDOWN, [ "$(false)" ])
+
+ # _NL_TIME_FIRST_WEEKDAY support
+ # note that it is an enum and not a define
diff --git a/graphics/geeqie/files/patch-configure.in b/graphics/geeqie/files/patch-configure.in
deleted file mode 100644
index d43d2843179f..000000000000
--- a/graphics/geeqie/files/patch-configure.in
+++ /dev/null
@@ -1,15 +0,0 @@
---- configure.in.orig 2017-11-27 13:02:57 UTC
-+++ configure.in
-@@ -277,7 +277,11 @@ for dir in `echo "$withval" | tr : ' '`;
- HAVE_LIRC=no
- if test "x${lirc}" != "xno" ; then
- AC_CHECK_HEADER(lirc/lirc_client.h,
-- [AC_CHECK_LIB(lirc_client,lirc_init,[HAVE_LIRC=yes;LIBS=-llirc_client $LIBS;AC_DEFINE([HAVE_LIRC],[],[Define to 1 if LIRC must be used])],,)],)
-+ [AC_CHECK_LIB(lirc_client,lirc_init,[
-+ HAVE_LIRC=yes
-+ LIBS="-llirc_client $LIBS"
-+ AC_DEFINE([HAVE_LIRC],[],[Define to 1 if LIRC must be used])
-+ ],,)],)
- fi
- AM_CONDITIONAL(HAVE_LIRC, [test "x$HAVE_LIRC" = xyes])
-
diff --git a/graphics/geeqie/files/patch-plugins_ufraw_geeqie-ufraw b/graphics/geeqie/files/patch-plugins_ufraw_geeqie-ufraw
deleted file mode 100644
index 10a4cb04a826..000000000000
--- a/graphics/geeqie/files/patch-plugins_ufraw_geeqie-ufraw
+++ /dev/null
@@ -1,35 +0,0 @@
---- plugins/ufraw/geeqie-ufraw.orig 2016-03-07 10:21:06 UTC
-+++ plugins/ufraw/geeqie-ufraw
-@@ -37,7 +37,7 @@ add_xmp_from_sidecar ()
-
- basename=${input%.*}
- dirname=${basename%/*}
-- xmp=`find "$dirname" -maxdepth 1 -path "$basename.*" -regextype posix-egrep -iregex "$XMP_REGEX" -print | head -n 1`
-+ xmp=`find -E "$dirname" -maxdepth 1 -path "$basename.*" -iregex "$XMP_REGEX" -print | head -n 1`
- [ -f "$xmp" ] || return 1
-
- output=`get_output_from_id "$idfile"`
-@@ -75,7 +75,7 @@ raw_file_not_processed ()
- rawfile=$1
- basename=${rawfile%.*}
- dirname=${basename%/*}
-- outfiles=`find "$dirname" -maxdepth 1 -path "$basename.*" -regextype posix-egrep \( -iregex "$OUT_REGEX" -o -regex "$ID_REGEX" \) -print `
-+ outfiles=`find -E "$dirname" -maxdepth 1 -path "$basename.*" \( -iregex "$OUT_REGEX" -o -regex "$ID_REGEX" \) -print `
- [ -z "$outfiles" ] # return true if no possible output file exists
-
- # raw+jpeg pair created by the camera is considered processed,
-@@ -136,12 +136,12 @@ process_tree ()
- {
- list=`mktemp /tmp/geeqie-ufraw-list.XXXXXXXXXX` || exit 1
-
-- find "$@" -regextype posix-egrep -iregex "$RAW_REGEX" -print | while read rawfile ; do
-+ find -E "$@" -iregex "$RAW_REGEX" -print | while read rawfile ; do
- raw_file_not_processed "$rawfile" && echo "$rawfile"
- done >>$list
-
- #refresh output from changed id files
-- find "$@" -regextype posix-egrep -regex "$ID_REGEX" -print | while read idfile ; do
-+ find -E "$@" -regex "$ID_REGEX" -print | while read idfile ; do
- id_file_changed "$idfile" && echo "$idfile"
- done >>$list
-
diff --git a/graphics/geeqie/files/patch-src_layout__util.c b/graphics/geeqie/files/patch-src_layout__util.c
index c760ee9546ba..8a6b0825fc58 100644
--- a/graphics/geeqie/files/patch-src_layout__util.c
+++ b/graphics/geeqie/files/patch-src_layout__util.c
@@ -1,10 +1,11 @@
---- src/layout_util.c.orig 2017-12-31 12:31:21 UTC
+--- src/layout_util.c.orig 2019-07-26 18:19:11 UTC
+++ src/layout_util.c
-@@ -59,6 +59,7 @@
- #include "desktop_file.h"
-
+@@ -62,6 +62,8 @@
#include <gdk/gdkkeysyms.h> /* for keyboard values */
-+#include <sys/wait.h> /* for WEXITSTATUS */
#include "keymap_template.c"
++#include <sys/wait.h> /* for WEXITSTATUS */
++
#define MENU_EDIT_ACTION_OFFSET 16
+ #define FILE_COLUMN_POINTER 0
+
diff --git a/graphics/geeqie/pkg-plist b/graphics/geeqie/pkg-plist
index 06e2d67ca387..10cddc97d9a6 100644
--- a/graphics/geeqie/pkg-plist
+++ b/graphics/geeqie/pkg-plist
@@ -1,54 +1,64 @@
bin/geeqie
-lib/geeqie/geeqie-import
lib/geeqie/geeqie-rotate
lib/geeqie/geeqie-symlink
lib/geeqie/geeqie-ufraw
lib/geeqie/geocode-parameters.awk
+lib/geeqie/geeqie-camera-import
+lib/geeqie/geeqie-camera-import-hook-script
+lib/geeqie/geeqie-export-jpeg
+lib/geeqie/geeqie-image-crop
+lib/geeqie/geeqie-random-image
+lib/geeqie/geeqie-tethered-photography
+lib/geeqie/geeqie-tethered-photography-hook-script
man/man1/geeqie.1.gz
share/applications/geeqie.desktop
-%%DATADIR%%/applications/geeqie-import-geeqie.desktop
-%%DATADIR%%/applications/geeqie-import-gqview.desktop
+%%DATADIR%%/applications/camera-import.desktop
+%%DATADIR%%/applications/export-jpeg.desktop
%%DATADIR%%/applications/geeqie-ufraw-id.desktop
%%DATADIR%%/applications/geeqie-ufraw-recursive.desktop
%%DATADIR%%/applications/geeqie-ufraw.desktop
+%%DATADIR%%/applications/image-crop.desktop
+%%DATADIR%%/applications/random-image.desktop
%%DATADIR%%/applications/rotate.desktop
%%DATADIR%%/applications/symlink.desktop
+%%DATADIR%%/applications/tethered-photography.desktop
%%DATADIR%%/template.desktop
-share/locale/ar/LC_MESSAGES/geeqie.mo
-share/locale/be/LC_MESSAGES/geeqie.mo
-share/locale/bg/LC_MESSAGES/geeqie.mo
-share/locale/ca/LC_MESSAGES/geeqie.mo
-share/locale/cs/LC_MESSAGES/geeqie.mo
-share/locale/da/LC_MESSAGES/geeqie.mo
-share/locale/de/LC_MESSAGES/geeqie.mo
-share/locale/el/LC_MESSAGES/geeqie.mo
-share/locale/eo/LC_MESSAGES/geeqie.mo
-share/locale/es/LC_MESSAGES/geeqie.mo
-share/locale/et/LC_MESSAGES/geeqie.mo
-share/locale/eu/LC_MESSAGES/geeqie.mo
-share/locale/fi/LC_MESSAGES/geeqie.mo
-share/locale/fr/LC_MESSAGES/geeqie.mo
-share/locale/hu/LC_MESSAGES/geeqie.mo
-share/locale/id/LC_MESSAGES/geeqie.mo
-share/locale/it/LC_MESSAGES/geeqie.mo
-share/locale/ja/LC_MESSAGES/geeqie.mo
-share/locale/ko/LC_MESSAGES/geeqie.mo
-share/locale/nb/LC_MESSAGES/geeqie.mo
-share/locale/nl/LC_MESSAGES/geeqie.mo
-share/locale/pl/LC_MESSAGES/geeqie.mo
-share/locale/pt_BR/LC_MESSAGES/geeqie.mo
-share/locale/ro/LC_MESSAGES/geeqie.mo
-share/locale/ru/LC_MESSAGES/geeqie.mo
-share/locale/sk/LC_MESSAGES/geeqie.mo
-share/locale/sl/LC_MESSAGES/geeqie.mo
-share/locale/sr/LC_MESSAGES/geeqie.mo
-share/locale/sr@latin/LC_MESSAGES/geeqie.mo
-share/locale/sv/LC_MESSAGES/geeqie.mo
-share/locale/th/LC_MESSAGES/geeqie.mo
-share/locale/tlh/LC_MESSAGES/geeqie.mo
-share/locale/tr/LC_MESSAGES/geeqie.mo
-share/locale/uk/LC_MESSAGES/geeqie.mo
-share/locale/vi/LC_MESSAGES/geeqie.mo
-share/locale/zh_CN/LC_MESSAGES/geeqie.mo
-share/locale/zh_TW/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/be/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/da/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/de/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/el/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/es/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/et/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/id/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/it/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/th/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/tlh/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/geeqie.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/geeqie.mo
share/pixmaps/geeqie.png