aboutsummaryrefslogtreecommitdiff
path: root/graphics/geeqie
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-04 18:22:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2020-12-04 18:22:22 +0000
commit748833764dab4c0c1aa6136e23d984f3a6e3d168 (patch)
tree0146a17edd714de1cd5c14bcb8ffaf37a5f1d2bb /graphics/geeqie
parentd8d9c2496366ed552332b249c3fe41c409734445 (diff)
downloadports-748833764dab4c0c1aa6136e23d984f3a6e3d168.tar.gz
ports-748833764dab4c0c1aa6136e23d984f3a6e3d168.zip
Notes
Diffstat (limited to 'graphics/geeqie')
-rw-r--r--graphics/geeqie/Makefile23
-rw-r--r--graphics/geeqie/distinfo6
-rw-r--r--graphics/geeqie/files/patch-Makefile.am2
-rw-r--r--graphics/geeqie/files/patch-configure.ac6
-rw-r--r--graphics/geeqie/files/patch-options.c12
-rw-r--r--graphics/geeqie/files/patch-options.h13
-rw-r--r--graphics/geeqie/files/patch-src_layout__util.c11
-rw-r--r--graphics/geeqie/pkg-plist2
8 files changed, 25 insertions, 50 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index 9d5993923a73..80cf00e45cbf 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geeqie
-PORTVERSION= 1.5.1
-PORTREVISION= 12
+PORTVERSION= 1.6
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/
@@ -23,12 +22,13 @@ USES= autoreconf compiler:c++11-lang gettext gmake gnome jpeg \
USE_GNOME= intltool
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-readmedir="${DOCSDIR}"
+CONFIGURE_ARGS+=--disable-j2k # not in ports (yet), disable proactively to avoid hidden dependency
SHEBANG_FILES= plugins/*/geeqie-*
PORTDOCS= *
-OPTIONS_DEFINE= EXIV2 LCMS LIRC MAP TIFF PDF FFMPEGTHUMBNAILER DOCS NLS
-OPTIONS_DEFAULT=EXIV2 LCMS GTK3 PDF FFMPEGTHUMBNAILER
+OPTIONS_DEFINE= EXIV2 LCMS LIRC MAP TIFF PDF FFMPEGTHUMBNAILER DOCS NLS HEIF WEBP DJVU OPENJPEG
+OPTIONS_DEFAULT=EXIV2 LCMS GTK3 PDF FFMPEGTHUMBNAILER HEIF WEBP DJVU OPENJPEG
OPTIONS_SINGLE= TOOLKIT
OPTIONS_SINGLE_TOOLKIT=GTK2 GTK3
OPTIONS_SUB= yes
@@ -40,6 +40,7 @@ MAP_DESC= GPS map support via libchamplain
TOOLKIT_DESC= Graphical user interface toolkit
GTK2_DESC= Use GTK 2
GTK3_DESC= Use GTK 3
+HEIF_DESC= HEIF image format support
EXIV2_LIB_DEPENDS= libexiv2.so:graphics/exiv2
EXIV2_CONFIGURE_ENABLE= exiv2
@@ -74,8 +75,16 @@ FFMPEGTHUMBNAILER_LIB_DEPENDS= libffmpegthumbnailer.so:multimedia/ffmpegthumbnai
NLS_CONFIGURE_ENABLE= nls
-pre-build:
- # fixes threaded build
- @cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} gq-marshal.c
+HEIF_CONFIGURE_ENABLE= heif
+HEIF_LIB_DEPENDS= libheif.so:graphics/libheif
+
+WEBP_CONFIGURE_ENABLE= webp
+WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
+
+DJVU_CONFIGURE_ENABLE= djvu
+DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
+
+OPENJPEG_CONFIGURE_ENABLE= j2k
+OPENJPEG_LIB_DEPENDS= libopenjp2.so:graphics/openjpeg
.include <bsd.port.mk>
diff --git a/graphics/geeqie/distinfo b/graphics/geeqie/distinfo
index f3c35be71ba3..ca18b7a41cec 100644
--- a/graphics/geeqie/distinfo
+++ b/graphics/geeqie/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1566422244
-SHA256 (geeqie-1.5.1.tar.xz) = 4854d5d323c31f8f4068fd73ab2c454ff91e826c4ca4d37b22c246ad14dea10a
-SIZE (geeqie-1.5.1.tar.xz) = 1587116
+TIMESTAMP = 1606937789
+SHA256 (geeqie-1.6.tar.xz) = 48f8a4474454d182353100e43878754b76227f3b8f30cfc258afc9d90a4e1920
+SIZE (geeqie-1.6.tar.xz) = 1693488
diff --git a/graphics/geeqie/files/patch-Makefile.am b/graphics/geeqie/files/patch-Makefile.am
index 4bd94c141248..00d7be3edc8c 100644
--- a/graphics/geeqie/files/patch-Makefile.am
+++ b/graphics/geeqie/files/patch-Makefile.am
@@ -1,4 +1,4 @@
---- Makefile.am.orig 2019-08-20 19:01:23 UTC
+--- Makefile.am.orig 2020-11-20 21:36:33 UTC
+++ Makefile.am
@@ -2,8 +2,8 @@
diff --git a/graphics/geeqie/files/patch-configure.ac b/graphics/geeqie/files/patch-configure.ac
index 9f91619b1723..4f2ee4b8933e 100644
--- a/graphics/geeqie/files/patch-configure.ac
+++ b/graphics/geeqie/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2019-08-20 19:01:23 UTC
+--- configure.ac.orig 2020-11-20 21:36:33 UTC
+++ configure.ac
-@@ -518,7 +518,7 @@ AC_ARG_ENABLE([lua],
+@@ -525,7 +525,7 @@ AC_ARG_ENABLE([lua],
[liblua=$enableval], [liblua=auto])
if test "x${liblua}" != "xno"; then
@@ -9,7 +9,7 @@
[
HAVE_LUA=yes
AC_DEFINE(HAVE_LUA, 1, [define to enable lua support])
-@@ -581,7 +581,7 @@ AC_SUBST(PDF_LIBS)
+@@ -688,7 +688,7 @@ AC_SUBST(DJVU_LIBS)
# Markdown support
# ----------------------------------------------------------------------
diff --git a/graphics/geeqie/files/patch-options.c b/graphics/geeqie/files/patch-options.c
deleted file mode 100644
index 71094c6a6166..000000000000
--- a/graphics/geeqie/files/patch-options.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/options.c.orig 2019-08-20 19:01:23 UTC
-+++ src/options.c
-@@ -32,6 +32,9 @@
- #include "ui_fileops.h"
- #include "window.h"
-
-+ConfOptions *options;
-+CommandLine *command_line;
-+
- ConfOptions *init_options(ConfOptions *options)
- {
- gint i;
diff --git a/graphics/geeqie/files/patch-options.h b/graphics/geeqie/files/patch-options.h
deleted file mode 100644
index ffec06f4e03b..000000000000
--- a/graphics/geeqie/files/patch-options.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/options.h.orig 2019-08-20 19:01:23 UTC
-+++ src/options.h
-@@ -321,8 +321,8 @@ struct _ConfOptions
- GList *disabled_plugins;
- };
-
--ConfOptions *options;
--CommandLine *command_line;
-+extern ConfOptions *options;
-+extern CommandLine *command_line;
-
- ConfOptions *init_options(ConfOptions *options);
- void setup_default_options(ConfOptions *options);
diff --git a/graphics/geeqie/files/patch-src_layout__util.c b/graphics/geeqie/files/patch-src_layout__util.c
deleted file mode 100644
index 8a6b0825fc58..000000000000
--- a/graphics/geeqie/files/patch-src_layout__util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/layout_util.c.orig 2019-07-26 18:19:11 UTC
-+++ src/layout_util.c
-@@ -62,6 +62,8 @@
- #include <gdk/gdkkeysyms.h> /* for keyboard values */
- #include "keymap_template.c"
-
-+#include <sys/wait.h> /* for WEXITSTATUS */
-+
- #define MENU_EDIT_ACTION_OFFSET 16
- #define FILE_COLUMN_POINTER 0
-
diff --git a/graphics/geeqie/pkg-plist b/graphics/geeqie/pkg-plist
index 10cddc97d9a6..ca690c49dab7 100644
--- a/graphics/geeqie/pkg-plist
+++ b/graphics/geeqie/pkg-plist
@@ -10,6 +10,7 @@ lib/geeqie/geeqie-image-crop
lib/geeqie/geeqie-random-image
lib/geeqie/geeqie-tethered-photography
lib/geeqie/geeqie-tethered-photography-hook-script
+lib/geeqie/lensID
man/man1/geeqie.1.gz
share/applications/geeqie.desktop
%%DATADIR%%/applications/camera-import.desktop
@@ -61,4 +62,5 @@ share/applications/geeqie.desktop
%%NLS%%share/locale/vi/LC_MESSAGES/geeqie.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/geeqie.mo
%%NLS%%share/locale/zh_TW/LC_MESSAGES/geeqie.mo
+share/metainfo/org.geeqie.Geeqie.appdata.xml
share/pixmaps/geeqie.png