aboutsummaryrefslogtreecommitdiff
path: root/graphics/geeqie
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-25 01:36:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2013-09-25 01:36:57 +0000
commitdb96368acc9c15b9b105bc6fb99a1b9fa693d627 (patch)
treecde801ab3d4912600cc090c24b2630220d7407d5 /graphics/geeqie
parent5738084bd977a9f8415c641506d9985cb331627a (diff)
downloadports-db96368acc9c15b9b105bc6fb99a1b9fa693d627.tar.gz
ports-db96368acc9c15b9b105bc6fb99a1b9fa693d627.zip
Notes
Diffstat (limited to 'graphics/geeqie')
-rw-r--r--graphics/geeqie/Makefile53
-rw-r--r--graphics/geeqie/pkg-plist1
2 files changed, 16 insertions, 38 deletions
diff --git a/graphics/geeqie/Makefile b/graphics/geeqie/Makefile
index f7dd95065339..fbec6f23a116 100644
--- a/graphics/geeqie/Makefile
+++ b/graphics/geeqie/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Lightweight image viewer forked from GQview
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
USE_GNOME= gtk20 desktopfileutils
GNU_CONFIGURE= yes
@@ -17,65 +17,42 @@ CONFIGURE_ARGS= --docdir="${DOCSDIR}" \
--htmldir="${DOCSDIR}/html" \
--with-htmldir="${DOCSDIR}/html" \
--with-readmedir="${DOCSDIR}"
+USES= gettext gmake pkgconfig
+
CFLAGS+= -I${LOCALBASE}/include
CPPFLAGS+= ${CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= top_builddir="${WRKSRC}"
PORTDOCS= *
-MAN1= geeqie.1
-USES= gettext gmake pkgconfig
OPTIONS_DEFINE= EXIV2 LCMS LIRC GPS DOCS
-OPTIONS_DEFAULT=EXIV2 LCMS
+OPTIONS_DEFAULT=EXIV2 LCMS DOCS
EXIV2_DESC= Metadata editing
LCMS_DESC= Color adjusting
LIRC_DESC= Remote control
GPS_DESC= GPS map support (libchamplain) EXPERIMENTAL
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+EXIV2_LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2
+EXIV2_CONFIGURE_ENABLE= exiv2
-.if ${PORT_OPTIONS:MEXIV2}
-LIB_DEPENDS+= exiv2:${PORTSDIR}/graphics/exiv2
-CONFIGURE_ARGS+=--enable-exiv2
-.else
-CONFIGURE_ARGS+=--disable-exiv2
-.endif
+LCMS_LIB_DEPENDS= liblcms.so:${PORTSDIR}/graphics/lcms
+LCMS_CONFIGURE_ENABLE= lcms
-.if ${PORT_OPTIONS:MLCMS}
-LIB_DEPENDS+= lcms:${PORTSDIR}/graphics/lcms
-CONFIGURE_ARGS+=--enable-lcms
-.else
-CONFIGURE_ARGS+=--disable-lcms
-.endif
+LIRC_LIB_DEPENDS= liblirc_client.so:${PORTSDIR}/comms/lirc
+LIRC_CONFIGURE_ENABLE= lirc
-.if ${PORT_OPTIONS:MLIRC}
-LIB_DEPENDS+= lirc_client:${PORTSDIR}/comms/lirc
-CONFIGURE_ARGS+=--enable-lirc
-.else
-CONFIGURE_ARGS+=--disable-lirc
-.endif
-
-# Support for libchamplain is marked as experimental!
-.if ${PORT_OPTIONS:MGPS}
-LIB_DEPENDS+= champlain-0.8:${PORTSDIR}/graphics/libchamplain
-CONFIGURE_ARGS+=--enable-gps
-.else
-CONFIGURE_ARGS+=--disable-gps
-.endif
+GPS_LIB_DEPENDS= libchamplain-0.8.so:${PORTSDIR}/graphics/libchamplain
+GPS_CONFIGURE_ENABLE= gps
post-patch:
+ @${REINPLACE_CMD} -e 's|champlain-0\.4|champlain-0.8|g; \
+ s|champlain-gtk-0\.4|champlain-gtk-0.8|g' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|MAP_ANONYMOUS|MAP_ANON|' ${WRKSRC}/src/main.c
@${REINPLACE_CMD} -e 's| -r %F||' ${WRKSRC}/geeqie.desktop
# I cannot get gnome-doc-tool working properly: Outputs gibberish
@${REINPLACE_CMD} -Ee '/^(SUBDIRS|DIST_SUBDIRS)/ s|doc||' \
${WRKSRC}/Makefile.in
-.if ! ${PORT_OPTIONS:MDOCS}
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-helpDATA||' \
- ${WRKSRC}/doc/Makefile.in
- @${REINPLACE_CMD} -e '/^install-data-am:/,/^[a-z]/ s|install-readmeDATA||' \
- ${WRKSRC}/Makefile.in
-.endif
.include <bsd.port.mk>
diff --git a/graphics/geeqie/pkg-plist b/graphics/geeqie/pkg-plist
index 9386e23e39d4..5516b6bd4c0a 100644
--- a/graphics/geeqie/pkg-plist
+++ b/graphics/geeqie/pkg-plist
@@ -3,6 +3,7 @@ lib/geeqie/geeqie-import
lib/geeqie/geeqie-rotate
lib/geeqie/geeqie-symlink
lib/geeqie/geeqie-ufraw
+man/man1/geeqie.1.gz
share/applications/geeqie.desktop
%%DATADIR%%/applications/geeqie-import-geeqie.desktop
%%DATADIR%%/applications/geeqie-import-gqview.desktop