aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-07-25 21:46:22 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-07-25 21:46:22 +0000
commit9057d20bd5072ec061d43ce0799a8a3e0b02aaf5 (patch)
treef62f94d7eb1a909e2d6d491358110845074befa3 /graphics/gegl/Makefile
parentd1767d6d0e2a97aa2982c3b8eb5af003d1555aa9 (diff)
downloadports-9057d20bd5072ec061d43ce0799a8a3e0b02aaf5.tar.gz
ports-9057d20bd5072ec061d43ce0799a8a3e0b02aaf5.zip
Notes
Diffstat (limited to 'graphics/gegl/Makefile')
-rw-r--r--graphics/gegl/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 5f048fc946c7..7df92811f48f 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -219,10 +219,11 @@ post-patch:
.if ${PORT_OPTIONS:MDOCS}
pre-configure:
-.if !exists(${LOCALBASE}/bin/vimdot)
- @${ECHO_CMD} "${PKGNAME}: Needs graphics/graphviz with PANGOCAIRO support enabled."
- @${FALSE}
-.endif
+# .if !exists() evaluates too early before graphviz has a chance to be installed
+ @if ! hash vimdot 2>/dev/null; then \
+ ${ECHO_MSG} "${PKGNAME}: Needs graphics/graphviz with PANGOCAIRO support enabled."; \
+ ${FALSE}; \
+ fi
.endif
post-build: