aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-06-17 19:26:33 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-06-17 19:26:33 +0000
commit94fad015f48424ecd3774823a49131507c90ac0f (patch)
treebca750886397735bded166a7452a0d00602d5b98 /graphics/gegl
parenta21de85869628a198d2e787cf5627dcbfc8c24d8 (diff)
downloadports-94fad015f48424ecd3774823a49131507c90ac0f.tar.gz
ports-94fad015f48424ecd3774823a49131507c90ac0f.zip
Notes
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile22
-rw-r--r--graphics/gegl/files/patch-tools_create-reference.rb14
-rw-r--r--graphics/gegl/pkg-plist21
3 files changed, 27 insertions, 30 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 09e32590dde3..69368e7267c4 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gegl
PORTVERSION= 0.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.2/
@@ -22,13 +22,13 @@ SPIRO_DESC= Spiro support
#UMFPACK_DESC= UMFpack support
USE_GNOME= glib20 intltool
-USES= pathfix pkgconfig gettext
+USES= gettext pathfix pkgconfig shebangfix
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= ${PREFIX}/lib/gegl-0.2
GNU_CONFIGURE= yes
CONFIGURE_ENV+= ac_cv_header_execinfo_h=no
-CONFIGURE_ARGS+=--without-vala
+CONFIGURE_ARGS+=--without-vala --disable-docs
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lintl
@@ -40,6 +40,8 @@ EXAMPLES= 2geglbuffer csugar float-lookup \
gegl-convert gegl-slicer geglbuffer-add-image \
geglbuffer-clock hello-world-video hello-world
+SHEBANG_FILES= tools/xml_insert.sh
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPIXBUF}
@@ -191,20 +193,21 @@ PLIST_SUB+= EXIV2="@comment "
.if ${PORT_OPTIONS:MDOCS}
BUILD_DEPENDS+= a2x:${PORTSDIR}/textproc/asciidoc \
+ ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash \
vimdot:${PORTSDIR}/graphics/graphviz
+USE_RUBY= yes
+RUBY_NO_RUN_DEPENDS=yes
.else
CONFIGURE_ARGS+=--disable-docs
.endif
post-patch:
-.if empty(PORT_OPTIONS:MDOCS)
- ${REINPLACE_CMD} -e '10s|\\||; 11,13d' \
- ${WRKSRC}/Makefile.am
+.if ! ${PORT_OPTIONS:MDOCS}
+ ${REINPLACE_CMD} -e 's|tools examples|tools|g' \
+ ${WRKSRC}/Makefile.in
.endif
${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g ; s|x86_64|amd64|g' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|/usr/bin/ruby|/usr/bin/env ruby|' \
- ${WRKSRC}/tools/gobj2dot.rb
.if ${PORT_OPTIONS:MDOCS}
pre-configure:
@@ -216,7 +219,8 @@ pre-configure:
post-build:
.if ${PORT_OPTIONS:MDOCS}
- cd ${WRKSRC}/docs && ${GMAKE}
+ cd ${WRKSRC}/docs && ${GMAKE} index.html
+ cd ${WRKSRC}/docs/gallery && ${GMAKE} index.html
.endif
post-install:
diff --git a/graphics/gegl/files/patch-tools_create-reference.rb b/graphics/gegl/files/patch-tools_create-reference.rb
new file mode 100644
index 000000000000..9f3cc579a835
--- /dev/null
+++ b/graphics/gegl/files/patch-tools_create-reference.rb
@@ -0,0 +1,14 @@
+--- tools/create-reference.rb.orig 2013-06-17 14:02:54.000000000 +0000
++++ tools/create-reference.rb 2013-06-17 14:03:31.000000000 +0000
+@@ -5,6 +5,11 @@
+ # Use under a public domain license.
+ #
+
++if RUBY_VERSION != /^1.8/
++ Encoding.default_external = Encoding::UTF_8
++ Encoding.default_internal = Encoding::UTF_8
++end
++
+ class Argument
+ attr_accessor :name, :data_type, :doc
+ def initialize
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index df6fff1999db..f32746a7e208 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -292,27 +292,9 @@ lib/libgegl-%%GEGL_VER%%.la
lib/libgegl-%%GEGL_VER%%.so
lib/libgegl-%%GEGL_VER%%.so.%%GEGL_MINOR%%
libdata/pkgconfig/gegl-%%GEGL_VER%%.pc
-%%PORTDOCS%%share/gtk-doc/html/gegl/brightness-contrast.c.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-area-filter.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-composer.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-filter.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-meta.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-point-composer.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-point-filter.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-point-render.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-sink.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-source.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation-temporal.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-operation.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl-plugin.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl.css
-%%PORTDOCS%%share/gtk-doc/html/gegl/gegl.h.html
-%%PORTDOCS%%share/gtk-doc/html/gegl/operations.html
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/api.html
%%PORTDOCS%%%%DOCSDIR%%/brightness-contrast.c.html
-%%PORTDOCS%%%%DOCSDIR%%/class-hierarchy.html
-%%PORTDOCS%%%%DOCSDIR%%/development.html
%%PORTDOCS%%%%DOCSDIR%%/devhelp.css
%%PNG%%%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-00.png
%%PORTDOCS%%%%DOCSDIR%%/gallery/OpenRaster-00.txt
@@ -363,9 +345,6 @@ share/locale/sl/LC_MESSAGES/gegl-%%GEGL_VER%%.mo
@dirrm include/gegl-%%GEGL_VER%%/opencl
@dirrm include/gegl-%%GEGL_VER%%
@dirrm lib/gegl-%%GEGL_VER%%
-%%PORTDOCS%%@dirrm share/gtk-doc/html/gegl
-%%PORTDOCS%%@dirrmtry share/gtk-doc/html
-%%PORTDOCS%%@dirrmtry share/gtk-doc
%%PORTDOCS%%@dirrm %%DOCSDIR%%/gallery
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/data