aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2009-07-24 09:24:10 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2009-07-24 09:24:10 +0000
commite93039a2a2c718a34cfed07239e53e7c0e9dd2ec (patch)
treec97198ab1f02324afc92f20fd1e895130639dca5 /graphics/gegl
parentfe7bfc1d17c1b457d120a730a2557c591a48fd9a (diff)
downloadports-e93039a2a2c718a34cfed07239e53e7c0e9dd2ec.tar.gz
ports-e93039a2a2c718a34cfed07239e53e7c0e9dd2ec.zip
Notes
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile30
-rw-r--r--graphics/gegl/pkg-plist6
2 files changed, 29 insertions, 7 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index adf482511dca..f7f2a2a0b1e3 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gegl
PORTVERSION= 0.0.${GEGL_MINOR}
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.0/
@@ -20,13 +20,16 @@ OPTIONS= CAIRO "Enable Cairo" on \
FFMPEG "Enable videos through ffmpeg" on \
GRAPHVIZ "Enable Graphviz" on \
JPEG "Enable JPEG format support" on \
+ LUA "Enable LUA" on \
OPENEXR "Enable High Dynamic Range (HDR) format support" on \
OPENRAW "Enable RAW camera format support" on \
+ OPTIMIZE "Enable optimizations autodetection (MMX, SSE)" off \
PANGO "Enable rendering through Pango " on \
PNG "Enable PNG format support" on \
RSVG "Enable RSVG format support" on \
+ SDL "Enable SDL" on \
SPIRO "Enable Spiro" on \
- SDL "Enable SDL" on
+ V4L "Enable Video4Linux" on
USE_GNOME= gtk20 glib20 pkgconfig gnomehack
USE_BZIP2= yes
@@ -35,10 +38,7 @@ USE_RUBY= build
USE_LDCONFIG= ${PREFIX}/lib/gegl-0.0
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS+=--disable-sse \
- --disable-mmx
GEGL_MINOR= 22
PLIST_SUB+= GEGL_MINOR="${GEGL_MINOR}"
@@ -78,6 +78,12 @@ CONFIGURE_ARGS+=--without-libjpeg
PLIST_SUB+= JPEG="@comment "
.endif
+.if !defined(WITHOUT_LUA)
+USE_LUA= 5.1
+.else
+CONFIGURE_ARGS+=--without-lua
+.endif
+
.if !defined(WITHOUT_OPENEXR)
LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
PLIST_SUB+= OPENEXR=""
@@ -94,6 +100,11 @@ CONFIGURE_ARGS+=--without-libopenraw
PLIST_SUB+= OPENRAW="@comment "
.endif
+.if defined(WITHOUT_OPTIMIZE)
+CONFIGURE_ARGS+=--disable-mmx \
+ --disable-sse
+.endif
+
.if !defined(WITHOUT_PANGO)
USE_GNOME+= pango
.else
@@ -130,6 +141,14 @@ LIB_DEPENDS+= spiro.0:${PORTSDIR}/graphics/libspiro
CONFIGURE_ARGS+=--without-libspiro
.endif
+.if !defined(WITHOUT_V4L)
+BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+PLIST_SUB+= V4L=""
+.else
+CONFIGURE_ARGS+=--without-libv4l
+PLIST_SUB+= V4L="@comment "
+.endif
+
.if !defined(NOPORTDOCS)
BUILD_DEPENDS+= a2x:${PORTSDIR}/textproc/asciidoc
.else
@@ -138,6 +157,7 @@ CONFIGURE_ARGS+= --disable-docs
post-patch:
${REINPLACE_CMD} -e 's|-T||' ${WRKSRC}/docs/Makefile.am ${WRKSRC}/docs/Makefile.in
+ ${REINPLACE_CMD} -e 's|\(lua\)\(5\.1\)|\1-\2|g' ${WRKSRC}/configure
post-build:
.if !defined(NOPORTDOCS)
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index 32b25d3db491..353b0bc64dd6 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -200,6 +200,8 @@ lib/gegl-0.0/tonemap.la
lib/gegl-0.0/tonemap.so
lib/gegl-0.0/unsharp-mask.la
lib/gegl-0.0/unsharp-mask.so
+%%V4L%%lib/gegl-0.0/v4l.la
+%%V4L%%lib/gegl-0.0/v4l.so
lib/gegl-0.0/value-invert.la
lib/gegl-0.0/value-invert.so
lib/gegl-0.0/whitebalance.la
@@ -259,8 +261,8 @@ libdata/pkgconfig/gegl.pc
@dirrm include/gegl-0.0
@dirrm lib/gegl-0.0
%%PORTDOCS%%@dirrm share/gtk-doc/html/gegl
-%%PORTDOCS%%@dirrm share/gtk-doc/html
-%%PORTDOCS%%@dirrm share/gtk-doc
+%%PORTDOCS%%@dirrmtry share/gtk-doc/html
+%%PORTDOCS%%@dirrmtry share/gtk-doc
%%PORTDOCS%%@dirrm %%DOCSDIR%%/gallery
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/data