aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2011-03-08 11:24:58 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2011-03-08 11:24:58 +0000
commit8fe29935fe416246fdb176e627247612e67543a0 (patch)
tree70a651df01eab1da16c042a8e9dd19db42c511cb /graphics/gegl
parentd9bea3bd8fdae682a76e9753171182dd9a7de049 (diff)
downloadports-8fe29935fe416246fdb176e627247612e67543a0.tar.gz
ports-8fe29935fe416246fdb176e627247612e67543a0.zip
Notes
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile25
-rw-r--r--graphics/gegl/pkg-plist8
2 files changed, 23 insertions, 10 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 07cb77f2c85a..32275ef04fd1 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -51,7 +51,7 @@ PLIST_SUB+= GEGL_MINOR="${GEGL_MINOR}"
EXAMPLES= 2geglbuffer gegl-paint geglbuffer-add-image \
geglbuffer-clock hello-world hello-world-video
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if !defined(WITHOUT_CAIRO)
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
@@ -61,6 +61,21 @@ CONFIGURE_ARGS+=--without-cairo
PLIST_SUB+= CAIRO="@comment "
.endif
+.if !defined(WITHOUT_PANGO)
+USE_GNOME+= pango
+PLIST_SUB+= PANGO=""
+.else
+CONFIGURE_ARGS+=--without-pango
+PLIST_SUB+= PANGO="@comment "
+.endif
+
+.if !defined(WITHOUT_PANGO) && !defined(WITHOUT_CAIRO)
+PLIST_SUB+= PANGOCAIRO=""
+.else
+CONFIGURE_ARGS+=--without-pangocairo
+PLIST_SUB+= PANGOCAIRO="@comment "
+.endif
+
.if !defined(WITHOUT_ENSCRIPT)
BUILD_DEPENDS+= enscript:${PORTSDIR}/print/enscript-a4
.endif
@@ -115,12 +130,6 @@ CONFIGURE_ARGS+=--disable-mmx \
--disable-sse
.endif
-.if !defined(WITHOUT_PANGO)
-USE_GNOME+= pango
-.else
-CONFIGURE_ARGS+=--without-pango
-.endif
-
.if !defined(WITHOUT_PNG)
LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
PLIST_SUB+= PNG=""
@@ -196,4 +205,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index 80faad6c77f2..4cac0c34186e 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -30,6 +30,10 @@ include/gegl-0.1/operation/gegl-operation-sink.h
include/gegl-0.1/operation/gegl-operation-source.h
include/gegl-0.1/operation/gegl-operation-temporal.h
include/gegl-0.1/operation/gegl-operation.h
+%%CAIRO%%lib/gegl-0.1/vector-fill.la
+%%CAIRO%%lib/gegl-0.1/vector-fill.so
+%%CAIRO%%lib/gegl-0.1/vector-stroke.la
+%%CAIRO%%lib/gegl-0.1/vector-stroke.so
%%CAIRO%%lib/gegl-0.1/path.la
%%CAIRO%%lib/gegl-0.1/path.so
%%FFMPEG%%lib/gegl-0.1/ff-load.la
@@ -230,8 +234,8 @@ lib/gegl-0.1/svg-multiply.la
lib/gegl-0.1/svg-multiply.so
lib/gegl-0.1/svg-saturate.la
lib/gegl-0.1/svg-saturate.so
-lib/gegl-0.1/text.la
-lib/gegl-0.1/text.so
+%%PANGOCAIRO%%lib/gegl-0.1/text.la
+%%PANGOCAIRO%%lib/gegl-0.1/text.so
lib/gegl-0.1/threshold.la
lib/gegl-0.1/threshold.so
lib/gegl-0.1/unsharp-mask.la