aboutsummaryrefslogtreecommitdiff
path: root/graphics/gegl
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2012-05-20 16:39:14 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2012-05-20 16:39:14 +0000
commit135d0b1c1226967dd43ce3df3ae94c9340a360d2 (patch)
tree6c4e93710f8668e8255afefc2b21dad63089170f /graphics/gegl
parentd7eaeb8bafb7291739d3eb32b5f5ef5be7f77c3d (diff)
downloadports-135d0b1c1226967dd43ce3df3ae94c9340a360d2.tar.gz
ports-135d0b1c1226967dd43ce3df3ae94c9340a360d2.zip
Notes
Diffstat (limited to 'graphics/gegl')
-rw-r--r--graphics/gegl/Makefile22
-rw-r--r--graphics/gegl/pkg-plist12
2 files changed, 26 insertions, 8 deletions
diff --git a/graphics/gegl/Makefile b/graphics/gegl/Makefile
index 3c1d882c1e08..49609653b265 100644
--- a/graphics/gegl/Makefile
+++ b/graphics/gegl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gegl
PORTVERSION= 0.1.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.gimp.org/pub/gegl/0.1/
@@ -21,7 +21,9 @@ LIB_DEPENDS= babl-0.1:${PORTSDIR}/x11/babl \
OPTIONS= CAIRO "Enable Cairo" on \
ENSCRIPT "Enable Enscript" on \
FFMPEG "Enable videos through ffmpeg (BROKEN)" off \
+ GDK "Enable gdk-pixbuf2 formats support" on \
GRAPHVIZ "Enable Graphviz" on \
+ JP2 "Enable JPEG2000 format support" on \
JPEG "Enable JPEG format support" on \
LUA "Enable LUA" on \
OPENEXR "Enable High Dynamic Range (HDR) format support" on \
@@ -37,7 +39,7 @@ OPTIONS= CAIRO "Enable Cairo" on \
# Disable docs until I fix the problem with graphviz's dot
NOPORTDOCS= yes
-USE_GNOME= gtk20 glib20 pkgconfig gnomehack
+USE_GNOME= glib20 pkgconfig gnomehack
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -56,6 +58,14 @@ EXAMPLES= 2geglbuffer csugar float-lookup \
.include <bsd.port.options.mk>
+.if !defined(WITHOUT_GDK)
+USE_GNOME+= gdkpixbuf2
+PLIST_SUB+= GDK=""
+.else
+CONFIGURE_ARGS+=--without-gdk-pixbuf
+PLIST_SUB+= GDK="@comment "
+.endif
+
.if !defined(WITHOUT_CAIRO)
LIB_DEPENDS+= cairo.2:${PORTSDIR}/graphics/cairo
PLIST_SUB+= CAIRO=""
@@ -98,6 +108,14 @@ LIB_DEPENDS+= graph:${PORTSDIR}/graphics/graphviz
CONFIGURE_ARGS+=--without-graphviz
.endif
+.if !defined(WITHOUT_JP2)
+LIB_DEPENDS+= jasper.4:${PORTSDIR}/graphics/jasper
+PLIST_SUB+= JP2=""
+.else
+CONFIGURE_ARGS+=--without-jasper
+PLIST_SUB+= JP2="@comment "
+.endif
+
.if !defined(WITHOUT_JPEG)
LIB_DEPENDS+= jpeg.11:${PORTSDIR}/graphics/jpeg
PLIST_SUB+= JPEG=""
diff --git a/graphics/gegl/pkg-plist b/graphics/gegl/pkg-plist
index b7f7904b2098..347b83d733ee 100644
--- a/graphics/gegl/pkg-plist
+++ b/graphics/gegl/pkg-plist
@@ -149,8 +149,8 @@ lib/gegl-0.1/introspect.la
lib/gegl-0.1/introspect.so
lib/gegl-0.1/invert.la
lib/gegl-0.1/invert.so
-lib/gegl-0.1/jp2-load.la
-lib/gegl-0.1/jp2-load.so
+%%JP2%%lib/gegl-0.1/jp2-load.la
+%%JP2%%lib/gegl-0.1/jp2-load.so
lib/gegl-0.1/layer.la
lib/gegl-0.1/layer.so
lib/gegl-0.1/levels.la
@@ -191,8 +191,8 @@ lib/gegl-0.1/over.la
lib/gegl-0.1/over.so
lib/gegl-0.1/overlay.la
lib/gegl-0.1/overlay.so
-lib/gegl-0.1/pixbuf.la
-lib/gegl-0.1/pixbuf.so
+%%GDK%%lib/gegl-0.1/pixbuf.la
+%%GDK%%lib/gegl-0.1/pixbuf.so
lib/gegl-0.1/pixelise.la
lib/gegl-0.1/pixelise.so
lib/gegl-0.1/plus.la
@@ -213,8 +213,8 @@ lib/gegl-0.1/rgbe-load.la
lib/gegl-0.1/rgbe-load.so
lib/gegl-0.1/rgbe-save.la
lib/gegl-0.1/rgbe-save.so
-lib/gegl-0.1/save-pixbuf.la
-lib/gegl-0.1/save-pixbuf.so
+%%GDK%%lib/gegl-0.1/save-pixbuf.la
+%%GDK%%lib/gegl-0.1/save-pixbuf.so
lib/gegl-0.1/save.la
lib/gegl-0.1/save.so
lib/gegl-0.1/screen.la