aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-07 17:51:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-09-07 17:51:24 +0000
commit8f187f74fdc9f614a3b75e04e5cb32e271f05d4d (patch)
tree6934cbfb209392c330f3055220a67d8852642fff /graphics/geos
parent5d059778c90830b4276569b69145f9963a466f1b (diff)
downloadports-8f187f74fdc9f614a3b75e04e5cb32e271f05d4d.tar.gz
ports-8f187f74fdc9f614a3b75e04e5cb32e271f05d4d.zip
Notes
Diffstat (limited to 'graphics/geos')
-rw-r--r--graphics/geos/Makefile12
-rw-r--r--graphics/geos/distinfo4
-rw-r--r--graphics/geos/pkg-plist7
3 files changed, 13 insertions, 10 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 468a1c3f9a7d..5d0e4f47e3d9 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geos
-PORTVERSION= 3.4.2
-PORTREVISION= 3
+PORTVERSION= 3.5.0
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/ \
LOCAL/sunpoet
@@ -17,6 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
OPTIONS_DEFINE= PHP PYTHON RUBY
OPTIONS_SUB= yes
+CONFIGURE_ARGS= ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
@@ -24,18 +24,18 @@ USES= gmake libtool tar:bzip2
PLIST_SUB= PORTVERSION=${PORTVERSION}
-PHP_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PHP_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
PHP_CONFIGURE_ENABLE= php
PHP_USE= PHP=yes PHP_BUILD=yes
-PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+PYTHON_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
PYTHON_CONFIGURE_ENABLE=python
PYTHON_USES= python:2
-RUBY_BUILD_DEPENDS= ${LOCALBASE}/bin/swig1.3:${PORTSDIR}/devel/swig13
+RUBY_BUILD_DEPENDS= ${LOCALBASE}/bin/swig3.0:${PORTSDIR}/devel/swig30
RUBY_CONFIGURE_ENABLE= ruby
RUBY_CONFIGURE_ENV= RUBY="${RUBY}"
RUBY_USE= RUBY=yes
post-patch:
- @${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/configure ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
+ @${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/geos/distinfo b/graphics/geos/distinfo
index 54da3fd07448..29776baf5a10 100644
--- a/graphics/geos/distinfo
+++ b/graphics/geos/distinfo
@@ -1,2 +1,2 @@
-SHA256 (geos-3.4.2.tar.bz2) = 15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53
-SIZE (geos-3.4.2.tar.bz2) = 1813726
+SHA256 (geos-3.5.0.tar.bz2) = 49982b23bcfa64a53333dab136b82e25354edeb806e5a2e2f5b8aa98b1d0ae02
+SIZE (geos-3.5.0.tar.bz2) = 1949397
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index 88597cfeea97..2b412b9a9b4f 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -261,6 +261,9 @@ include/geos/operation/distance/ConnectedElementLocationFilter.h
include/geos/operation/distance/ConnectedElementPointFilter.h
include/geos/operation/distance/DistanceOp.h
include/geos/operation/distance/GeometryLocation.h
+include/geos/operation/intersection/Rectangle.h
+include/geos/operation/intersection/RectangleIntersection.h
+include/geos/operation/intersection/RectangleIntersectionBuilder.h
include/geos/operation/linemerge/EdgeString.h
include/geos/operation/linemerge/LineMergeDirectedEdge.h
include/geos/operation/linemerge/LineMergeEdge.h
@@ -347,6 +350,7 @@ include/geos/spatialIndex.h
include/geos/timeval.h
include/geos/triangulate/DelaunayTriangulationBuilder.h
include/geos/triangulate/IncrementalDelaunayTriangulator.h
+include/geos/triangulate/VoronoiDiagramBuilder.h
include/geos/triangulate/quadedge/LastFoundQuadEdgeLocator.h
include/geos/triangulate/quadedge/LocateFailureException.h
include/geos/triangulate/quadedge/QuadEdge.h
@@ -378,7 +382,7 @@ lib/libgeos.so
lib/libgeos_c.a
lib/libgeos_c.so
lib/libgeos_c.so.1
-lib/libgeos_c.so.1.8.2
+lib/libgeos_c.so.1.9.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos.pth
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.a
%%PYTHON%%%%PYTHON_SITELIBDIR%%/geos/_geos.so
@@ -388,4 +392,3 @@ lib/libgeos_c.so.1.8.2
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.a
%%RUBY%%%%RUBY_SITEARCHLIBDIR%%/geos.so
%%PHP%%lib/php/%%PHP_EXT_DIR%%/geos.so
-@dir lib/geos