aboutsummaryrefslogtreecommitdiff
path: root/graphics/geos
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 08:02:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-11-19 08:02:56 +0000
commitc1677dd8d17c6e69cdb98b6e655673ace9e49e9a (patch)
treec55033ab17fa5dd41dc6f62e2627eb17a1bc4a3d /graphics/geos
parent0909e1e4d2a911b51c72b8bdac213a7aa8e9cab8 (diff)
downloadports-c1677dd8d17c6e69cdb98b6e655673ace9e49e9a.tar.gz
ports-c1677dd8d17c6e69cdb98b6e655673ace9e49e9a.zip
- Fix geos::geom::CoordinateArraySequenceFactory assertion
- Convert to new test framework - Bump PORTREVISION for package change PR: 213173 Submitted by: Rainer Hurling <rhurlin@gwdg.de>
Notes
Notes: svn path=/head/; revision=426351
Diffstat (limited to 'graphics/geos')
-rw-r--r--graphics/geos/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 8a4c89f4fc89..c092f7ba5e7d 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -3,6 +3,7 @@
PORTNAME= geos
PORTVERSION= 3.5.0
+PORTREVISION= 1
CATEGORIES= graphics geography
MASTER_SITES= http://download.osgeo.org/geos/ \
LOCAL/sunpoet
@@ -19,6 +20,7 @@ OPTIONS_SUB= yes
CONFIGURE_ARGS= ac_cv_path_SWIG=${LOCALBASE}/bin/swig3.0
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+TEST_TARGET= check
USE_LDCONFIG= yes
USES= gmake libtool tar:bzip2
@@ -38,4 +40,7 @@ RUBY_USE= RUBY=yes
post-patch:
@${REINPLACE_CMD} -e 's|-lstdc++||' ${WRKSRC}/tests/geostest/Makefile.in ${WRKSRC}/tests/thread/Makefile.in
+post-configure:
+ @${FIND} ${WRKSRC} -name Makefile -exec ${REINPLACE_CMD} -e '/CXXFLAGS = / s| -O2||' '{}' \;
+
.include <bsd.port.mk>