aboutsummaryrefslogtreecommitdiff
path: root/graphics/gephex
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2006-02-11 21:40:39 +0000
committerThierry Thomas <thierry@FreeBSD.org>2006-02-11 21:40:39 +0000
commit41ae3d419c24f99c5718c51c5d93c1e27e01882e (patch)
tree95d6a64560c22ebc03c7da352e0da0950c89bfb3 /graphics/gephex
parentc60f3637133cf5350e6dafa6657cfeaf1cc58498 (diff)
Notes
Diffstat (limited to 'graphics/gephex')
-rw-r--r--graphics/gephex/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/gephex/Makefile b/graphics/gephex/Makefile
index d7c1f9639dca..0d06a0af1e2b 100644
--- a/graphics/gephex/Makefile
+++ b/graphics/gephex/Makefile
@@ -24,7 +24,6 @@ CONFIGURE_ARGS= --without-V4L --without-ASOUNDLIB --without-LINUX_JOYSTICK \
--without-FFMPEG --without-AVIFILE --without-MPEG3 \
--without-LIBPNG --without-SDL --without-SDL_IMAGE \
--without-SDL_TTF --without-AALIB --disable-static
-CONFIGURE_ENV= "CFLAGS+=-I${LOCALBASE}/include LDFLAGS+=-L${LOCALBASE}/lib"
USE_QT_VER= 3
WANT_SDL= yes
INSTALLS_SHLIB= yes
@@ -172,4 +171,11 @@ post-patch:
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's|%%PORTDOCS%%|${DO_DOCS}|' ${WRKSRC}/Makefile.am
+# Compile contents of static libs with PIC, as they can be used in dynamic ones
+.if !empty(ARCH:M*64)
+ @(${FIND} -X ${WRKSRC} -name Makefile.am \! -regex '.*cpuinfo.*' | \
+ ${XARGS} ${REINPLACE_CMD} -E -e \
+ "/^lib[[:alnum:]]+_a_SOURCES.*$$/{ h; s//AM_CFLAGS = -DPIC -fPIC/; G;}")
+.endif
+
.include <bsd.port.post.mk>