aboutsummaryrefslogtreecommitdiff
path: root/graphics/gif2png/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-11-20 06:06:46 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-11-20 06:06:46 +0000
commit298c1beebf75c58135dba5407580d4fb758c76bb (patch)
treeee712bf745c8da0236c94a3abefc0932f59835d7 /graphics/gif2png/Makefile
parent37f2a01b786680db25c81327be8da1c5aac5aa7e (diff)
downloadports-298c1beebf75c58135dba5407580d4fb758c76bb.tar.gz
ports-298c1beebf75c58135dba5407580d4fb758c76bb.zip
Notes
Diffstat (limited to 'graphics/gif2png/Makefile')
-rw-r--r--graphics/gif2png/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/gif2png/Makefile b/graphics/gif2png/Makefile
index c60604e2b7eb..237ef26d9c86 100644
--- a/graphics/gif2png/Makefile
+++ b/graphics/gif2png/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gif2png
-PORTVERSION= 2.5.1
+PORTVERSION= 2.5.2
CATEGORIES= graphics
MASTER_SITES= http://www.catb.org/~esr/gif2png/
@@ -15,11 +15,14 @@ COMMENT= Converts GIF images to a PNG format
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
-USE_GMAKE= yes
USE_PYTHON_RUN= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+MAN1= ${PORTNAME}.1 web2png.1
+PLIST_FILES= bin/${PORTNAME} bin/web2png
-MAN1= gif2png.1 web2png.1
+CPPFLAGS= `libpng-config --I_opts`
+LDFLAGS= `libpng-config --L_opts`
.include <bsd.port.mk>