aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimageview/Makefile
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-06-26 08:38:40 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-06-26 08:38:40 +0000
commit592ba41a87be95e9a8d8dfe6cdd868d7cfb4811c (patch)
treecc0989eb7583e1b284a55479b345db2fc6e8314d /graphics/gimageview/Makefile
parent98f321d651f730eebdad8a1fca01d7118922bb6c (diff)
downloadports-592ba41a87be95e9a8d8dfe6cdd868d7cfb4811c.tar.gz
ports-592ba41a87be95e9a8d8dfe6cdd868d7cfb4811c.zip
Notes
Diffstat (limited to 'graphics/gimageview/Makefile')
-rw-r--r--graphics/gimageview/Makefile40
1 files changed, 39 insertions, 1 deletions
diff --git a/graphics/gimageview/Makefile b/graphics/gimageview/Makefile
index 0bfd84d71662..bb9e0112ea6f 100644
--- a/graphics/gimageview/Makefile
+++ b/graphics/gimageview/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gimageview
-PORTVERSION= 0.2.13
+PORTVERSION= 0.2.23
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gtkmmviewer
@@ -31,6 +31,44 @@ PKGNAMESUFFIX= -imlib
WITH_IMLIB= yes
.endif
+.if exists(${LOCALBASE}/lib/libmng.so.1)
+WITH_LIBMNG= yes
+.endif
+
+.if exists(${LOCALBASE}/lib/libwmf.so.2)
+WITH_LIBWMF= yes
+.endif
+
+.if exists(${X11BASE}/lib/librsvg.so.1)
+WITH_LIBRSVG= yes
+.endif
+
+.if exists(${LOCALBASE}/bin/mplayer)
+WITH_MPLAYER= yes
+.endif
+
+.if defined(WITH_LIBMNG)
+LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng
+.endif
+
+.if defined(WITH_LIBWMF)
+LIB_DEPENDS+= wmf.2:${PORTSDIR}/graphics/libwmf
+.endif
+
+.if defined(WITH_LIBRSVG)
+LIB_DEPENDS+= rsvg.1:${PORTSDIR}/graphics/librsvg
+.endif
+
+.if defined(WITH_MPLAYER)
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+CONFIGURE_ARGS+= --enable-mplayer
+.endif
+
+.if defined(WITH_LIBXINE)
+LIB_DEPENDS+= xine.3:${PORTSDIR}/graphics/libxine
+CONFIGURE_ARGS+= --with-xine
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/DATADIRNAME=lib/DATADIRNAME=share/g' \
${WRKSRC}/configure