aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimmage
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-06-09 22:06:11 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-06-09 22:06:11 +0000
commitc32952a6b0f4cd49cd62e9f7f66473c18ca7dd94 (patch)
treed3a68d04cae8a940359142d09da2e7bc04641b0e /graphics/gimmage
parent77e34ba788a4423955e7e775dec06d709c86715b (diff)
downloadports-c32952a6b0f4cd49cd62e9f7f66473c18ca7dd94.tar.gz
ports-c32952a6b0f4cd49cd62e9f7f66473c18ca7dd94.zip
Notes
Diffstat (limited to 'graphics/gimmage')
-rw-r--r--graphics/gimmage/Makefile22
-rw-r--r--graphics/gimmage/distinfo3
-rw-r--r--graphics/gimmage/files/patch-src__AppWindow.cpp10
-rw-r--r--graphics/gimmage/files/patch-src__FileManager.cpp15
-rw-r--r--graphics/gimmage/files/patch-src__ImageEventBox.cpp10
-rw-r--r--graphics/gimmage/pkg-descr10
-rw-r--r--graphics/gimmage/pkg-plist13
7 files changed, 83 insertions, 0 deletions
diff --git a/graphics/gimmage/Makefile b/graphics/gimmage/Makefile
new file mode 100644
index 000000000000..26275abcffaa
--- /dev/null
+++ b/graphics/gimmage/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: gimmage
+# Date created: 10 June 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gimmage
+PORTVERSION= 0.2.1
+CATEGORIES= graphics
+MASTER_SITES= BERLIOS CENKES
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Simple image viewer
+
+LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
+ curl.4:${PORTSDIR}/ftp/curl
+
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/gimmage/distinfo b/graphics/gimmage/distinfo
new file mode 100644
index 000000000000..1f2c8d7fb5c2
--- /dev/null
+++ b/graphics/gimmage/distinfo
@@ -0,0 +1,3 @@
+MD5 (gimmage-0.2.1.tar.gz) = 29a00006da0def06e2636e26dc4c2c33
+SHA256 (gimmage-0.2.1.tar.gz) = 1fb2c917e9bd2257add9e75925741736e11eb31c5508a4bd6a4a7a88ac7b800c
+SIZE (gimmage-0.2.1.tar.gz) = 187589
diff --git a/graphics/gimmage/files/patch-src__AppWindow.cpp b/graphics/gimmage/files/patch-src__AppWindow.cpp
new file mode 100644
index 000000000000..62577034e587
--- /dev/null
+++ b/graphics/gimmage/files/patch-src__AppWindow.cpp
@@ -0,0 +1,10 @@
+--- ./src/AppWindow.cpp.orig Sun Jun 10 01:55:15 2007
++++ ./src/AppWindow.cpp Sun Jun 10 01:55:33 2007
+@@ -24,6 +24,7 @@
+ #include "../config.h"
+
+ extern "C" {
++#include <libintl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
diff --git a/graphics/gimmage/files/patch-src__FileManager.cpp b/graphics/gimmage/files/patch-src__FileManager.cpp
new file mode 100644
index 000000000000..e66585475d70
--- /dev/null
+++ b/graphics/gimmage/files/patch-src__FileManager.cpp
@@ -0,0 +1,15 @@
+--- ./src/FileManager.cpp.orig Sun Jun 10 01:55:51 2007
++++ ./src/FileManager.cpp Sun Jun 10 01:56:13 2007
+@@ -20,10 +20,12 @@
+ // gimmage: FileManager.cpp
+ #include "FileManager.h"
+ #include "defines.h"
++#define get_current_dir_name() getcwd(NULL, PATH_MAX)
+
+ #include "../config.h"
+
+ extern "C" {
++#include <libintl.h>
+ #include <string.h>
+ #include <unistd.h>
+ }
diff --git a/graphics/gimmage/files/patch-src__ImageEventBox.cpp b/graphics/gimmage/files/patch-src__ImageEventBox.cpp
new file mode 100644
index 000000000000..71644d3dffc3
--- /dev/null
+++ b/graphics/gimmage/files/patch-src__ImageEventBox.cpp
@@ -0,0 +1,10 @@
+--- ./src/ImageEventBox.cpp.orig Sun Jun 10 01:56:27 2007
++++ ./src/ImageEventBox.cpp Sun Jun 10 01:56:40 2007
+@@ -21,6 +21,7 @@
+
+ #include "ImageEventBox.h"
+ #include "defines.h"
++#include "libintl.h"
+
+ #include "../config.h"
+
diff --git a/graphics/gimmage/pkg-descr b/graphics/gimmage/pkg-descr
new file mode 100644
index 000000000000..88f0c89fb3d4
--- /dev/null
+++ b/graphics/gimmage/pkg-descr
@@ -0,0 +1,10 @@
+Gimmage is a simple image viewer that aims to have a minimalist
+interface and tries to be keyboard operable for browsing through a
+large number of images quickly. It is appropriate for command line
+usage as it accepts directories and image filenames as arguments. It
+has an in-application file browser that allows users to select and
+drag images and directories into the image viewing area in order to
+have them displayed.
+
+WWW: http://gimmage.berlios.de/
+Author: Bartek Kostrzewa
diff --git a/graphics/gimmage/pkg-plist b/graphics/gimmage/pkg-plist
new file mode 100644
index 000000000000..c612992d00a9
--- /dev/null
+++ b/graphics/gimmage/pkg-plist
@@ -0,0 +1,13 @@
+bin/gimmage
+%%DATADIR%%/pixmaps/1to1.png
+%%DATADIR%%/pixmaps/anticlockwise.png
+%%DATADIR%%/pixmaps/clockwise.png
+%%DATADIR%%/pixmaps/unreadable.png
+share/gnome/apps/Graphics/gimmage.desktop
+share/locale/de/LC_MESSAGES/gimmage.mo
+share/locale/fr/LC_MESSAGES/gimmage.mo
+@dirrm share/gimmage/pixmaps
+@dirrm share/gimmage
+@dirrmtry share/gnome/apps/Graphics
+@dirrmtry share/gnome/apps
+@dirrmtry share/gnome