aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-app-devel/Makefile
diff options
context:
space:
mode:
authorEric L. Hernes <erich@FreeBSD.org>1997-10-15 20:18:02 +0000
committerEric L. Hernes <erich@FreeBSD.org>1997-10-15 20:18:02 +0000
commit451355f015d0c8c649546a413da244f3711fed97 (patch)
treef91fa55c8bae08bd652fcdc799d737ac6ddd25af /graphics/gimp-app-devel/Makefile
parent53232c9cd3e5ee2f21710ef3a4e23140476b747f (diff)
downloadports-451355f015d0c8c649546a413da244f3711fed97.tar.gz
ports-451355f015d0c8c649546a413da244f3711fed97.zip
Notes
Diffstat (limited to 'graphics/gimp-app-devel/Makefile')
-rw-r--r--graphics/gimp-app-devel/Makefile34
1 files changed, 22 insertions, 12 deletions
diff --git a/graphics/gimp-app-devel/Makefile b/graphics/gimp-app-devel/Makefile
index 67dd07babf4b..791c571a8225 100644
--- a/graphics/gimp-app-devel/Makefile
+++ b/graphics/gimp-app-devel/Makefile
@@ -1,38 +1,48 @@
-# New ports collection makefile for: GIMP
-# Version required: 0.99.7
+# New ports collection makefile for: Gimp
+# Version required: 0.99.13
# Date created: Mon Nov 18 21:28:43 CST 1996
# Whom: erich@FreeBSD.org
#
-# $Id: Makefile,v 1.9 1997/05/01 18:25:44 erich Exp $
+# $Id: Makefile,v 1.10 1997/07/14 22:19:04 erich Exp $
#
-VERSION= 0.99.10
-DATA_VERSION= 0.99.9
-DISTNAME= gimp-${VERSION}
+VERSION= 0.99.14
+
+DISTNAME= gimp-${VERSION}
DISTFILES= ${DISTNAME}.tar.gz
-DISTFILES+= gimp-data-${DATA_VERSION}.tar.gz
+DISTFILES+= gimp-data-min-${VERSION}.tar.gz \
+ gimp-data-extras-${VERSION}.tar.gz \
+ gimptcl-1.0.tar.gz
+
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.xcf.berkeley.edu/pub/gimp/developers/
+MASTER_SITES= ftp://ftp.cs.umn.edu/pub/gimp/gimp/devel/${VERSION}/ \
+ ftp://ftp.gimp.org/pub/gimp/devel/${VERSION}/ \
+ http://www.freebsd.org/~erich/
MAINTAINER= erich@FreeBSD.org
-#LIB_DEPENDS+= png\\.0\\.[7-9]:${PORTSDIR}/graphics/png
+LIB_DEPENDS+= gtk\\.1\\.0:${PORTSDIR}/x11/gtk
+LIB_DEPENDS+= png\\.0\\.[7-9]:${PORTSDIR}/graphics/png
LIB_DEPENDS+= jpeg\\.7\\.:${PORTSDIR}/graphics/jpeg
LIB_DEPENDS+= tiff\\.3\\.:${PORTSDIR}/graphics/tiff
LIB_DEPENDS+= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS+= mpeg\\.1\\.2:${PORTSDIR}/graphics/mpeg-lib
+LIB_DEPENDS+= tk80\\.1\\.:${PORTSDIR}/x11/tk80
USE_X11= yes
GNU_CONFIGURE= yes
-
USE_GMAKE= yes
+CONFIGURE_ENV= CPPFLAGS=-I/usr/local/include LIBS=-L/usr/local/lib
DATASTUFF= brushes palettes gradients patterns
post-install:
- cd ${WRKDIR}/gimp-data-${DATA_VERSION}; \
+ cd ${WRKDIR}/gimp-data-min-${VERSION}; \
+ tar -cf - --exclude '*Makefile*' ${DATASTUFF} |\
+ (cd ${PREFIX}/share/gimp/${VERSION}; tar -xvf -)
+ cd ${WRKDIR}/gimp-data-extras-${VERSION}; \
tar -cf - --exclude '*Makefile*' ${DATASTUFF} |\
(cd ${PREFIX}/share/gimp/${VERSION}; tar -xvf -)
-
.include <bsd.port.mk>