aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-app/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-26 10:39:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-26 10:39:06 +0000
commit8430f2111fc01d017ba0c338660c7b11db13692e (patch)
tree5788e01398ffd7cdb84641e98bf0bf8e06d1e7d9 /graphics/gimp-app/Makefile
parent05be4352420951a98677c8bd45c80a42068bc18f (diff)
downloadports-8430f2111fc01d017ba0c338660c7b11db13692e.tar.gz
ports-8430f2111fc01d017ba0c338660c7b11db13692e.zip
Notes
Diffstat (limited to 'graphics/gimp-app/Makefile')
-rw-r--r--graphics/gimp-app/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/graphics/gimp-app/Makefile b/graphics/gimp-app/Makefile
index 239a3eb5f86c..6eb2fbf4be1f 100644
--- a/graphics/gimp-app/Makefile
+++ b/graphics/gimp-app/Makefile
@@ -38,7 +38,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2 librsvg2
+USE_GNOME= gnomehack intltool intlhack gtk20 libartlgpl2
WANT_GNOME= yes
USE_GETTEXT= yes
INSTALLS_SHLIB= yes
@@ -57,6 +57,7 @@ MAN5= gimprc.5 gimprc-2.2.5
OPTIONS= DEBUG "debugging" off \
PYTHON "Python-Fu support" off \
+ RSVG "SVG format support" on \
PRINT "GIMP printing" on \
HTML_HELP_BROWSER "GIMP help browser" on \
MP "multiple processor support" off
@@ -80,6 +81,14 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON:="@comment "
.endif
+.if defined(WITHOUT_RSVG)
+CONFIGURE_ARGS+= --without-librsvg
+PLIST_SUB+= SVG="@comment "
+.else
+USE_GNOME+= librsvg2
+PLIST_SUB+= SVG=""
+.endif
+
.if defined(WITHOUT_PRINT)
CONFIGURE_ARGS+= --disable-print
PLIST_SUB+= PRINT="@comment "