aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-beautify-plugin
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-03-23 23:08:39 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-03-23 23:08:39 +0000
commit29e5699051d732d37009deba9fe200736c2abfb4 (patch)
treee1b6588b005490cd8318258381a4afa4747214b8 /graphics/gimp-beautify-plugin
parent65e47b6e7daecf5a23587e8188439cb694873023 (diff)
downloadports-29e5699051d732d37009deba9fe200736c2abfb4.tar.gz
ports-29e5699051d732d37009deba9fe200736c2abfb4.zip
Notes
Diffstat (limited to 'graphics/gimp-beautify-plugin')
-rw-r--r--graphics/gimp-beautify-plugin/Makefile60
-rw-r--r--graphics/gimp-beautify-plugin/distinfo2
-rw-r--r--graphics/gimp-beautify-plugin/files/patch-Makefile10
-rw-r--r--graphics/gimp-beautify-plugin/pkg-descr3
4 files changed, 75 insertions, 0 deletions
diff --git a/graphics/gimp-beautify-plugin/Makefile b/graphics/gimp-beautify-plugin/Makefile
new file mode 100644
index 000000000000..b0e4a3872219
--- /dev/null
+++ b/graphics/gimp-beautify-plugin/Makefile
@@ -0,0 +1,60 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= beautify
+PORTVERSION= 2012.08.12.00
+CATEGORIES= graphics
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GIMP plug-ins to both quickly and easily beautify photo
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig \
+ ${LOCALBASE}/libdata/pkgconfig/freetype2.pc:${PORTSDIR}/print/freetype2 \
+ ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/fontconfig.pc:${PORTSDIR}/x11-fonts/fontconfig \
+ ${LOCALBASE}/libdata/pkgconfig/freetype2.pc:${PORTSDIR}/print/freetype2 \
+ ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+
+USE_GITHUB= yes
+GH_ACCOUNT= hejiann
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= e209c8d
+
+USES= gettext gmake
+USE_GCC= yes
+USE_GNOME= atk cairo gdkpixbuf2 gtk20
+USE_XORG= x11 xcomposite xcursor xdamage xext xfixes xi xinerama xrandr xrender
+
+PLUGIN_DIR?= libexec/gimp/2.2/plug-ins/
+PLUGINS= beautify \
+ border \
+ simple-border \
+ skin-whitening
+
+# installed files
+.for plugin in ${PLUGINS}
+PLIST_FILES+= ${PLUGIN_DIR}/${plugin}
+.endfor
+
+# installed dirs
+PLIST_DIRSTRY= libexec/gimp/2.2/plug-ins \
+ libexec/gimp/2.2 \
+ libexec/gimp
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ -e 's|gdk-pixbuf-csource|${LOCALBASE}/bin/gdk-pixbuf-csource|' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+.for plugin in ${PLUGINS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${plugin} ${STAGEDIR}${PREFIX}/${PLUGIN_DIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-beautify-plugin/distinfo b/graphics/gimp-beautify-plugin/distinfo
new file mode 100644
index 000000000000..9f82e5d248f9
--- /dev/null
+++ b/graphics/gimp-beautify-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (beautify-2012.08.12.00.tar.gz) = 78aa8db61b9d4f7130f0be3ce348822651bf612415c11a1176aa100e75bdb056
+SIZE (beautify-2012.08.12.00.tar.gz) = 24499201
diff --git a/graphics/gimp-beautify-plugin/files/patch-Makefile b/graphics/gimp-beautify-plugin/files/patch-Makefile
new file mode 100644
index 000000000000..e3db7d3cd149
--- /dev/null
+++ b/graphics/gimp-beautify-plugin/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2014-03-19 21:58:10.000000000 -0300
++++ Makefile 2014-03-19 22:24:08.000000000 -0300
+@@ -13,7 +13,6 @@
+ # You should have received a copy of the GNU General Public License
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+-CC = gcc
+
+ GIMPTOOL = gimptool-2.0
+
diff --git a/graphics/gimp-beautify-plugin/pkg-descr b/graphics/gimp-beautify-plugin/pkg-descr
new file mode 100644
index 000000000000..f8607246108c
--- /dev/null
+++ b/graphics/gimp-beautify-plugin/pkg-descr
@@ -0,0 +1,3 @@
+GIMP Beautify is a set of GIMP plug-ins to both quickly and easily beautify photos
+
+WWW: https://github.com/hejiann/beautify/