aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-manual-html/Makefile
diff options
context:
space:
mode:
authorDonald Burr <dburr@FreeBSD.org>1998-06-10 13:57:13 +0000
committerDonald Burr <dburr@FreeBSD.org>1998-06-10 13:57:13 +0000
commitfbc682bd2c4b4a8f64708a9a6eee9d8d315bcbea (patch)
tree8433236b669c8b68ddc1079909e790ca41d59b79 /graphics/gimp-manual-html/Makefile
parentdad23f6017060e3626fccd16d7140823b9b8a65c (diff)
downloadports-fbc682bd2c4b4a8f64708a9a6eee9d8d315bcbea.tar.gz
ports-fbc682bd2c4b4a8f64708a9a6eee9d8d315bcbea.zip
Notes
Diffstat (limited to 'graphics/gimp-manual-html/Makefile')
-rw-r--r--graphics/gimp-manual-html/Makefile110
1 files changed, 110 insertions, 0 deletions
diff --git a/graphics/gimp-manual-html/Makefile b/graphics/gimp-manual-html/Makefile
new file mode 100644
index 000000000000..cc72f81d08c7
--- /dev/null
+++ b/graphics/gimp-manual-html/Makefile
@@ -0,0 +1,110 @@
+# New ports collection makefile for: gimp-manual-1.0.0
+# Version required: 1.0.0
+# Date created: 5 June 1998
+# Whom: Brett Taylor
+#
+# $Id$
+#
+
+DISTNAME= GimpUserManual-1.0.0
+CATEGORIES= graphics
+MASTER_SITES= ftp://manual.gimp.org/pub/manual/
+
+MAINTAINER= brett@peloton.physics.montana.edu
+
+MANUAL_PACKAGE_BUILD=\
+ "User must choose which version of the manual to install."
+
+.if !defined(DOCFORMAT)
+DOCFORMAT=HTML
+DOCFORMAT_UNSPECIFIED=YES
+.else
+.if ${DOCFORMAT} != "HTML" && ${DOCFORMAT} != "PDF" && ${DOCFORMAT} != "PS"
+DOCFORMAT_INVALID=YES
+.endif
+.endif
+
+pre-fetch:
+ @${ECHO} "This manual is available in three formats: HTML, PDF, and"
+ @${ECHO} "PS (PostScript). To choose the one you want, type:"
+ @${ECHO} " make DOCFORMAT={HTML,PDF,PS} [install]"
+ @${ECHO} "Also please note that the manual is pretty darn big."
+ @${ECHO} "The gzip'ed PS version is 44 MB (unpacks to 173 MB),"
+ @${ECHO} "the PDF version is 14 MB and the HTML tar-bzip'ed"
+ @${ECHO} "version is 16 MB (unpacks to 18.7 MB)."
+
+.if defined(DOCFORMAT_UNSPECIFIED)
+ @${ECHO} "(DOCFORMAT not specified: defaulting to HTML format.)"
+.elif defined(DOCFORMAT_INVALID)
+ @echo "ERROR: invalid value for DOCFORMAT: \"${DOCFORMAT}\""
+ @echo "Possible values are: HTML (default), PDF, PS."
+ @${FALSE}
+.endif
+
+.if ${DOCFORMAT} == "HTML"
+PKGNAME= GimpUserManual-HTML-1.0.0
+
+EXTRACT_SUFX= -html.tar.bz2
+WRKSRC= ${WRKDIR}/GimpUserManaul_v1.0.0
+
+BUILD_DEPENDS= bzip2:${PORTSDIR}/archivers/bzip2
+
+USE_X11= yes
+
+NO_BUILD= yes
+
+pre-extract:
+ @${CP} ${PKGDIR}/PLIST_${DOCFORMAT} ${PKGDIR}/PLIST
+
+EXTRACT_CMD= bzip2
+EXTRACT_BEFORE_ARGS= -cd
+EXTRACT_AFTER_ARGS= | tar -xf -
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/doc/gimp
+ @${CP} ${WRKSRC}/* ${PREFIX}/share/doc/gimp
+.endif
+
+.if ${DOCFORMAT} == "PDF"
+PKGNAME= GimpUserManual-PDF-1.0.0
+
+DISTFILES= GimpUserManual-1.0.0-pdf
+
+NO_EXTRACT= yes
+NO_BUILD= yes
+
+USE_X11= yes
+
+post-fetch:
+ @${MKDIR} ${WRKDIR}
+
+pre-install:
+ @${CP} ${PKGDIR}/PLIST_PDF ${PKGDIR}/PLIST
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/doc/gimp
+ @${CP} ${DISTDIR}/GimpUserManual-1.0.0-pdf ${PREFIX}/share/doc/gimp
+.endif
+
+.if ${DOCFORMAT} == "PS"
+DISTNAME= GimpUserManual-1.0.0-ps
+PKGNAME= GimpUserManual-PS-1.0.0
+
+EXTRACT_SUFX= .gz
+EXTRACT_CMD= ${GZIP_CMD}
+EXTRACT_BEFORE_ARGS= -cd
+EXTRACT_AFTER_ARGS= > ${DISTNAME}
+
+NO_BUILD= yes
+
+USE_X11= yes
+
+pre-extract:
+ @${CP} ${PKGDIR}/PLIST_PS ${PKGDIR}/PLIST
+
+do-install:
+ @${MKDIR} ${PREFIX}/share/doc/gimp
+ @${CP} ${WRKDIR}/GimpUserManual-1.0.0-ps ${PREFIX}/share/doc/gimp
+.endif
+
+.include <bsd.port.mk>