aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-pmosaic
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-02-24 02:45:55 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-02-24 02:45:55 +0000
commit8c578c7d6bd255093539d921c62989248847648c (patch)
tree5e9588653fc602f8cf1c2ad72386ad52c195a036 /graphics/gimp-pmosaic
parentb676dc68da42549c35db8876b1ef6386d4fb083c (diff)
downloadports-8c578c7d6bd255093539d921c62989248847648c.tar.gz
ports-8c578c7d6bd255093539d921c62989248847648c.zip
Notes
Diffstat (limited to 'graphics/gimp-pmosaic')
-rw-r--r--graphics/gimp-pmosaic/Makefile38
-rw-r--r--graphics/gimp-pmosaic/distinfo2
-rw-r--r--graphics/gimp-pmosaic/pkg-descr7
-rw-r--r--graphics/gimp-pmosaic/pkg-plist4
4 files changed, 51 insertions, 0 deletions
diff --git a/graphics/gimp-pmosaic/Makefile b/graphics/gimp-pmosaic/Makefile
new file mode 100644
index 000000000000..8bf6e3d4a06c
--- /dev/null
+++ b/graphics/gimp-pmosaic/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: gimp-pmosaic
+# Date created: 23 Feb 2004
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pmosaic
+PORTVERSION= 1.08
+CATEGORIES= graphics
+MASTER_SITES= http://www.kirchgessner.net/pub/gimp-1.2/
+PKGNAMEPREFIX= gimp-
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Photo/Image Mosaic plugin for gimp
+
+BUILD_DEPENDS= gimp-config:${PORTSDIR}/graphics/gimp1
+RUN_DEPENDS= gimp:${PORTSDIR}/graphics/gimp1
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_X_PREFIX= yes
+
+do-build:
+ cd ${WRKSRC}; ${CC} ${CFLAGS} -o pmosaic `gimp-config --cflags` \
+ pmsc.c pmosaic.c `gimp-config --libs` -ljpeg
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/pmosaic \
+ ${PREFIX}/libexec/gimp/1.2/plug-ins/
+ ${INSTALL_DATA} ${WRKSRC}/de/gimp-pmosaic.mo \
+ ${PREFIX}/share/locale/de/LC_MESSAGES/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-pmosaic/distinfo b/graphics/gimp-pmosaic/distinfo
new file mode 100644
index 000000000000..9c80158ae810
--- /dev/null
+++ b/graphics/gimp-pmosaic/distinfo
@@ -0,0 +1,2 @@
+MD5 (pmosaic.1.08.tar.gz) = 9e17b2630ce68b8079055b1d8a351b8f
+SIZE (pmosaic.1.08.tar.gz) = 57254
diff --git a/graphics/gimp-pmosaic/pkg-descr b/graphics/gimp-pmosaic/pkg-descr
new file mode 100644
index 000000000000..33f070a0bf9a
--- /dev/null
+++ b/graphics/gimp-pmosaic/pkg-descr
@@ -0,0 +1,7 @@
+The image/photo mosaic plug-in creates a image/photo mosaic (composition
+of multiple images) from an input image and an image archive.
+It also has the function to create the image archive.
+With GIMP menues, the plug-in is located at "Filters/Render/Image Mosaic".
+It's help-button should tell you how to use the plug-in.
+
+WWW: http://www.kirchgessner.net/photo-mosaic.html
diff --git a/graphics/gimp-pmosaic/pkg-plist b/graphics/gimp-pmosaic/pkg-plist
new file mode 100644
index 000000000000..c678e792d488
--- /dev/null
+++ b/graphics/gimp-pmosaic/pkg-plist
@@ -0,0 +1,4 @@
+libexec/gimp/1.2/plug-ins/pmosaic
+share/locale/de/LC_MESSAGES/gimp-pmosaic.mo
+%%DOCSDIR%%/README.TXT
+@dirrm %%DOCSDIR%%