aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-resynthesizer/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-06 16:29:43 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-06 16:29:43 +0000
commit457022d0285fdd0ecaeb5fd3ac57944d2cc6658b (patch)
treefd263ca273e81608abc9b03544f5c857d7e18330 /graphics/gimp-resynthesizer/Makefile
parent619336abdf11002aab0c85490943ce8d6e9df4c0 (diff)
Notes
Diffstat (limited to 'graphics/gimp-resynthesizer/Makefile')
-rw-r--r--graphics/gimp-resynthesizer/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
new file mode 100644
index 000000000000..681887973d1f
--- /dev/null
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: resynthesizer
+# Date created: 05 May 2010
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= resynthesizer
+PORTVERSION= 0.16
+CATEGORIES= graphics
+MASTER_SITES= http://www.logarithmic.net/pfh-files/resynthesizer/ \
+ http://mirror.amdmi3.ru/distfiles/
+PKGNAMEPREFIX= gimp-
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Gimp plug-in for texture synthesis
+
+LIB_DEPENDS= gimp-2.0:${PORTSDIR}/graphics/gimp-app
+
+GIMPTOOL?= gimptool-2.0
+PLUGINS_DIR?= libexec/gimp/2.2/plug-ins
+SCRIPTS_DIR?= share/gimp/scripts
+
+MAKE_JOBS_SAFE= yes
+PLIST_FILES= ${PLUGINS_DIR}/resynth \
+ ${SCRIPTS_DIR}/smart-enlarge.scm \
+ ${SCRIPTS_DIR}/smart-remove.scm
+
+do-build:
+ cd ${WRKSRC} && ${CXX} ${CXXFLAGS} \
+ `${GIMPTOOL} --cflags --libs` -o resynth resynth.cc
+
+do-install:
+ ${MKDIR} ${PREFIX}/${PLUGINS_DIR} ${PREFIX}/${SCRIPTS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/resynth ${PREFIX}/${PLUGINS_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/smart-enlarge.scm \
+ ${WRKSRC}/smart-remove.scm ${PREFIX}/${SCRIPTS_DIR}
+
+post-install:
+ @${ECHO_CMD}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
+
+.include <bsd.port.mk>