aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-resynthesizer/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-24 23:49:06 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-08-24 23:49:06 +0000
commitb9ce44537d8141c3baa9b7bdbd3248c6f4d961c7 (patch)
treeddcee0da182cd01bc1799b4aedf150311122fbc2 /graphics/gimp-resynthesizer/Makefile
parentc12684409a255a137011fc41496b040efb3252eb (diff)
downloadports-b9ce44537d8141c3baa9b7bdbd3248c6f4d961c7.tar.gz
ports-b9ce44537d8141c3baa9b7bdbd3248c6f4d961c7.zip
Notes
Diffstat (limited to 'graphics/gimp-resynthesizer/Makefile')
-rw-r--r--graphics/gimp-resynthesizer/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/gimp-resynthesizer/Makefile b/graphics/gimp-resynthesizer/Makefile
index 834b8c9bcbd6..88869a2672a7 100644
--- a/graphics/gimp-resynthesizer/Makefile
+++ b/graphics/gimp-resynthesizer/Makefile
@@ -2,9 +2,7 @@
# $FreeBSD$
PORTNAME= resynthesizer
-PORTVERSION= 2.0
-DISTVERSIONPREFIX= v
-PORTREVISION= 3
+PORTVERSION= 2.0.1
CATEGORIES= graphics
PKGNAMEPREFIX= gimp-
@@ -12,6 +10,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Gimp plug-in for texture synthesis
LICENSE= GPLv2+ # though COPYING has GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${LOCALBASE}/libexec/gimp/2.2/python/gimpfu.py:graphics/py-gimp
BUILD_DEPENDS= intltool-extract:textproc/intltool
@@ -20,10 +19,8 @@ LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
USE_GITHUB= yes
GH_ACCOUNT= bootchk
-USES= autoreconf compiler:nestedfct gettext gmake pkgconfig
+USES= autoreconf compiler:nestedfct gettext gmake localbase pkgconfig
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
PLUGIN_DIR?= libexec/gimp/2.2/plug-ins
PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
@@ -34,10 +31,10 @@ THREADS_LIBS= `pkg-config --libs gthread-2.0`
post-patch:
@${REINPLACE_CMD} -e 's|^\(GIMP_LIBDIR=\).*|\1"$${prefix}/${PLUGIN_DIR:H}"|; \
- s|^\(gimpplugindir=\).*|\1"$$GIMP_LIBDIR"|' ${WRKSRC}/configure.in
+ s|^\(gimpplugindir=\).*|\1"$$GIMP_LIBDIR"|' ${WRKSRC}/configure.ac
post-patch-THREADS-off:
@${REINPLACE_CMD} -e '/^#define SYNTH_THREADED/ d' \
- ${WRKSRC}/src/buildSwitches.h
+ ${WRKSRC}/lib/buildSwitches.h
.include <bsd.port.mk>