aboutsummaryrefslogtreecommitdiff
path: root/graphics/gimp-wavelet-denoise-plugin
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-04-07 23:56:01 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2014-04-07 23:56:01 +0000
commit69d281f306674f9348138c73e73e2078c4b2373b (patch)
tree7a1aa7cfe521cc0b5cbec9ddd27b24ff733e8de7 /graphics/gimp-wavelet-denoise-plugin
parent09c482df59a49146379d1ba8626f4572003a038c (diff)
downloadports-69d281f306674f9348138c73e73e2078c4b2373b.tar.gz
ports-69d281f306674f9348138c73e73e2078c4b2373b.zip
Notes
Diffstat (limited to 'graphics/gimp-wavelet-denoise-plugin')
-rw-r--r--graphics/gimp-wavelet-denoise-plugin/Makefile67
-rw-r--r--graphics/gimp-wavelet-denoise-plugin/distinfo2
-rw-r--r--graphics/gimp-wavelet-denoise-plugin/pkg-descr15
-rw-r--r--graphics/gimp-wavelet-denoise-plugin/pkg-plist20
4 files changed, 104 insertions, 0 deletions
diff --git a/graphics/gimp-wavelet-denoise-plugin/Makefile b/graphics/gimp-wavelet-denoise-plugin/Makefile
new file mode 100644
index 000000000000..4d41ee0a58da
--- /dev/null
+++ b/graphics/gimp-wavelet-denoise-plugin/Makefile
@@ -0,0 +1,67 @@
+# Created by: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wavelet-denoise
+PORTVERSION= 0.3.1
+CATEGORIES= graphics
+MASTER_SITES= http://registry.gimp.org/files/
+PKGNAMEPREFIX= gimp-
+PKGNAMESUFFIX= -plugin
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= GIMP plugin to reduce noise in each channel of an image separately
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gimp-2.0.pc:${PORTSDIR}/graphics/gimp-app
+
+OPTIONS_DEFINE= NLS OPTIMIZED_CFLAGS
+OPTIONS_DEFAULT= OPTIMIZED_CFLAGS
+OPTIONS_SUB= yes
+
+USES= gettext gmake
+
+PLIST_SUB= GIMP_PLUGIN_DIR=${GIMP_PLUGIN_DIR}
+GIMP_PLUGIN_DIR= libexec/gimp/2.2/plug-ins
+
+# l10n languages
+LANGUAGES= de et it pl ru
+
+.include <bsd.port.options.mk>
+
+# optimized CFLAGS
+.if ${PORT_OPTIONS:MOPTIMIZED_CFLAGS}
+CFLAGS+= -O3
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|gimptool-2.0|${LOCALBASE}/bin/gimptool-2.0|' \
+ ${WRKSRC}/src/Makefile
+#
+## l10n
+# disable l10n if appropriate
+.if ! ${PORT_OPTIONS:MNLS}
+ @${REINPLACE_CMD} -E \
+ -e 's|(^all:.*)po |\1|' \
+ ${WRKSRC}/Makefile
+.endif
+
+do-install:
+# plugin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${GIMP_PLUGIN_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/${GIMP_PLUGIN_DIR}
+#
+## l10n
+#
+.if ${PORT_OPTIONS:MNLS}
+.for language in ${LANGUAGES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/po/${language}.mo \
+ ${STAGEDIR}${PREFIX}/share/locale/${language}/LC_MESSAGES/gimp20-${PORTNAME}-plug-in.mo
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/gimp-wavelet-denoise-plugin/distinfo b/graphics/gimp-wavelet-denoise-plugin/distinfo
new file mode 100644
index 000000000000..cb0743f3d149
--- /dev/null
+++ b/graphics/gimp-wavelet-denoise-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (wavelet-denoise-0.3.1.tar.gz) = 430d6cf0a641656c251d11fe1635f8859836b0e784770024a41da3c33482383b
+SIZE (wavelet-denoise-0.3.1.tar.gz) = 27291
diff --git a/graphics/gimp-wavelet-denoise-plugin/pkg-descr b/graphics/gimp-wavelet-denoise-plugin/pkg-descr
new file mode 100644
index 000000000000..58ba99185c04
--- /dev/null
+++ b/graphics/gimp-wavelet-denoise-plugin/pkg-descr
@@ -0,0 +1,15 @@
+The wavelet denoise plugin is a tool to reduce noise in each channel
+of an image separately.
+
+The default colour space to do denoising is YCbCr which has the
+advantage that chroma noise can be reduced without affecting image
+details. Denoising in CIELAB (L*a*b*) or RGB is available as an
+option.
+
+The user interface allows colour mode and preview channel selection.
+The denoising threshold can be set for each colour channel
+independently.
+
+The plugin can be found under "Filters > Enhance > Wavelet denoise"
+
+WWW: http://registry.gimp.org/node/4235
diff --git a/graphics/gimp-wavelet-denoise-plugin/pkg-plist b/graphics/gimp-wavelet-denoise-plugin/pkg-plist
new file mode 100644
index 000000000000..51fc131c6434
--- /dev/null
+++ b/graphics/gimp-wavelet-denoise-plugin/pkg-plist
@@ -0,0 +1,20 @@
+%%GIMP_PLUGIN_DIR%%/wavelet-denoise
+%%NLS%%share/locale/de/LC_MESSAGES/gimp20-wavelet-denoise-plug-in.mo
+%%NLS%%share/locale/et/LC_MESSAGES/gimp20-wavelet-denoise-plug-in.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gimp20-wavelet-denoise-plug-in.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gimp20-wavelet-denoise-plug-in.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/gimp20-wavelet-denoise-plug-in.mo
+@dirrmtry %%GIMP_PLUGIN_DIR%%
+@dirrmtry libexec/gimp/2.2
+@dirrmtry libexec/gimp
+%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/de
+%%NLS%%@dirrmtry share/locale/et/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/et
+%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/it
+%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/pl
+%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ru
+%%NLS%%@dirrmtry share/locale