aboutsummaryrefslogtreecommitdiff
path: root/graphics/giram
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-23 06:19:44 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-23 06:19:44 +0000
commit2cdf2e1fe06651c2a7107e4b2943280e5337aeef (patch)
treec6dde3c03e117088a24d18865c72867b88eddce2 /graphics/giram
parent9330ed99d366634543b377255d7457a8a79b11c2 (diff)
downloadports-2cdf2e1fe06651c2a7107e4b2943280e5337aeef.tar.gz
ports-2cdf2e1fe06651c2a7107e4b2943280e5337aeef.zip
Notes
Diffstat (limited to 'graphics/giram')
-rw-r--r--graphics/giram/Makefile55
-rw-r--r--graphics/giram/distinfo2
-rw-r--r--graphics/giram/files/patch-aa19
-rw-r--r--graphics/giram/files/patch-ac11
-rw-r--r--graphics/giram/files/patch-configure44
-rw-r--r--graphics/giram/pkg-plist113
6 files changed, 126 insertions, 118 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index b4e6c1e74035..23a4c195e095 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -6,47 +6,38 @@
#
PORTNAME= giram
-PORTVERSION= 0.1.7
+PORTVERSION= 0.3.5
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.giram.org/pub/
-DISTNAME= Giram-${PORTVERSION}
+MASTER_SITES= http://www.giram.org/downloads/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Giram is Really A Modeller
+COMMENT= A POV-Ray oriented modeller
-RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray31
-
-USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
-USE_MESA= yes
+USE_PERL5_BUUID= yes
+USE_GNOME= gtk20
USE_GMAKE= yes
-USE_GNOME= gtk12
-WANT_GNOME= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-gl=${X11BASE}
+USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_GNOME:Mlibcapplet}!=""
-USE_GNOME+= libcapplet
-PKGNAMESUFFIX= -gnome
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ NTLTOOL_PERL="${PERL}"
+CONFIGURE_ARGS= --datadir="${PREFIX}/lib" \
+ --with-tutorial-path="${DOCSDIR}" \
+ --with-lib3ds-prefix="${LOCALBASE}"
+MAN1= giram.1
+
+.if defined(WITH_POVRAY31)
+BUILD_DEPENDS= povray:${PORTSDIR}/graphics/povray31
+RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray31
.else
-CONFIGURE_ARGS+=--disable-gnome
+BUILD_DEPENDS= povray:${PORTSDIR}/graphics/povray
+RUN_DEPENDS= povray:${PORTSDIR}/graphics/povray
.endif
-post-patch:
- @${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
- s|\$$(top_builddir)/intl/libintl.a|-lintl|g' \
- ${WRKSRC}/configure
-
post-install:
- @${MKDIR} ${PREFIX}/share/doc/giram/SampleScenes
- ${INSTALL_DATA} ${WRKSRC}/SampleScenes/* ${PREFIX}/share/doc/giram/SampleScenes/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.pov ${EXAMPLESDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/giram/distinfo b/graphics/giram/distinfo
index e6150ca35ab7..9b57f4d841c7 100644
--- a/graphics/giram/distinfo
+++ b/graphics/giram/distinfo
@@ -1 +1 @@
-MD5 (Giram-0.1.7.tar.bz2) = 040f278a1466953d0031e3f970ebed52
+MD5 (giram-0.3.5.tar.gz) = 1197134bd838669f202fc2f2f1b5da9b
diff --git a/graphics/giram/files/patch-aa b/graphics/giram/files/patch-aa
deleted file mode 100644
index 3a4d13537dc9..000000000000
--- a/graphics/giram/files/patch-aa
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/view.c.orig Tue Jul 11 20:34:10 2000
-+++ src/view.c Tue Jul 11 20:52:40 2000
-@@ -223,6 +223,7 @@
- {
- ViewUserDataStruct *UserData;
- FrameStruct *LocalFrame;
-+ int fd;
- char *TmpFileName;
- gchar *CommandLine;
-
-@@ -230,7 +231,7 @@
- strcpy(TmpFileName, "/tmp/GiramXXXXXX");
- UserData = get_view_user_data();
- LocalFrame = UserData->FrameView;
-- mktemp(TmpFileName);
-+ fd = mkstemp(TmpFileName);
- SavePovByName(LocalFrame, TmpFileName);
- CommandLine = g_strdup_printf("povfront -p -s %s &", TmpFileName);
- system(CommandLine);
diff --git a/graphics/giram/files/patch-ac b/graphics/giram/files/patch-ac
deleted file mode 100644
index cff3172ef611..000000000000
--- a/graphics/giram/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- docs/Makefile.in.orig Mon Mar 6 00:33:01 2000
-+++ docs/Makefile.in Mon Mar 6 00:35:17 2000
-@@ -88,7 +88,7 @@
- helpfilepath = @helpfilepath@
- l = @l@
-
--docsdir = @helpfilepath@
-+docsdir = @prefix@/share/doc/giram
-
- docs_DATA = Tutorial
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/graphics/giram/files/patch-configure b/graphics/giram/files/patch-configure
index 4b9ea7718e11..289774907d39 100644
--- a/graphics/giram/files/patch-configure
+++ b/graphics/giram/files/patch-configure
@@ -1,31 +1,19 @@
---- configure.orig Sun Jul 20 17:02:58 2003
-+++ configure Sun Jul 20 17:03:44 2003
-@@ -4152,7 +4152,6 @@
- #
- have_pthread=no
- mesa_requires_pthread=no
-- if test "$ac_have_mesa_gl" = yes; then
- echo $ac_n "checking for pthread_create in -lpthread""... $ac_c" 1>&6
- echo "configure:4158: checking for pthread_create in -lpthread" >&5
- ac_lib_var=`echo pthread'_'pthread_create | sed 'y%./+-%__p_%'`
-@@ -4240,12 +4239,7 @@
- LIBS="$ac_save_LIBS"
+--- configure.orig Sat Mar 8 21:30:47 2003
++++ configure Sun May 25 21:41:54 2003
+@@ -5432,6 +5432,7 @@
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+ +@@ -5843,7 +5844,7 @@
fi
--if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
-- echo "$ac_t""yes" 1>&6
- mesa_requires_pthread=yes
--else
-- echo "$ac_t""no" 1>&6
--fi
- CPPFLAGS="$ac_save_CPPFLAGS"
- LDFLAGS="$ac_save_LDFLAGS"
-@@ -4253,7 +4247,6 @@
- if test "$mesa_requires_pthread" = yes; then
- GL_LIBS="$GL_LIBS -lpthread"
- fi
-- fi
- # Check for OpenGL 1.1 features.
- #
-
+
+-CFLAGS="-g -Wall -DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED $CFLAGS"
++CFLAGS="-DGTK_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_DEPRECATED $CFLAGS"
+
+ if test -n "$DEBUGFLAG"; then
+ CFLAGS="$DEBUGFLAG $CFLAGS"
diff --git a/graphics/giram/pkg-plist b/graphics/giram/pkg-plist
index 59061c4bb511..10b1803f5d15 100644
--- a/graphics/giram/pkg-plist
+++ b/graphics/giram/pkg-plist
@@ -1,34 +1,93 @@
bin/giram
bin/povfront
+etc/giram/0.3/giramrc
+etc/giram/0.3/giramrc_user
+etc/giram/0.3/gtkrc
+etc/giram/0.3/gtkrc_user
+etc/giram/0.3/ps-menurc
+lib/giram/0.3/color/color1.gcf
+lib/giram/0.3/finish/finish1
+lib/giram/0.3/giram_logo.ppm
+lib/giram/0.3/giram_splash.ppm
+lib/giram/0.3/modules/librender_flat.so
+lib/giram/0.3/modules/librender_gouraud.so
+lib/giram/0.3/modules/librender_hiddenfaces.so
+lib/giram/0.3/modules/librender_povray.so
+lib/giram/0.3/modules/librender_raytracing.so
+lib/giram/0.3/modules/librender_wireframe.so
+lib/giram/0.3/normal/normal1
+lib/giram/0.3/pigment/pigment1
+lib/giram/0.3/shape/shape1
+lib/giram/0.3/texture/texture1
+lib/giram/0.3/tips/giram_conseils.fr.txt
+lib/giram/0.3/tips/giram_tips.txt
+lib/giram/0.3/user_install
libexec/giram/plug-ins/Box
libexec/giram/plug-ins/Rotate
libexec/giram/plug-ins/Spheres
-share/doc/giram/SampleScenes/Cone.pov
-share/doc/giram/SampleScenes/Disc.pov
-share/doc/giram/SampleScenes/Giram.gsf
-share/doc/giram/SampleScenes/Giram.pov
-share/doc/giram/SampleScenes/IntSphereBox1.pov
-share/doc/giram/SampleScenes/IntSphereBox2.pov
-share/doc/giram/SampleScenes/IntSphereBox3.pov
-share/doc/giram/SampleScenes/IntSpherePlane1.pov
-share/doc/giram/SampleScenes/IntSpherePlane2.pov
-share/doc/giram/SampleScenes/IntSpherePlane3.pov
-share/doc/giram/SampleScenes/Triangle.pov
-share/doc/giram/SampleScenes/basicvue.pov
-share/doc/giram/SampleScenes/basicvue2.pov
-share/doc/giram/SampleScenes/basicvue3.pov
-share/doc/giram/SampleScenes/basicvue4.pov
-share/doc/giram/SampleScenes/box.pov
-share/doc/giram/SampleScenes/lollipop.pov
-share/doc/giram/SampleScenes/superel1.pov
-share/doc/giram/SampleScenes/superel2.pov
-share/doc/giram/SampleScenes/superel3.pov
-share/doc/giram/SampleScenes/test.pov
-share/doc/giram/SampleScenes/torus.pov
-share/doc/giram/Tutorial
-share/locale/es/LC_MESSAGES/Giram.mo
-share/locale/fr/LC_MESSAGES/Giram.mo
-@dirrm share/doc/giram/SampleScenes
-@dirrm share/doc/giram
+%%DOCSDIR%%/Tutorial
+%%PORTDOCS%%%%EXAMPLESDIR%%/Cone.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Disc.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Giram.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Triangle.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue4.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/box.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/checker.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/lollipop.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/test.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/torus.pov
+share/locale/ca/LC_MESSAGES/giram.mo
+share/locale/cs/LC_MESSAGES/giram.mo
+share/locale/da/LC_MESSAGES/giram.mo
+share/locale/de/LC_MESSAGES/giram.mo
+share/locale/el/LC_MESSAGES/giram.mo
+share/locale/en_GB/LC_MESSAGES/giram.mo
+share/locale/es/LC_MESSAGES/giram.mo
+share/locale/fi/LC_MESSAGES/giram.mo
+share/locale/fr/LC_MESSAGES/giram.mo
+share/locale/ga/LC_MESSAGES/giram.mo
+share/locale/gl/LC_MESSAGES/giram.mo
+share/locale/hr/LC_MESSAGES/giram.mo
+share/locale/hu/LC_MESSAGES/giram.mo
+share/locale/it/LC_MESSAGES/giram.mo
+share/locale/ja/LC_MESSAGES/giram.mo
+share/locale/ko/LC_MESSAGES/giram.mo
+share/locale/nl/LC_MESSAGES/giram.mo
+share/locale/no/LC_MESSAGES/giram.mo
+share/locale/pl/LC_MESSAGES/giram.mo
+share/locale/pt_BR/LC_MESSAGES/giram.mo
+share/locale/ro/LC_MESSAGES/giram.mo
+share/locale/ru/LC_MESSAGES/giram.mo
+share/locale/sk/LC_MESSAGES/giram.mo
+share/locale/sv/LC_MESSAGES/giram.mo
+share/locale/tr/LC_MESSAGES/giram.mo
+share/locale/uk/LC_MESSAGES/giram.mo
+share/locale/zh_CN/LC_MESSAGES/giram.mo
+share/locale/zh_TW/LC_MESSAGES/giram.mo
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%
@dirrm libexec/giram/plug-ins
@dirrm libexec/giram
+@dirrm lib/giram/0.3/tips
+@dirrm lib/giram/0.3/texture
+@dirrm lib/giram/0.3/shape
+@dirrm lib/giram/0.3/pigment
+@dirrm lib/giram/0.3/normal
+@dirrm lib/giram/0.3/modules
+@dirrm lib/giram/0.3/finish
+@dirrm lib/giram/0.3/color_map
+@dirrm lib/giram/0.3/color
+@dirrm lib/giram/0.3
+@dirrm lib/giram