aboutsummaryrefslogtreecommitdiff
path: root/graphics/giram
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-27 09:02:53 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2004-10-27 09:02:53 +0000
commit15ae431f9380e198d89be039647e62d51d5b652b (patch)
treed5ed6acce7e8786c7bc5796266471017d82538d0 /graphics/giram
parent18f920d66d37df40ece1e000d3e6594823c714c6 (diff)
downloadports-15ae431f9380e198d89be039647e62d51d5b652b.tar.gz
ports-15ae431f9380e198d89be039647e62d51d5b652b.zip
Notes
Diffstat (limited to 'graphics/giram')
-rw-r--r--graphics/giram/Makefile47
-rw-r--r--graphics/giram/distinfo2
-rw-r--r--graphics/giram/files/patch-src+camera.c13
-rw-r--r--graphics/giram/files/patch-src+filetypes+povray+LoadPov.c42
-rw-r--r--graphics/giram/files/patch-src+filetypes+povray+SavePov.c10
-rw-r--r--graphics/giram/files/patch-src+giram.c12
-rw-r--r--graphics/giram/files/patch-src+giramobjecteditor.c14
-rw-r--r--graphics/giram/files/patch-src+texture.c15
-rw-r--r--graphics/giram/files/patch-src+view.c17
-rw-r--r--graphics/giram/files/patch-src+widgets+gtkcolorbutton.c16
-rw-r--r--graphics/giram/pkg-descr7
-rw-r--r--graphics/giram/pkg-plist101
12 files changed, 296 insertions, 0 deletions
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
new file mode 100644
index 000000000000..9cf57b08e056
--- /dev/null
+++ b/graphics/giram/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: giram
+# Date created: 17 June 1999
+# Whom: Brandon Fosdick <bfoz@glue.umd.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= giram
+PORTVERSION= 0.3.5
+PORTREVISION= 3
+CATEGORIES= graphics
+MASTER_SITES= http://www.giram.org/downloads/
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= A POV-Ray oriented modeller
+
+LIB_DEPENDS= 3ds.1:${PORTSDIR}/graphics/lib3ds
+
+USE_X_PREFIX= yes
+USE_PERL5_BUILD= yes
+USE_GNOME= gtk20
+USE_GMAKE= yes
+USE_LIBTOOL_VER=13
+LIBTOOLFLAGS= # none
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ INTLTOOL_PERL="${PERL}"
+CONFIGURE_ARGS= --datadir="${PREFIX}/lib" \
+ --with-tutorial-path="${DOCSDIR}" \
+ --with-lib3ds-prefix="${LOCALBASE}"
+MAN1= giram.1
+
+.if defined(WITH_POVRAY31)
+BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray31
+RUN_DEPENDS+= povray:${PORTSDIR}/graphics/povray31
+.else
+BUILD_DEPENDS+= povray:${PORTSDIR}/graphics/povray
+RUN_DEPENDS+= povray:${PORTSDIR}/graphics/povray
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/samples/*.pov ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/giram/distinfo b/graphics/giram/distinfo
new file mode 100644
index 000000000000..3fe5f7009d71
--- /dev/null
+++ b/graphics/giram/distinfo
@@ -0,0 +1,2 @@
+MD5 (giram-0.3.5.tar.gz) = 1197134bd838669f202fc2f2f1b5da9b
+SIZE (giram-0.3.5.tar.gz) = 1028404
diff --git a/graphics/giram/files/patch-src+camera.c b/graphics/giram/files/patch-src+camera.c
new file mode 100644
index 000000000000..0e5f8a62beb8
--- /dev/null
+++ b/graphics/giram/files/patch-src+camera.c
@@ -0,0 +1,13 @@
+--- src/camera.c.orig Fri Aug 9 18:19:56 2002
++++ src/camera.c Tue Oct 26 17:04:03 2004
+@@ -19,6 +19,10 @@
+
+ #include <stdlib.h>
+ #include <stdio.h>
++
++#undef GTK_DISABLE_DEPRECATED
++#warning GTK_DISABLE_DEPRECATED
++
+ #include <math.h>
+ #include "giram.h"
+ #include "utils.h"
diff --git a/graphics/giram/files/patch-src+filetypes+povray+LoadPov.c b/graphics/giram/files/patch-src+filetypes+povray+LoadPov.c
new file mode 100644
index 000000000000..92f8ab6cceaf
--- /dev/null
+++ b/graphics/giram/files/patch-src+filetypes+povray+LoadPov.c
@@ -0,0 +1,42 @@
+--- src/filetypes/povray/LoadPov.c.orig Mon Dec 23 18:06:14 2002
++++ src/filetypes/povray/LoadPov.c Tue Oct 26 17:04:03 2004
+@@ -1152,6 +1152,7 @@
+ break;
+ default:
+ /* panic!!! */
++ ;
+ }
+ get_token();
+ }
+@@ -3238,6 +3239,7 @@
+
+ default:
+ /*Error("Mis-matched '#case' or '#range'.");*/
++ ;
+ }
+ done = TRUE;
+ break;
+@@ -3303,6 +3305,7 @@
+
+ default:
+ /* Error("Mis-matched '#end'.");*/
++ ;
+ }
+ done = TRUE;
+ break;
+@@ -4965,6 +4968,7 @@
+ break;
+ default:
+ /* panic!!! */
++ ;
+ }
+ get_token();
+ }
+@@ -5111,6 +5115,7 @@
+ PARSE_FLOAT(HoleRadius)
+ break;
+ default: /* nothing */
++ ;
+ }
+
+ *pDisc = giram_disc_new(Center, Normal, Radius, HoleRadius);
diff --git a/graphics/giram/files/patch-src+filetypes+povray+SavePov.c b/graphics/giram/files/patch-src+filetypes+povray+SavePov.c
new file mode 100644
index 000000000000..b4ad20cb5fef
--- /dev/null
+++ b/graphics/giram/files/patch-src+filetypes+povray+SavePov.c
@@ -0,0 +1,10 @@
+--- src/filetypes/povray/SavePov.c.orig Fri Aug 9 18:17:09 2002
++++ src/filetypes/povray/SavePov.c Tue Oct 26 17:04:03 2004
+@@ -799,6 +799,7 @@
+
+ default:
+ /* panic */
++ ;
+ }
+ fprintf(OutFile, " location <%g, %g, %g>\n", Camera->Location[0],
+ Camera->Location[1],
diff --git a/graphics/giram/files/patch-src+giram.c b/graphics/giram/files/patch-src+giram.c
new file mode 100644
index 000000000000..493a74ec48fb
--- /dev/null
+++ b/graphics/giram/files/patch-src+giram.c
@@ -0,0 +1,12 @@
+--- src/giram.c.orig Sun Dec 29 02:49:03 2002
++++ src/giram.c Tue Oct 26 17:04:03 2004
+@@ -26,6 +26,9 @@
+ #include <sys/types.h>
+ #include <sys/wait.h>
+
++#undef GTK_DISABLE_DEPRECATED
++#warning GTK_DISABLE_DEPRECATED
++
+ #ifndef WAIT_ANY
+ #define WAIT_ANY (-1)
+ #endif /* WAIT_ANY */
diff --git a/graphics/giram/files/patch-src+giramobjecteditor.c b/graphics/giram/files/patch-src+giramobjecteditor.c
new file mode 100644
index 000000000000..c46a259ab019
--- /dev/null
+++ b/graphics/giram/files/patch-src+giramobjecteditor.c
@@ -0,0 +1,14 @@
+--- src/giramobjecteditor.c.orig Tue Jul 23 00:32:37 2002
++++ src/giramobjecteditor.c Tue Oct 26 17:04:03 2004
+@@ -19,10 +19,10 @@
+ */
+
+ #include <stdlib.h>
++#include "widgets/gtkcolorbutton.h"
+ #include "giram.h"
+
+ #include "giramintl.h"
+-#include "widgets/gtkcolorbutton.h"
+ #include "widgets/giramfileselection.h"
+
+ #include "widgets/giramvectorframe.h"
diff --git a/graphics/giram/files/patch-src+texture.c b/graphics/giram/files/patch-src+texture.c
new file mode 100644
index 000000000000..1bc0d04ed7f6
--- /dev/null
+++ b/graphics/giram/files/patch-src+texture.c
@@ -0,0 +1,15 @@
+--- src/texture.c.orig Tue Jul 9 02:02:23 2002
++++ src/texture.c Tue Oct 26 17:04:03 2004
+@@ -21,10 +21,10 @@
+ #include <string.h>
+ #undef GTK_DISABLE_DEPRECATED
+ #warning GTK_DISABLE_DEPRECATED
+-#include "giram.h"
+-#include "utils.h"
+ #include "widgets/gtkcolorbutton.h"
+ #include "widgets/gtkcolormapbutton.h"
++#include "giram.h"
++#include "utils.h"
+ #include "texture.h"
+
+ #include "widgets/giramwidgets.h"
diff --git a/graphics/giram/files/patch-src+view.c b/graphics/giram/files/patch-src+view.c
new file mode 100644
index 000000000000..721522ad08f3
--- /dev/null
+++ b/graphics/giram/files/patch-src+view.c
@@ -0,0 +1,17 @@
+--- src/view.c.orig Sat Aug 10 02:25:18 2002
++++ src/view.c Tue Oct 26 17:04:03 2004
+@@ -22,8 +22,13 @@
+ #include <unistd.h>
+ #include <math.h>
+ #include <string.h>
+-#include "giram.h"
++
++#undef GTK_DISABLE_DEPRECATED
++#warning GTK_DISABLE_DEPRECATED
++
+ #include <gdk/gdkkeysyms.h>
++#include <gtk/gtkitemfactory.h>
++#include "giram.h"
+
+ #include "tools/tools.h"
+ #include "tools/tool_select.h"
diff --git a/graphics/giram/files/patch-src+widgets+gtkcolorbutton.c b/graphics/giram/files/patch-src+widgets+gtkcolorbutton.c
new file mode 100644
index 000000000000..2440d49fafd2
--- /dev/null
+++ b/graphics/giram/files/patch-src+widgets+gtkcolorbutton.c
@@ -0,0 +1,16 @@
+--- src/widgets/gtkcolorbutton.c.orig Wed Jul 3 19:47:16 2002
++++ src/widgets/gtkcolorbutton.c Tue Oct 26 17:04:03 2004
+@@ -25,11 +25,11 @@
+ #undef GTK_DISABLE_DEPRECATED
+ #warning GTK_DISABLE_DEPRECATED
+
++#include "gtkcolorbutton.h"
++
+ #include "giram.h"
+
+ #include "giramintl.h"
+-
+-#include "gtkcolorbutton.h"
+
+ static void gtk_color_button_destroy(GtkObject *object);
+ static void gtk_color_button_clicked(GtkButton *button);
diff --git a/graphics/giram/pkg-descr b/graphics/giram/pkg-descr
new file mode 100644
index 000000000000..6581ca9ac639
--- /dev/null
+++ b/graphics/giram/pkg-descr
@@ -0,0 +1,7 @@
+Giram Is Really A Modeller.
+
+It is a Persistance Of Vision (POV-Ray) oriented modeller. But may become
+more of a general modeller in the future.
+
+Author: David Odin <David.Odin@bigfoot.com>
+WWW: http://www.giram.org/
diff --git a/graphics/giram/pkg-plist b/graphics/giram/pkg-plist
new file mode 100644
index 000000000000..3f801719c32e
--- /dev/null
+++ b/graphics/giram/pkg-plist
@@ -0,0 +1,101 @@
+bin/giram
+bin/povfront
+etc/giram/0.3/giramrc
+etc/giram/0.3/giramrc_user
+etc/giram/0.3/gtkrc
+etc/giram/0.3/gtkrc_user
+etc/giram/0.3/ps-menurc
+lib/giram/0.3/color/color1.gcf
+lib/giram/0.3/finish/finish1
+lib/giram/0.3/giram_logo.ppm
+lib/giram/0.3/giram_splash.ppm
+lib/giram/0.3/modules/librender_flat.la
+lib/giram/0.3/modules/librender_flat.so
+lib/giram/0.3/modules/librender_gouraud.la
+lib/giram/0.3/modules/librender_gouraud.so
+lib/giram/0.3/modules/librender_hiddenfaces.la
+lib/giram/0.3/modules/librender_hiddenfaces.so
+lib/giram/0.3/modules/librender_povray.la
+lib/giram/0.3/modules/librender_povray.so
+lib/giram/0.3/modules/librender_raytracing.la
+lib/giram/0.3/modules/librender_raytracing.so
+lib/giram/0.3/modules/librender_wireframe.la
+lib/giram/0.3/modules/librender_wireframe.so
+lib/giram/0.3/normal/normal1
+lib/giram/0.3/pigment/pigment1
+lib/giram/0.3/shape/shape1
+lib/giram/0.3/texture/texture1
+lib/giram/0.3/tips/giram_conseils.fr.txt
+lib/giram/0.3/tips/giram_tips.txt
+lib/giram/0.3/user_install
+libexec/giram/plug-ins/Box
+libexec/giram/plug-ins/Rotate
+libexec/giram/plug-ins/Spheres
+%%DOCSDIR%%/Tutorial
+%%PORTDOCS%%%%EXAMPLESDIR%%/Cone.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Disc.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Giram.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSphereBox3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/IntSpherePlane3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/Triangle.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/basicvue4.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/box.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/checker.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/lollipop.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel1.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel2.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/superel3.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/test.pov
+%%PORTDOCS%%%%EXAMPLESDIR%%/torus.pov
+share/locale/ca/LC_MESSAGES/giram.mo
+share/locale/cs/LC_MESSAGES/giram.mo
+share/locale/da/LC_MESSAGES/giram.mo
+share/locale/de/LC_MESSAGES/giram.mo
+share/locale/el/LC_MESSAGES/giram.mo
+share/locale/en_GB/LC_MESSAGES/giram.mo
+share/locale/es/LC_MESSAGES/giram.mo
+share/locale/fi/LC_MESSAGES/giram.mo
+share/locale/fr/LC_MESSAGES/giram.mo
+share/locale/ga/LC_MESSAGES/giram.mo
+share/locale/gl/LC_MESSAGES/giram.mo
+share/locale/hr/LC_MESSAGES/giram.mo
+share/locale/hu/LC_MESSAGES/giram.mo
+share/locale/it/LC_MESSAGES/giram.mo
+share/locale/ja/LC_MESSAGES/giram.mo
+share/locale/ko/LC_MESSAGES/giram.mo
+share/locale/nl/LC_MESSAGES/giram.mo
+share/locale/no/LC_MESSAGES/giram.mo
+share/locale/pl/LC_MESSAGES/giram.mo
+share/locale/pt_BR/LC_MESSAGES/giram.mo
+share/locale/ro/LC_MESSAGES/giram.mo
+share/locale/ru/LC_MESSAGES/giram.mo
+share/locale/sk/LC_MESSAGES/giram.mo
+share/locale/sv/LC_MESSAGES/giram.mo
+share/locale/tr/LC_MESSAGES/giram.mo
+share/locale/uk/LC_MESSAGES/giram.mo
+share/locale/zh_CN/LC_MESSAGES/giram.mo
+share/locale/zh_TW/LC_MESSAGES/giram.mo
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DOCSDIR%%
+@dirrm libexec/giram/plug-ins
+@dirrm libexec/giram
+@dirrm lib/giram/0.3/tips
+@dirrm lib/giram/0.3/texture
+@dirrm lib/giram/0.3/shape
+@dirrm lib/giram/0.3/pigment
+@dirrm lib/giram/0.3/normal
+@dirrm lib/giram/0.3/modules
+@dirrm lib/giram/0.3/finish
+@dirrm lib/giram/0.3/color_map
+@dirrm lib/giram/0.3/color
+@dirrm lib/giram/0.3
+@dirrm lib/giram
+@dirrm etc/giram/0.3
+@dirrm etc/giram