aboutsummaryrefslogtreecommitdiff
path: root/graphics/glew
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-01-21 16:57:02 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-01-21 16:57:02 +0000
commit3aaea2c0d1e813573782abebe9722b6bffe0418c (patch)
treef941bf5b7e93aa1aa7ac18fddf2c7cf85138aaca /graphics/glew
parent292b04093b78301f641f843f78e7c8433c2593cc (diff)
downloadports-3aaea2c0d1e813573782abebe9722b6bffe0418c.tar.gz
ports-3aaea2c0d1e813573782abebe9722b6bffe0418c.zip
Notes
Diffstat (limited to 'graphics/glew')
-rw-r--r--graphics/glew/files/patch-config_Makefile.freebsd9
1 files changed, 8 insertions, 1 deletions
diff --git a/graphics/glew/files/patch-config_Makefile.freebsd b/graphics/glew/files/patch-config_Makefile.freebsd
index 5192b66b8bc0..2ce5d93a5a39 100644
--- a/graphics/glew/files/patch-config_Makefile.freebsd
+++ b/graphics/glew/files/patch-config_Makefile.freebsd
@@ -3,7 +3,7 @@ $FreeBSD$
--- config/Makefile.freebsd.orig
+++ config/Makefile.freebsd
-@@ -1,15 +1,15 @@
+@@ -1,20 +1,20 @@
NAME = $(GLEW_NAME)
-CC = cc
-LD = ld
@@ -23,3 +23,10 @@ $FreeBSD$
NAME = GLEW
WARN = -Wall -W
POPT = -O2
+ BIN.SUFFIX =
+-LIB.SONAME = lib$(NAME).so.$(SO_MAJOR)
++LIB.SONAME = lib$(NAME).so.$(GLEW_MAJOR)
+ LIB.DEVLNK = lib$(NAME).so
+-LIB.SHARED = lib$(NAME).so.$(SO_VERSION)
++LIB.SHARED = lib$(NAME).so.$(GLEW_VERSION)
+ LIB.STATIC = lib$(NAME).a