aboutsummaryrefslogtreecommitdiff
path: root/graphics/glew
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-01-01 18:26:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-01-01 18:26:52 +0000
commit5952de42a03511c010f25b42706ae432b53ff713 (patch)
treec01a2efe163d9f81d219e8b39e93ef21707aa3cb /graphics/glew
parent2593bec07c41998c7b05f3be7e03cc59f2c074a1 (diff)
Add glew 1.1.4,
The goal of the OpenGL Extension Wrangler Library (GLEW) is to assist C/C++ OpenGL developers with two tedious tasks: initializing and using extensions and writing portable applications. GLEW provides an efficient run-time mechanism to determine whether a certain extension is supported by the driver or not. OpenGL core and extension functionality is exposed via a single header file. PR: 60717 Submitted by: Igor Pokrovsky <tiamat@comset.net>
Notes
Notes: svn path=/head/; revision=97041
Diffstat (limited to 'graphics/glew')
-rw-r--r--graphics/glew/Makefile42
-rw-r--r--graphics/glew/distinfo1
-rw-r--r--graphics/glew/files/patch-Makefile47
-rw-r--r--graphics/glew/pkg-descr11
-rw-r--r--graphics/glew/pkg-plist14
5 files changed, 115 insertions, 0 deletions
diff --git a/graphics/glew/Makefile b/graphics/glew/Makefile
new file mode 100644
index 000000000000..b08c2c51875e
--- /dev/null
+++ b/graphics/glew/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: glew
+# Date created: 29 Dec 2003
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glew
+PORTVERSION= 1.1.4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= -src.tgz
+
+MAINTAINER= tiamat@comset.net
+COMMENT= The OpenGL Extension Wrangler Library
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_GL= yes
+INSTALLS_SHLIB= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/glewinfo ${PREFIX}/bin
+
+ ${INSTALL_PROGRAM} ${WRKSRC}/lib/libGLEW.so.${PORTVERSION} \
+ ${PREFIX}/lib/libGLEW.so.1
+ @${LN} -sf ${PREFIX}/lib/libGLEW.so.1 ${PREFIX}/lib/libGLEW.so
+ ${INSTALL_DATA} ${WRKSRC}/lib/libGLEW.a ${PREFIX}/lib
+
+ ${INSTALL_DATA} ${WRKSRC}/include/GL/*.h ${PREFIX}/include/GL
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/glew.css ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/glew.png ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/glew/distinfo b/graphics/glew/distinfo
new file mode 100644
index 000000000000..da8df204b456
--- /dev/null
+++ b/graphics/glew/distinfo
@@ -0,0 +1 @@
+MD5 (glew-1.1.4-src.tgz) = 12ad1232a9031cb452222f38511f31cb
diff --git a/graphics/glew/files/patch-Makefile b/graphics/glew/files/patch-Makefile
new file mode 100644
index 000000000000..f87da6ab5f7c
--- /dev/null
+++ b/graphics/glew/files/patch-Makefile
@@ -0,0 +1,47 @@
+--- Makefile.orig Sun Dec 14 18:21:44 2003
++++ Makefile Wed Dec 31 06:25:49 2003
+@@ -83,6 +83,27 @@
+
+ else
+ # ----------------------------------------------------------------------------
++# FreeBSD
++# ----------------------------------------------------------------------------
++ifeq ($(patsubst FreeBSD%,FreeBSD,$(SYSTEM)), FreeBSD)
++NAME = GLEW
++CC ?= gcc
++LD ?= ld
++CFLAGS.EXTRA = -I${X11BASE}/include
++LDFLAGS.SO = -shared -soname $(LIB.SONAME)
++LDFLAGS.EXTRA = -L${X11BASE}/lib
++LDFLAGS.GL = -lXmu -lXi -lGLU -lGL -lXext -lX11
++GLEW_DEST = ${X11BASE}
++WARN = -Wall -W
++POPT = -O2
++BIN.SUFFIX =
++LIB.SONAME = lib$(NAME).so.$(GLEW_MAJOR)
++LIB.DEVLNK = lib$(NAME).so
++LIB.SHARED = lib$(NAME).so.$(GLEW_VERSION)
++LIB.STATIC = lib$(NAME).a
++
++else
++# ----------------------------------------------------------------------------
+ # Irix
+ # ----------------------------------------------------------------------------
+ ifeq ($(patsubst IRIX%,IRIX,$(SYSTEM)), IRIX)
+@@ -158,6 +179,7 @@
+ endif
+ endif
+ endif
++endif
+
+ AR = ar
+ INSTALL = install
+@@ -171,7 +193,7 @@
+ STRIP = -s
+ endif
+ INCLUDE = -Iinclude
+-CFLAGS = $(OPT) $(WARN) $(INCLUDE) $(CFLAGS.EXTRA)
++CFLAGS += $(OPT) $(WARN) $(INCLUDE) $(CFLAGS.EXTRA)
+
+ LIB.SRCS = src/glew.c
+ LIB.OBJS = $(LIB.SRCS:.c=.o)
diff --git a/graphics/glew/pkg-descr b/graphics/glew/pkg-descr
new file mode 100644
index 000000000000..e0bc429ca8c8
--- /dev/null
+++ b/graphics/glew/pkg-descr
@@ -0,0 +1,11 @@
+The goal of the OpenGL Extension Wrangler Library (GLEW) is to assist
+C/C++ OpenGL developers with two tedious tasks: initializing and using
+extensions and writing portable applications. GLEW provides an efficient
+run-time mechanism to determine whether a certain extension is supported
+by the driver or not. OpenGL core and extension functionality is exposed
+via a single header file.
+
+WWW: http://glew.sourceforge.net/
+
+- Igor Pokrovsky
+tiamat@comset.net
diff --git a/graphics/glew/pkg-plist b/graphics/glew/pkg-plist
new file mode 100644
index 000000000000..36a8c54c0a6e
--- /dev/null
+++ b/graphics/glew/pkg-plist
@@ -0,0 +1,14 @@
+bin/glewinfo
+include/GL/glew.h
+include/GL/glxew.h
+include/GL/wglew.h
+lib/libGLEW.a
+lib/libGLEW.so
+lib/libGLEW.so.1
+%%PORTDOCS%%%%DOCSDIR%%/glew.css
+%%PORTDOCS%%%%DOCSDIR%%/README.html
+%%PORTDOCS%%%%DOCSDIR%%/glew.html
+%%PORTDOCS%%%%DOCSDIR%%/glxew.html
+%%PORTDOCS%%%%DOCSDIR%%/wglew.html
+%%PORTDOCS%%%%DOCSDIR%%/glew.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%