aboutsummaryrefslogtreecommitdiff
path: root/graphics/glew
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2009-05-13 17:36:51 +0000
committerMarcus von Appen <mva@FreeBSD.org>2009-05-13 17:36:51 +0000
commitf4f49ff0b2ecbcd81a3071c75f802b47e174ffc6 (patch)
tree50808a823ed06cb188ceff365b4a347ddea157f8 /graphics/glew
parent54225f4577e7f38d76c618db47b8d52cea0747bb (diff)
downloadports-f4f49ff0b2ecbcd81a3071c75f802b47e174ffc6.tar.gz
ports-f4f49ff0b2ecbcd81a3071c75f802b47e174ffc6.zip
Notes
Diffstat (limited to 'graphics/glew')
-rw-r--r--graphics/glew/Makefile4
-rw-r--r--graphics/glew/files/patch-Makefile11
-rw-r--r--graphics/glew/files/patch-config_Makefile.freebsd9
-rw-r--r--graphics/glew/files/patch-include_GL_glew.h26
4 files changed, 22 insertions, 28 deletions
diff --git a/graphics/glew/Makefile b/graphics/glew/Makefile
index e370453f03b2..6bdf7b1ab0af 100644
--- a/graphics/glew/Makefile
+++ b/graphics/glew/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= glew
-PORTVERSION= 1.4.0
-PORTREVISION= 2
+PORTVERSION= 1.5.1
CATEGORIES= graphics
MASTER_SITES= SF
EXTRACT_SUFX= -src.tgz
@@ -19,6 +18,7 @@ USE_XORG= x11 xext xi xmu
USE_GMAKE= yes
USE_GL= yes
USE_LDCONFIG= yes
+USE_DOS2UNIX= config/config.guess config/Makefile.freebsd Makefile
WRKSRC= ${WRKDIR}/${PORTNAME}
do-install:
diff --git a/graphics/glew/files/patch-Makefile b/graphics/glew/files/patch-Makefile
index d05780aa1bbd..f17419f0e084 100644
--- a/graphics/glew/files/patch-Makefile
+++ b/graphics/glew/files/patch-Makefile
@@ -1,10 +1,7 @@
-
-$FreeBSD$
-
---- Makefile.orig
-+++ Makefile
-@@ -61,7 +61,7 @@
- STRIP = -s
+--- Makefile.orig 2008-11-03 07:25:21.000000000 +0100
++++ Makefile 2009-05-04 21:58:03.000000000 +0200
+@@ -59,7 +59,7 @@
+ OPT = $(POPT)
endif
INCLUDE = -Iinclude
-CFLAGS = $(OPT) $(WARN) $(INCLUDE) $(CFLAGS.EXTRA)
diff --git a/graphics/glew/files/patch-config_Makefile.freebsd b/graphics/glew/files/patch-config_Makefile.freebsd
index b765952f3362..ebea3a475c9c 100644
--- a/graphics/glew/files/patch-config_Makefile.freebsd
+++ b/graphics/glew/files/patch-config_Makefile.freebsd
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- config/Makefile.freebsd.orig
-+++ config/Makefile.freebsd
+--- config/Makefile.freebsd.orig 2008-11-03 07:25:19.000000000 +0100
++++ config/Makefile.freebsd 2009-05-04 22:03:30.000000000 +0200
@@ -1,20 +1,20 @@
NAME = $(GLEW_NAME)
-CC = cc
@@ -19,7 +16,7 @@ $FreeBSD$
LDFLAGS.STATIC = -Wl,-Bstatic
LDFLAGS.DYNAMIC = -Wl,-Bdynamic
-CFLAGS.EXTRA += -I/usr/X11R6/include
-+CFLAGS.EXTRA += -I${LOCALBASE}/include -fPIC
++CFLAGS.EXTRA += -I${LOCALBASE}/include
NAME = GLEW
WARN = -Wall -W
POPT = -O2
diff --git a/graphics/glew/files/patch-include_GL_glew.h b/graphics/glew/files/patch-include_GL_glew.h
index 3782f61049e8..6a971e2fa84c 100644
--- a/graphics/glew/files/patch-include_GL_glew.h
+++ b/graphics/glew/files/patch-include_GL_glew.h
@@ -1,13 +1,13 @@
---- include/GL/glew.h.orig
-+++ include/GL/glew.h
-@@ -9647,7 +9647,9 @@
- #ifdef GLEW_APIENTRY_DEFINED
- #undef GLEW_APIENTRY_DEFINED
- #undef APIENTRY
--#undef GLAPIENTRY
-+/* Do not undef GLAPIENTRY here. This is a quick hack to avoid
-+ undefined symbols when including glut.h just after glew.h */
-+/* #undef GLAPIENTRY */
- #endif
-
- #ifdef GLEW_CALLBACK_DEFINED
+--- include/GL/glew.h.orig 2008-11-03 07:25:21.000000000 +0100
++++ include/GL/glew.h 2009-05-04 21:55:35.000000000 +0200
+@@ -12243,7 +12243,9 @@
+ #ifdef GLEW_APIENTRY_DEFINED
+ #undef GLEW_APIENTRY_DEFINED
+ #undef APIENTRY
+-#undef GLAPIENTRY
++/* Do not undef GLAPIENTRY here. This is a quick hack to avoid
++ undefined symbols when including glut.h just after glew.h */
++/* #undef GLAPIENTRY */
+ #endif
+
+ #ifdef GLEW_CALLBACK_DEFINED