aboutsummaryrefslogtreecommitdiff
path: root/graphics/glexcess/Makefile
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-10-08 15:44:33 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-10-08 15:44:33 +0000
commitb0dd04d896815853ea5d1f2bf7a2b5a1bcce308a (patch)
treee8a6def4d36b5d1f06506763fbc890c6c2d6a512 /graphics/glexcess/Makefile
parent0c797fafbae33fd240a8901f10fb02c8eac13bfa (diff)
Notes
Diffstat (limited to 'graphics/glexcess/Makefile')
-rw-r--r--graphics/glexcess/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/glexcess/Makefile b/graphics/glexcess/Makefile
new file mode 100644
index 000000000000..29310f1221ed
--- /dev/null
+++ b/graphics/glexcess/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: glexcess
+# Date created: 1 September 2006
+# Whom: Hernan Di Pietro <hernan.di.pietro@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glexcess
+PORTVERSION= 1.0
+CATEGORIES= graphics
+MASTER_SITES= http://www.glexcess.com/files/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= hernan.di.pietro@gmail.com
+COMMENT= An impressive OpenGL Demo
+
+LIB_DEPENDS= glut:${PORTSDIR}/graphics/libglut
+
+USE_X_PREFIX= yes
+USE_GL= yes
+
+MAKE_ARGS= 'CXXFLAGS=${CXXFLAGS} -I${X11BASE}/include -pipe -s -O2' \
+ 'LDFLAGS=-L${X11BASE}/lib -lGL -lglut'
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|data/|${DATADIR}/|' ${WRKSRC}/scene*.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glxs ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/data/*.raw ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ReadMe.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>