aboutsummaryrefslogtreecommitdiff
path: root/graphics/glfw2
diff options
context:
space:
mode:
authorRusmir Dusko <nemysis@FreeBSD.org>2014-01-28 21:07:10 +0000
committerRusmir Dusko <nemysis@FreeBSD.org>2014-01-28 21:07:10 +0000
commit40d5080c5156f1563f56ebbfd853e733604563f8 (patch)
treedc03b56cf3cd20dc8287834a42a5f6fd9a3668de /graphics/glfw2
parent49686be75a35ee1d9868a2f1a53d72276578d3a3 (diff)
Notes
Diffstat (limited to 'graphics/glfw2')
-rw-r--r--graphics/glfw2/Makefile94
-rw-r--r--graphics/glfw2/distinfo2
-rw-r--r--graphics/glfw2/files/patch-lib__x11__Makefile.x11.in29
-rw-r--r--graphics/glfw2/pkg-descr6
4 files changed, 131 insertions, 0 deletions
diff --git a/graphics/glfw2/Makefile b/graphics/glfw2/Makefile
new file mode 100644
index 000000000000..15d167dc4cd7
--- /dev/null
+++ b/graphics/glfw2/Makefile
@@ -0,0 +1,94 @@
+# Created by: Igor Pokrovsky <tiamat@comset.net>
+# $FreeBSD$
+
+PORTNAME= glfw
+PORTVERSION= 2.7.9
+CATEGORIES= graphics
+MASTER_SITES= SF
+PKGNAMESUFFIX= 2
+
+MAINTAINER= nemysis@FreeBSD.org
+COMMENT= Portable framework for OpenGL development
+
+LICENSE= ZLIB
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_SCRIPT= compile.sh
+ALL_TARGET= x11
+INSTALL_TARGET= x11-install
+USE_XORG= xi xrandr
+USE_GL= glu
+USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+CFLAGS+= -w
+
+PLIST_FILES= include/GL/glfw.h \
+ lib/libglfw.a \
+ lib/libglfw.so \
+ lib/libglfw.so.0 \
+ libdata/pkgconfig/libglfw.pc
+
+PORTDOCS= *
+
+DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+DOCSRCDIR1= ${WRKSRC}
+DOC_FILES1= *.html
+
+DOCSRCDIR2= ${WRKSRC}/docs
+DOCSDIR2= ${DOCSDIR}/docs
+DOC_FILES2= *.pdf *.sty *.tex *.txt
+
+PORTEXAMPLES= *
+
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}${PKGNAMESUFFIX}
+
+EXAMPLESSRCDIR1= ${WRKSRC}/examples
+EXAMPLES_FILES1= boing gears heightmap listmodes mipmaps mtbench \
+ mthello pong3d splitview triangle wave
+
+EXAMPLESSRCDIR2= ${WRKSRC}/tests
+EXAMPLESDIR2= ${EXAMPLESDIR}/tests
+EXAMPLES_FILES2= accuracy defaults dynamic events fsaa fsinput iconify \
+ joysticks peter reopen tearing version
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+# Restrict to stable (even) versions, indicated by the second component.
+PORTSCOUT= limit:^2\..*
+
+post-extract:
+ @${CHMOD} ${BINMODE} ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|/usr/X11R6|${LOCALBASE}| ; \
+ /SOFLAGS/s|-soname |-Wl,-soname,| ; \
+ /CFLAGS_THREAD/s|"-pthread"|"${PTHREAD_CFLAGS}"| ; \
+ /LFLAGS_THREAD/s|"-pthread"|"${PTHREAD_LIBS}"|' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+ @${REINPLACE_CMD} \
+ -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
+ ${WRKSRC}/lib/x11/Makefile.x11.in
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/lib/x11/libglfw.so \
+ ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
+ ${LN} -sf ${PREFIX}/lib/libglfw.so.0 ${STAGEDIR}${PREFIX}/lib/libglfw.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libglfw.so.0
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR2}
+ ${INSTALL_DATA} ${DOC_FILES2:S|^|${DOCSRCDIR2}/|} ${STAGEDIR}${DOCSDIR2}
+
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES1:S|^|${EXAMPLESSRCDIR1}/|} \
+ ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLESSRCDIR1}/*.tga ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR2}
+ ${INSTALL_PROGRAM} ${EXAMPLES_FILES2:S|^|${EXAMPLESSRCDIR2}/|} \
+ ${STAGEDIR}${EXAMPLESDIR2}
+
+.include <bsd.port.mk>
diff --git a/graphics/glfw2/distinfo b/graphics/glfw2/distinfo
new file mode 100644
index 000000000000..dadf5d37140e
--- /dev/null
+++ b/graphics/glfw2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (glfw-2.7.9.tar.bz2) = d1f47e99e4962319f27f30d96571abcb04c1022c000de4d01df69ec59aae829d
+SIZE (glfw-2.7.9.tar.bz2) = 946924
diff --git a/graphics/glfw2/files/patch-lib__x11__Makefile.x11.in b/graphics/glfw2/files/patch-lib__x11__Makefile.x11.in
new file mode 100644
index 000000000000..1e31d02863a7
--- /dev/null
+++ b/graphics/glfw2/files/patch-lib__x11__Makefile.x11.in
@@ -0,0 +1,29 @@
+--- ./lib/x11/Makefile.x11.in.orig 2013-05-30 16:07:32.000000000 +0200
++++ ./lib/x11/Makefile.x11.in 2013-09-30 12:46:48.994429398 +0200
+@@ -26,19 +26,19 @@
+ # Install GLFW static library
+ ##########################################################################
+ install: libglfw.a libglfw.pc
+- $(INSTALL) -d $(PREFIX)/lib
+- $(INSTALL) -c -m 644 libglfw.a $(PREFIX)/lib/libglfw.a
+- $(INSTALL) -d $(PREFIX)/include/GL
+- $(INSTALL) -c -m 644 ../../include/GL/glfw.h $(PREFIX)/include/GL/glfw.h
+- $(INSTALL) -d $(PREFIX)/lib/pkgconfig
+- $(INSTALL) -c -m 644 libglfw.pc $(PREFIX)/lib/pkgconfig/libglfw.pc
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/lib
++ $(INSTALL) -c -m 644 libglfw.a $(DESTDIR)$(PREFIX)/lib/libglfw.a
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/include/GL
++ $(INSTALL) -c -m 644 ../../include/GL/glfw.h $(DESTDIR)$(PREFIX)/include/GL/glfw.h
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/lib/pkgconfig
++ $(INSTALL) -c -m 644 libglfw.pc $(DESTDIR)$(PREFIX)/lib/pkgconfig/libglfw.pc
+
+
+ ##########################################################################
+ # Install GLFW static and shared libraries
+ ##########################################################################
+ dist-install: libglfw.so install
+- $(INSTALL) -c -m 644 libglfw.so $(PREFIX)/lib/libglfw.so
++ $(INSTALL) -c -m 644 libglfw.so $(DESTDIR)$(PREFIX)/lib/libglfw.so
+
+
+ ##########################################################################
diff --git a/graphics/glfw2/pkg-descr b/graphics/glfw2/pkg-descr
new file mode 100644
index 000000000000..a411cc447c5e
--- /dev/null
+++ b/graphics/glfw2/pkg-descr
@@ -0,0 +1,6 @@
+GLFW is a free, Open Source, multi-platform library for OpenGL application
+development that provides a powerful API for handling operating system specific
+tasks such as opening an OpenGL window, reading keyboard, mouse, joystick and
+time input, creating threads, and more.
+
+WWW: http://www.glfw.org/