aboutsummaryrefslogtreecommitdiff
path: root/graphics/gmt/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-02-12 22:37:12 +0000
committerJohn Marino <marino@FreeBSD.org>2014-02-12 22:37:12 +0000
commit8284953b8e009b515d6033c2efa66b212f6569ca (patch)
treeaeece40a1079b08e0ad47bcf0deecf73b920beaa /graphics/gmt/Makefile
parente88cc5c043739010dcd947e0dae99b6d726aa7bd (diff)
downloadports-8284953b8e009b515d6033c2efa66b212f6569ca.tar.gz
ports-8284953b8e009b515d6033c2efa66b212f6569ca.zip
Notes
Diffstat (limited to 'graphics/gmt/Makefile')
-rw-r--r--graphics/gmt/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/graphics/gmt/Makefile b/graphics/gmt/Makefile
index e9ff736a90d5..9e51ca89b0ed 100644
--- a/graphics/gmt/Makefile
+++ b/graphics/gmt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gmt
-PORTVERSION= 4.5.9
+PORTVERSION= 4.5.11
CATEGORIES= graphics
MASTER_SITES= ftp://ftp.soest.hawaii.edu/%SUBDIR%/ \
ftp://ftp.geologi.uio.no/pub/%SUBDIR%/ \
@@ -11,15 +11,12 @@ MASTER_SITES= ftp://ftp.soest.hawaii.edu/%SUBDIR%/ \
http://gd.tuwien.ac.at/graphics/visual/%SUBDIR%/ \
http://gmt.mirror.ac.za/pub/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${GSHHG_DISTNAME}${EXTRACT_SUFX}
+DISTFILES= ${DISTNAME}-src${EXTRACT_SUFX} \
+ ${GSHHG_DISTNAME}.tar.gz
MAINTAINER= ports@FreeBSD.org
COMMENT= Generic Mapping Tools - data processing and display software package
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2014-03-10
-
LICENSE= GPLv2 LGPL3
LICENSE_COMB= multi
LICENSE_DISTFILES_GPLv2= ${DISTNAME}${EXTRACT_SUFX}
@@ -37,8 +34,6 @@ IMPERIAL_DESC= Choose Imperial (inch) units over metric (cm)
GDAL_DESC= Compile in experimental GDAL support
OCTAVE_DESC= Build GMT-octave interface
-WRKSRC= ${WRKDIR}/${PORTNAME:U}${DISTVERSION}
-
USE_BZIP2= yes
USES= gmake shebangfix
SHEBANG_FILES= gmtswitch
@@ -53,7 +48,7 @@ PORTDOCS= *
DEBUG_CONFIGURE_ON= --enable-debug --enable-devdebug
SHARED_CONFIGURE_ON= --enable-shared
IMPERIAL_CONFIGURE_ON= --enable-US
-EPS_CONFNIGURE_ON= --enable-eps
+EPS_CONFIGURE_ON= --enable-eps
GDAL_LIB_DEPENDS= libgdal.so:${PORTSDIR}/graphics/gdal
GDAL_CONFIGURE_ON= --enable-gdal
OCTAVE_RUN_DEPENDS= octave:${PORTSDIR}/math/octave
@@ -75,7 +70,7 @@ STRIP_FILES= blockmean blockmedian blockmode filter1d fitcircle \
psxy psxyz sample1d spectrum1d splitxyz \
surface trend1d trend2d triangulate xyz2grd
-GSHHG_DISTNAME= gshhg-gmt-nc3-2.2.2
+GSHHG_DISTNAME= gshhg-gmt-2.3.0
.include <bsd.port.options.mk>