aboutsummaryrefslogtreecommitdiff
path: root/graphics/gnash-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-29 11:09:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-29 11:09:15 +0000
commitb7f4e6832d71a21b2c8fb0c6514fe5863bcb4185 (patch)
tree1b381844b353cf3c2289efb64460527eea087677 /graphics/gnash-devel
parent808deb28b31c268e87df35e2d348754504573da4 (diff)
downloadports-b7f4e6832d71a21b2c8fb0c6514fe5863bcb4185.tar.gz
ports-b7f4e6832d71a21b2c8fb0c6514fe5863bcb4185.zip
Notes
Diffstat (limited to 'graphics/gnash-devel')
-rw-r--r--graphics/gnash-devel/Makefile21
-rw-r--r--graphics/gnash-devel/distinfo6
-rw-r--r--graphics/gnash-devel/pkg-plist18
3 files changed, 31 insertions, 14 deletions
diff --git a/graphics/gnash-devel/Makefile b/graphics/gnash-devel/Makefile
index 6dc84d33a287..3f795646fceb 100644
--- a/graphics/gnash-devel/Makefile
+++ b/graphics/gnash-devel/Makefile
@@ -6,10 +6,12 @@
#
PORTNAME= gnash
-PORTVERSION= 0.8.2
+DISTVERSION= 20080515
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= ${PORTNAME}/${PORTVERSION}
+# gnashdev.org is slower
+MASTER_SITES= http://www.amdmi3.ru/distfiles/ \
+ http://www.gnashdev.org/dev_snapshots/
+PKGNAMESUFFIX= -devel
MAINTAINER= amdmi3@amdmi3.ru
COMMENT= GNU Flash movie player
@@ -18,17 +20,18 @@ LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost \
jpeg.9:${PORTSDIR}/graphics/jpeg \
curl.4:${PORTSDIR}/ftp/curl
-CONFLICTS= gnash-devel-[0-9]*
+CONFLICTS= gnash-[0-9]*
-USE_BZIP2= yes
+EXTRACT_SUFX= .tar.tgz
USE_GMAKE= yes
GNU_CONFIGURE= yes
WANT_SDL= yes
WANT_GNOME= yes
+USE_GCC= 4.2+
WANT_GSTREAMER= yes
USE_GNOME= pkgconfig libxml2
USE_XORG= x11 xau xdmcp xext xi xinerama ice sm
-USE_AUTOTOOLS= libltdl:15
+USE_AUTOTOOLS= libltdl:15 automake:19:env autoheader:261:env autoconf:261:env aclocal:19:env libtool:15:env
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -40,6 +43,8 @@ CONFIGURE_ARGS= --with-boost-incl="${LOCALBASE}/include" \
--with-npapi-plugindir="${PREFIX}/lib/browser_plugins" \
--with-kde-pluginprefix="${PREFIX}"
+WRKSRC= ${WRKDIR}/${PORTNAME}-0.8.3
+
USE_LDCONFIG= ${PREFIX}/lib/gnash
MAN1= cygnal.1 gnash.1 gprocessor.1 soldumper.1 dumpshm.1
@@ -165,12 +170,14 @@ pre-everything::
@sleep 3
.endif
-post-patch:
+pre-configure:
+ @(cd ${WRKSRC}; ${SETENV} ${SCRIPTS_ENV} ${SH} ./autogen.sh)
@${REINPLACE_CMD} -e 's|^LIBS = |&$${INTLLIBS} |' \
${WRKSRC}/utilities/Makefile.in ${WRKSRC}/cygnal/Makefile.in
@${REINPLACE_CMD} -e '/^PTHREAD_[LC][IF]*=/ d' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; \
s|/usr/X11R6|${LOCALBASE}|g' ${WRKSRC}/configure \
+ s|/lib64|/lib|g; \
${WRKSRC}/macros/libslist ${WRKSRC}/macros/incllist
.if !defined(WITHOUT_PLUGIN)
diff --git a/graphics/gnash-devel/distinfo b/graphics/gnash-devel/distinfo
index 509eef638dc2..db552c423a47 100644
--- a/graphics/gnash-devel/distinfo
+++ b/graphics/gnash-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnash-0.8.2.tar.bz2) = 05cac831181be3fb40cbf3c00ab25c0f
-SHA256 (gnash-0.8.2.tar.bz2) = 4c81e71e6619b79da9641a90ed2c73c362603103bcdcc7b9cc5cc53739d06baa
-SIZE (gnash-0.8.2.tar.bz2) = 2637636
+MD5 (gnash-20080515.tar.tgz) = dfa5293481120dda51473d5974cb6bee
+SHA256 (gnash-20080515.tar.tgz) = b1e9a6bdf45e154e095c6c98ab822e9014d1c822d0841166ec39681d77b7c6eb
+SIZE (gnash-20080515.tar.tgz) = 3666406
diff --git a/graphics/gnash-devel/pkg-plist b/graphics/gnash-devel/pkg-plist
index 992a8659bc75..8bc032c84217 100644
--- a/graphics/gnash-devel/pkg-plist
+++ b/graphics/gnash-devel/pkg-plist
@@ -12,22 +12,32 @@ bin/soldumper
%%KONQPLUGIN%%lib/kde3/libklashpart.a
%%KONQPLUGIN%%lib/kde3/libklashpart.so
%%KONQPLUGIN%%lib/kde3/libklashpart.la
-lib/gnash/libgnashamf-0.8.2.so
+etc/gnashpluginrc
+etc/gnashrc
+lib/gnash/libgnashamf-0.8.3.so
lib/gnash/libgnashamf.a
lib/gnash/libgnashamf.la
lib/gnash/libgnashamf.so
-lib/gnash/libgnashbase-0.8.2.so
+lib/gnash/libgnashbase-0.8.3.so
lib/gnash/libgnashbase.a
lib/gnash/libgnashbase.la
lib/gnash/libgnashbase.so
-lib/gnash/libgnashmedia-0.8.2.so
+lib/gnash/libgnashmedia-0.8.3.so
lib/gnash/libgnashmedia.a
lib/gnash/libgnashmedia.la
lib/gnash/libgnashmedia.so
-lib/gnash/libgnashserver-0.8.2.so
+lib/gnash/libgnashnet.a
+lib/gnash/libgnashnet.la
+lib/gnash/libgnashnet.so
+lib/gnash/libgnashnet.so.0
+lib/gnash/libgnashserver-0.8.3.so
lib/gnash/libgnashserver.a
lib/gnash/libgnashserver.la
lib/gnash/libgnashserver.so
+%%FFPLUGIN%%lib/gnash/libmozsdk.a
+%%FFPLUGIN%%lib/gnash/libmozsdk.la
+%%FFPLUGIN%%lib/gnash/libmozsdk.so
+%%FFPLUGIN%%lib/gnash/libmozsdk.so.0
%%DOCSDIR%%/gnashuser.html
%%DOCSDIR%%/images/car_crash.png
%%DOCSDIR%%/images/rtmp.png